summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION107
-rw-r--r--php-pecl-grpc.spec10
3 files changed, 76 insertions, 46 deletions
diff --git a/PHPINFO b/PHPINFO
index 40b4b89..5e37577 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,11 @@
grpc
grpc support => enabled
-grpc module version => 1.25.0
+grpc module version => 1.26.0RC1
Directive => Local Value => Master Value
grpc.enable_fork_support => 0 => 0
grpc.poll_strategy => no value => no value
+grpc.grpc_verbosity => no value => no value
+grpc.grpc_trace => no value => no value
+grpc.log_filename => no value => no value
diff --git a/REFLECTION b/REFLECTION
index 12b96a4..199bcb5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #200 grpc version 1.25.0 ] {
+Extension [ <persistent> extension #189 grpc version 1.26.0RC1 ] {
- INI {
Entry [ grpc.enable_fork_support <SYSTEM> ]
@@ -7,50 +7,59 @@ Extension [ <persistent> extension #200 grpc version 1.25.0 ] {
Entry [ grpc.poll_strategy <SYSTEM> ]
Current = ''
}
+ Entry [ grpc.grpc_verbosity <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ grpc.grpc_trace <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ grpc.log_filename <SYSTEM> ]
+ Current = ''
+ }
}
- Constants [41] {
- Constant [ integer Grpc\CALL_OK ] { 0 }
- Constant [ integer Grpc\CALL_ERROR ] { 1 }
- Constant [ integer Grpc\CALL_ERROR_NOT_ON_SERVER ] { 2 }
- Constant [ integer Grpc\CALL_ERROR_NOT_ON_CLIENT ] { 3 }
- Constant [ integer Grpc\CALL_ERROR_ALREADY_INVOKED ] { 5 }
- Constant [ integer Grpc\CALL_ERROR_NOT_INVOKED ] { 6 }
- Constant [ integer Grpc\CALL_ERROR_ALREADY_FINISHED ] { 7 }
- Constant [ integer Grpc\CALL_ERROR_TOO_MANY_OPERATIONS ] { 8 }
- Constant [ integer Grpc\CALL_ERROR_INVALID_FLAGS ] { 9 }
- Constant [ integer Grpc\WRITE_BUFFER_HINT ] { 1 }
- Constant [ integer Grpc\WRITE_NO_COMPRESS ] { 2 }
- Constant [ integer Grpc\STATUS_OK ] { 0 }
- Constant [ integer Grpc\STATUS_CANCELLED ] { 1 }
- Constant [ integer Grpc\STATUS_UNKNOWN ] { 2 }
- Constant [ integer Grpc\STATUS_INVALID_ARGUMENT ] { 3 }
- Constant [ integer Grpc\STATUS_DEADLINE_EXCEEDED ] { 4 }
- Constant [ integer Grpc\STATUS_NOT_FOUND ] { 5 }
- Constant [ integer Grpc\STATUS_ALREADY_EXISTS ] { 6 }
- Constant [ integer Grpc\STATUS_PERMISSION_DENIED ] { 7 }
- Constant [ integer Grpc\STATUS_UNAUTHENTICATED ] { 16 }
- Constant [ integer Grpc\STATUS_RESOURCE_EXHAUSTED ] { 8 }
- Constant [ integer Grpc\STATUS_FAILED_PRECONDITION ] { 9 }
- Constant [ integer Grpc\STATUS_ABORTED ] { 10 }
- Constant [ integer Grpc\STATUS_OUT_OF_RANGE ] { 11 }
- Constant [ integer Grpc\STATUS_UNIMPLEMENTED ] { 12 }
- Constant [ integer Grpc\STATUS_INTERNAL ] { 13 }
- Constant [ integer Grpc\STATUS_UNAVAILABLE ] { 14 }
- Constant [ integer Grpc\STATUS_DATA_LOSS ] { 15 }
- Constant [ integer Grpc\OP_SEND_INITIAL_METADATA ] { 0 }
- Constant [ integer Grpc\OP_SEND_MESSAGE ] { 1 }
- Constant [ integer Grpc\OP_SEND_CLOSE_FROM_CLIENT ] { 2 }
- Constant [ integer Grpc\OP_SEND_STATUS_FROM_SERVER ] { 3 }
- Constant [ integer Grpc\OP_RECV_INITIAL_METADATA ] { 4 }
- Constant [ integer Grpc\OP_RECV_MESSAGE ] { 5 }
- Constant [ integer Grpc\OP_RECV_STATUS_ON_CLIENT ] { 6 }
- Constant [ integer Grpc\OP_RECV_CLOSE_ON_SERVER ] { 7 }
- Constant [ integer Grpc\CHANNEL_IDLE ] { 0 }
- Constant [ integer Grpc\CHANNEL_CONNECTING ] { 1 }
- Constant [ integer Grpc\CHANNEL_READY ] { 2 }
- Constant [ integer Grpc\CHANNEL_TRANSIENT_FAILURE ] { 3 }
- Constant [ integer Grpc\CHANNEL_FATAL_FAILURE ] { 4 }
+ Constant [ int Grpc\CALL_OK ] { 0 }
+ Constant [ int Grpc\CALL_ERROR ] { 1 }
+ Constant [ int Grpc\CALL_ERROR_NOT_ON_SERVER ] { 2 }
+ Constant [ int Grpc\CALL_ERROR_NOT_ON_CLIENT ] { 3 }
+ Constant [ int Grpc\CALL_ERROR_ALREADY_INVOKED ] { 5 }
+ Constant [ int Grpc\CALL_ERROR_NOT_INVOKED ] { 6 }
+ Constant [ int Grpc\CALL_ERROR_ALREADY_FINISHED ] { 7 }
+ Constant [ int Grpc\CALL_ERROR_TOO_MANY_OPERATIONS ] { 8 }
+ Constant [ int Grpc\CALL_ERROR_INVALID_FLAGS ] { 9 }
+ Constant [ int Grpc\WRITE_BUFFER_HINT ] { 1 }
+ Constant [ int Grpc\WRITE_NO_COMPRESS ] { 2 }
+ Constant [ int Grpc\STATUS_OK ] { 0 }
+ Constant [ int Grpc\STATUS_CANCELLED ] { 1 }
+ Constant [ int Grpc\STATUS_UNKNOWN ] { 2 }
+ Constant [ int Grpc\STATUS_INVALID_ARGUMENT ] { 3 }
+ Constant [ int Grpc\STATUS_DEADLINE_EXCEEDED ] { 4 }
+ Constant [ int Grpc\STATUS_NOT_FOUND ] { 5 }
+ Constant [ int Grpc\STATUS_ALREADY_EXISTS ] { 6 }
+ Constant [ int Grpc\STATUS_PERMISSION_DENIED ] { 7 }
+ Constant [ int Grpc\STATUS_UNAUTHENTICATED ] { 16 }
+ Constant [ int Grpc\STATUS_RESOURCE_EXHAUSTED ] { 8 }
+ Constant [ int Grpc\STATUS_FAILED_PRECONDITION ] { 9 }
+ Constant [ int Grpc\STATUS_ABORTED ] { 10 }
+ Constant [ int Grpc\STATUS_OUT_OF_RANGE ] { 11 }
+ Constant [ int Grpc\STATUS_UNIMPLEMENTED ] { 12 }
+ Constant [ int Grpc\STATUS_INTERNAL ] { 13 }
+ Constant [ int Grpc\STATUS_UNAVAILABLE ] { 14 }
+ Constant [ int Grpc\STATUS_DATA_LOSS ] { 15 }
+ Constant [ int Grpc\OP_SEND_INITIAL_METADATA ] { 0 }
+ Constant [ int Grpc\OP_SEND_MESSAGE ] { 1 }
+ Constant [ int Grpc\OP_SEND_CLOSE_FROM_CLIENT ] { 2 }
+ Constant [ int Grpc\OP_SEND_STATUS_FROM_SERVER ] { 3 }
+ Constant [ int Grpc\OP_RECV_INITIAL_METADATA ] { 4 }
+ Constant [ int Grpc\OP_RECV_MESSAGE ] { 5 }
+ Constant [ int Grpc\OP_RECV_STATUS_ON_CLIENT ] { 6 }
+ Constant [ int Grpc\OP_RECV_CLOSE_ON_SERVER ] { 7 }
+ Constant [ int Grpc\CHANNEL_IDLE ] { 0 }
+ Constant [ int Grpc\CHANNEL_CONNECTING ] { 1 }
+ Constant [ int Grpc\CHANNEL_READY ] { 2 }
+ Constant [ int Grpc\CHANNEL_TRANSIENT_FAILURE ] { 3 }
+ Constant [ int Grpc\CHANNEL_FATAL_FAILURE ] { 4 }
}
- Classes [7] {
@@ -302,7 +311,7 @@ Extension [ <persistent> extension #200 grpc version 1.25.0 ] {
- Static properties [0] {
}
- - Static methods [5] {
+ - Static methods [7] {
Method [ <internal:grpc> static public method setDefaultRootsPem ] {
- Parameters [1] {
@@ -310,6 +319,18 @@ Extension [ <persistent> extension #200 grpc version 1.25.0 ] {
}
}
+ Method [ <internal:grpc> static public method isDefaultRootsPemSet ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:grpc> static public method invalidateDefaultRootsPem ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:grpc> static public method createDefault ] {
- Parameters [0] {
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index 1bd93b0..9e6e69f 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -24,8 +24,8 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 1.25.0
-#global upstream_prever RC1
+%global upstream_version 1.26.0
+%global upstream_prever RC1
Summary: General RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
@@ -130,6 +130,9 @@ extension=%{pecl_name}.so
; Configuration
;grpc.enable_fork_support = 0
;grpc.poll_strategy = ''
+;grpc.grpc_verbosity = ''
+;grpc.grpc_trace = ''
+;grpc.log_filename = ''
EOF
@@ -231,6 +234,9 @@ cd ../ZTS
%changelog
+* Fri Dec 6 2019 Remi Collet <remi@remirepo.net> - 1.26.0~RC1-1
+- Update to 1.26.0RC1
+
* Thu Nov 7 2019 Remi Collet <remi@remirepo.net> - 1.25.0-1
- Update to 1.25.0