summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--grpc-build.patch8
-rw-r--r--php-pecl-grpc.spec7
4 files changed, 11 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index cd9ce77..d4f9357 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
grpc
grpc support => enabled
-grpc module version => 1.13.0
+grpc module version => 1.14.1
diff --git a/REFLECTION b/REFLECTION
index 2b57f4c..9efe67d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #197 grpc version 1.13.0 ] {
+Extension [ <persistent> extension #197 grpc version 1.14.1 ] {
- Constants [41] {
Constant [ integer Grpc\CALL_OK ] { 0 }
diff --git a/grpc-build.patch b/grpc-build.patch
index 3317c74..f212fc0 100644
--- a/grpc-build.patch
+++ b/grpc-build.patch
@@ -5,10 +5,10 @@ diff -up ./config.m4.rpm ./config.m4
LIBS="-lpthread $LIBS"
-- CFLAGS="-Wall -Werror -Wno-parentheses-equality -Wno-unused-value -std=c11 -g -O2 -D PB_FIELD_16BIT=1"
-- CXXFLAGS="-std=c++11 -fno-exceptions -fno-rtti -g -O2 -D PB_FIELD_16BIT=1"
-+ CFLAGS="$CFLAGS -std=c11 -D PB_FIELD_16BIT=1"
-+ CXXFLAGS="$CXXFLAGS -std=c++11 -fno-exceptions -fno-rtti -D PB_FIELD_16BIT=1"
+- CFLAGS="-Wall -Werror -Wno-parentheses-equality -Wno-unused-value -std=c11 -g -O2 -D PB_FIELD_32BIT=1"
+- CXXFLAGS="-std=c++11 -fno-exceptions -fno-rtti -g -O2 -D PB_FIELD_32BIT=1"
++ CFLAGS="$CFLAGS -std=c11 -D PB_FIELD_32BIT=1"
++ CXXFLAGS="$CXXFLAGS -std=c++11 -fno-exceptions -fno-rtti -D PB_FIELD_32BIT=1"
GRPC_SHARED_LIBADD="-lpthread $GRPC_SHARED_LIBADD"
PHP_REQUIRE_CXX()
PHP_ADD_LIBRARY(pthread)
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index 9c07a45..2029360 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -24,13 +24,13 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 1.13.0
+%global upstream_version 1.14.1
#global upstream_prever RC3
Summary: General RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -227,6 +227,9 @@ cd ../ZTS
%changelog
+* Fri Aug 10 2018 Remi Collet <remi@remirepo.net> - 1.14.1-1
+- update to 1.14.1
+
* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 1.13.0-2
- rebuld for 7.3.0alpha4 new ABI