summaryrefslogtreecommitdiffstats
path: root/php-pecl-gmagick.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-gmagick.spec')
-rw-r--r--php-pecl-gmagick.spec19
1 files changed, 13 insertions, 6 deletions
diff --git a/php-pecl-gmagick.spec b/php-pecl-gmagick.spec
index ac07630..04ffa7e 100644
--- a/php-pecl-gmagick.spec
+++ b/php-pecl-gmagick.spec
@@ -12,6 +12,8 @@
%scl_package php-pecl-gmagick
%endif
+%bcond_without tests
+
%global pecl_name gmagick
%global prever RC1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -23,15 +25,13 @@
Summary: Provides a wrapper to the GraphicsMagick library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
Source1: https://raw.githubusercontent.com/rlerdorf/gmagick/master/tests/skipif.inc
Patch0: https://patch-diff.githubusercontent.com/raw/vitoc/gmagick/pull/50.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/rlerdorf/gmagick/pull/1.patch
-Patch2: https://patch-diff.githubusercontent.com/raw/rlerdorf/gmagick/pull/2.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -87,8 +87,6 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
%patch0 -p1 -b .pr50
-%patch1 -p1 -b .pr1
-%patch2 -p1 -b .pr2
cp %{SOURCE1} tests/skipif.inc
extver=$(sed -n '/#define PHP_GMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_gmagick.h)
@@ -169,6 +167,8 @@ fi
%check
+export OMP_NUM_THREADS=1
+
rm ?TS/tests/gmagick-056-set_getsamplingfactors.phpt
%if 0%{?fedora} == 31 || 0%{?rhel} == 8
@@ -188,12 +188,14 @@ cd NTS
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: upstream test suite for NTS extension
export TEST_PHP_EXECUTABLE=%{__php}
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
%{__php} -n run-tests.php --show-diff
+%endif
%if %{with_zts}
: simple module load test for ZTS extension
@@ -202,11 +204,13 @@ cd ../ZTS
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: upstream test suite for ZTS extension
export TEST_PHP_EXECUTABLE=%{__ztsphp}
export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
%{__ztsphp} -n run-tests.php --show-diff
%endif
+%endif
%files
@@ -224,7 +228,10 @@ export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
%changelog
-* Wed Feb 19 2020 Remi Collet <remi@remirepo.net> - 2.0.5~RC1-8
+* Wed Jan 27 2021 Remi Collet <remi@remirepo.net> - 2.0.5~RC1-9
+- refresh PHP 8 patch
+
+* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 2.0.5~RC1-8
- add patch for PHP 8 from
https://github.com/vitoc/gmagick/pull/50
- add build fixes from