summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gmagick-const.patch12
-rw-r--r--gmagick-pr42.patch30
-rw-r--r--php-pecl-gmagick-php7.spec2
3 files changed, 31 insertions, 13 deletions
diff --git a/gmagick-const.patch b/gmagick-const.patch
deleted file mode 100644
index 792b15e..0000000
--- a/gmagick-const.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/gmagick_helpers.c b/gmagick_helpers.c
-index 88aab56..5e9d578 100644
---- a/gmagick_helpers.c
-+++ b/gmagick_helpers.c
-@@ -185,6 +185,7 @@ void php_gmagick_initialize_constants()
- GMAGICK_REGISTER_CONST_LONG("COMPRESSION_JBIG2", JBIG2Compression);
- #endif
-
-+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_NO", NoInterlace); //Don't interlace image (RGBRGBRGBRGBRGBRGB...)
- GMAGICK_REGISTER_CONST_LONG("INTERLACE_NONE", NoInterlace); //Don't interlace image (RGBRGBRGBRGBRGBRGB...)
- GMAGICK_REGISTER_CONST_LONG("INTERLACE_LINE", LineInterlace); //Use scanline interlacing (RRR...GGG...BBB...RRR...GGG...BBB...)
- GMAGICK_REGISTER_CONST_LONG("INTERLACE_PLANE", PlaneInterlace);//Use plane interlacing (RRRRRR...GGGGGG...BBBBBB...)
diff --git a/gmagick-pr42.patch b/gmagick-pr42.patch
new file mode 100644
index 0000000..d8abd9b
--- /dev/null
+++ b/gmagick-pr42.patch
@@ -0,0 +1,30 @@
+From e927cddb40786cbc4a27645e095f8f1da6cb8e6c Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Sun, 26 Jun 2016 17:08:05 +0200
+Subject: [PATCH] fix BC, re-add INTERLACE_NO
+
+---
+ gmagick_helpers.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/gmagick_helpers.c b/gmagick_helpers.c
+index 88aab56..4cc4893 100644
+--- a/gmagick_helpers.c
++++ b/gmagick_helpers.c
+@@ -185,6 +185,8 @@ void php_gmagick_initialize_constants()
+ GMAGICK_REGISTER_CONST_LONG("COMPRESSION_JBIG2", JBIG2Compression);
+ #endif
+
++ GMAGICK_REGISTER_CONST_LONG("INTERLACE_UNDEFINED", UndefinedInterlace);
++ GMAGICK_REGISTER_CONST_LONG("INTERLACE_NO", NoInterlace); //Don't interlace image (RGBRGBRGBRGBRGBRGB...)
+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_NONE", NoInterlace); //Don't interlace image (RGBRGBRGBRGBRGBRGB...)
+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_LINE", LineInterlace); //Use scanline interlacing (RRR...GGG...BBB...RRR...GGG...BBB...)
+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_PLANE", PlaneInterlace);//Use plane interlacing (RRRRRR...GGGGGG...BBBBBB...)
+@@ -340,7 +342,6 @@ void php_gmagick_initialize_constants()
+ GMAGICK_REGISTER_CONST_LONG("RENDERINGINTENT_PERCEPTUAL", PerceptualIntent);
+ GMAGICK_REGISTER_CONST_LONG("RENDERINGINTENT_ABSOLUTE", AbsoluteIntent);
+ GMAGICK_REGISTER_CONST_LONG("RENDERINGINTENT_RELATIVE", RelativeIntent);
+- GMAGICK_REGISTER_CONST_LONG("INTERLACE_UNDEFINED", UndefinedInterlace);
+ GMAGICK_REGISTER_CONST_LONG("FILLRULE_UNDEFINED", UndefinedRule);
+ GMAGICK_REGISTER_CONST_LONG("FILLRULE_EVENODD", EvenOddRule);
+ GMAGICK_REGISTER_CONST_LONG("FILLRULE_NONZERO", NonZeroRule);
diff --git a/php-pecl-gmagick-php7.spec b/php-pecl-gmagick-php7.spec
index 1e23c80..f338020 100644
--- a/php-pecl-gmagick-php7.spec
+++ b/php-pecl-gmagick-php7.spec
@@ -28,7 +28,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
# restore dropped constant by mistake
# see https://github.com/vitoc/gmagick/pull/41#issuecomment-228584703
-Patch0: %{pecl_name}-const.patch
+Patch0: %{pecl_name}-pr42.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-pear