summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-28 17:33:09 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-28 17:33:09 +0100
commit99990d767acbaaeef73c9ee424a773262d13e05f (patch)
treecdcf0e6fecb510322b5d5fc2865f61215354b4f9
parent85a61a85a260f34a52440e9f773cddc0deb62589 (diff)
php-pecl-gmagick 1.1.2RC1
-rw-r--r--gmagick-tests.patch32
-rw-r--r--gmagick.patch12
-rw-r--r--php-pecl-gmagick.spec27
-rw-r--r--px.c20
4 files changed, 15 insertions, 76 deletions
diff --git a/gmagick-tests.patch b/gmagick-tests.patch
deleted file mode 100644
index 280ff67..0000000
--- a/gmagick-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- tests.orig/gmagick-054-getquantumdepth.phpt 2012-01-23 08:06:35.694766376 +0100
-+++ tests/gmagick-054-getquantumdepth.phpt 2012-01-23 08:17:58.499797061 +0100
-@@ -9,11 +9,22 @@
- <?php
- $gm = new Gmagick();
- $gm->read("magick:rose");
--print_r($gm->getQuantumDepth());
-+$q=$gm->getQuantumDepth();
-+if (is_array($q) && count($q)==2 && isset($q['quantumDepthLong']) && isset($q['quantumDepthString'])) {
-+ echo "Struct OK\n";
-+ if ($q['quantumDepthLong']=='8' && $q['quantumDepthString']=='Q8') {
-+ echo "Quantum OK\n";
-+ } else if ($q['quantumDepthLong']=='16' && $q['quantumDepthString']=='Q16') {
-+ echo "Quantum OK\n";
-+ } else {
-+ echo "Quantum KO\n";
-+ print_r($q);
-+ }
-+} else {
-+ echo "Struct KO\n";
-+ print_r($q);
-+}
- ?>
- --EXPECTF--
--Array
--(
-- [quantumDepthLong] => 8
-- [quantumDepthString] => Q8
--)
-\ Pas de fin de ligne à la fin du fichier
-+Struct OK
-+Quantum OK
diff --git a/gmagick.patch b/gmagick.patch
deleted file mode 100644
index 391efda..0000000
--- a/gmagick.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up gmagick-1.1.0RC2/gmagickpixel_methods.c.orig gmagick-1.1.0RC2/gmagickpixel_methods.c
---- gmagick-1.1.0RC2/gmagickpixel_methods.c.orig 2012-01-21 07:42:13.727957934 +0100
-+++ gmagick-1.1.0RC2/gmagickpixel_methods.c 2012-01-21 07:43:09.328959265 +0100
-@@ -82,7 +82,7 @@ PHP_METHOD(gmagickpixel, getcolor)
- zend_bool as_array = 0, normalise_array = 0;
-
- /* Parse parameters given to function */
-- if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "|b", &as_array, &normalise_array) == FAILURE) {
-+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "|bb", &as_array, &normalise_array) == FAILURE) {
- return;
- }
-
diff --git a/php-pecl-gmagick.spec b/php-pecl-gmagick.spec
index be77aaa..bc7d457 100644
--- a/php-pecl-gmagick.spec
+++ b/php-pecl-gmagick.spec
@@ -5,16 +5,13 @@
Summary: Provides a wrapper to the GraphicsMagick library
Name: php-pecl-%{pecl_name}
-Version: 1.1.1
+Version: 1.1.2
Release: 0.1.%{prever}%{?dist}
License: PHP
Group: Development/Libraries
URL: http://pecl.php.net/package/gmagick
Source0: http://pecl.php.net/get/gmagick-%{version}%{?prever}.tgz
-# https://bugs.php.net/60829 getColor don't accept second option
-Patch0: gmagick.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
BuildRequires: php-pear >= 1.4.7
BuildRequires: php-devel >= 5.1.3, GraphicsMagick-devel >= 1.2.6
@@ -24,16 +21,22 @@ Requires(postun): %{__pecl}
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
-Provides: php-pecl(%{pecl_name}) = %{version}%{?prever}
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
Conflicts: php-pecl-imagick
Conflicts: php-magickwand
# Other third party repo stuff
-Obsoletes: php53-pecl-gmagick
-Obsoletes: php53u-pecl-gmagick
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
%if "%{php_version}" > "5.4"
-Obsoletes: php54-pecl-gmagick
+Obsoletes: php54-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.5"
+Obsoletes: php55-pecl-%{pecl_name}
%endif
# Filter private shared
@@ -50,7 +53,6 @@ of images using the GraphicsMagick API.
%setup -qc
cd %{pecl_name}-%{version}%{?prever}
-%patch0 -p1 -b .options
%if 0%{?fedora} <= 15 && 0%{?rhel} <= 6
# Remove know to fail tests (GM font config issue)
@@ -58,9 +60,6 @@ cd %{pecl_name}-%{version}%{?prever}
rm -f tests/gmagick-006-annotateimage.phpt
%endif
-# Fix version
-sed -e '/PHP_GMAGICK_VERSION/s/1.1.0RC3/%{version}%{?prever}/' -i php_gmagick.h
-
# Check extension version
extver=$(sed -n '/#define PHP_GMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_gmagick.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -171,6 +170,10 @@ fi
%changelog
+* Fri Dec 28 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.1.2-0.1.RC1
+- Update to 1.1.2RC1
+- also provides php-gmagick
+
* Wed Sep 12 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.1.1-0.1.RC1
- Update to 1.1.1RC1
diff --git a/px.c b/px.c
deleted file mode 100644
index 2c20418..0000000
--- a/px.c
+++ /dev/null
@@ -1,20 +0,0 @@
-#include <stdio.h>
-#include <wand/wand_api.h>
-
-int main(int argc, char *argv[])
-{
- PixelWand *pix;
- char *str;
- char *col[] = {"rgb(0,0,0)", "rgb(80,80,80)", "rgb(255,255,255)", "rgb(999,999,999)", NULL};
- int i;
-
- pix = NewPixelWand();
- for (i=0 ; col[i] ; i++)
- {
- PixelSetColor(pix, col[i]);
- str = PixelGetColorAsString(pix);
- printf("%s = rgb(%s)\n", col[i], str);
- }
- DestroyPixelWand(pix);
- return 0;
-}