summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-12-14 18:33:20 +0100
committerRemi Collet <fedora@famillecollet.com>2013-12-14 18:33:20 +0100
commit3e7e0f5d8a7b270d40e670a09b620fb493b8dc91 (patch)
treecf97ceafa508d950588152a5d79031c1d640efd6
parent659e7edd95ac0d70043996d6bc91a34eaead52a0 (diff)
php-pecl-gmagick: 1.1.6RC2 (beta)
-rw-r--r--gmagick-svn.patch79
-rw-r--r--php-pecl-gmagick.spec14
2 files changed, 5 insertions, 88 deletions
diff --git a/gmagick-svn.patch b/gmagick-svn.patch
deleted file mode 100644
index 7de88f9..0000000
--- a/gmagick-svn.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-Index: gmagick.c
-===================================================================
---- gmagick.c (révision 332363)
-+++ gmagick.c (copie de travail)
-@@ -1082,7 +1082,7 @@
- ZEND_ARG_INFO(0, miterLimit)
- ZEND_END_ARG_INFO()
-
--#if GMAGICK_LIB_MASK >= 1004000
-+#if GMAGICK_LIB_MASK >= 1003000
- ZEND_BEGIN_ARG_INFO_EX(gmagickdraw_setstrokedasharray_args, 0, 0, 1)
- ZEND_ARG_INFO(0, dashArray)
- ZEND_END_ARG_INFO()
-@@ -1137,7 +1137,7 @@
- PHP_ME(gmagickdraw, getstrokelinecap, gmagick_empty_args, ZEND_ACC_PUBLIC)
- PHP_ME(gmagickdraw, getstrokelinejoin, gmagick_empty_args, ZEND_ACC_PUBLIC)
- PHP_ME(gmagickdraw, getstrokemiterlimit, gmagick_empty_args, ZEND_ACC_PUBLIC)
--#if GMAGICK_LIB_MASK >= 1004000
-+#if GMAGICK_LIB_MASK >= 1003000
- PHP_ME(gmagickdraw, getstrokedasharray, gmagick_empty_args, ZEND_ACC_PUBLIC)
- PHP_ME(gmagickdraw, setstrokedasharray, gmagickdraw_setstrokedasharray_args, ZEND_ACC_PUBLIC)
- #endif
-Index: gmagick_helpers.c
-===================================================================
---- gmagick_helpers.c (révision 332363)
-+++ gmagick_helpers.c (copie de travail)
-@@ -632,7 +632,8 @@
- return NULL;
- }
-
-- double_array = (double *)emalloc(sizeof(double) * elements);
-+ /* Number of elements + 1 for final 0 */
-+ double_array = (double *)emalloc(sizeof(double) * (elements+1));
-
- for (zend_hash_internal_pointer_reset(Z_ARRVAL_P(param_array));
- zend_hash_get_current_data(Z_ARRVAL_P(param_array), (void **) &ppzval) == SUCCESS;
-@@ -648,6 +649,6 @@
- double_array[i] = Z_DVAL_P(tmp_pzval);
- tmp_pzval = NULL;
- }
-- *num_elements = elements;
-+ double_array[elements] = 0.0;
- return double_array;
--}
-\ Pas de retour chariot à la fin du fichier
-+}
-Index: gmagickdraw_methods.c
-===================================================================
---- gmagickdraw_methods.c (révision 332363)
-+++ gmagickdraw_methods.c (copie de travail)
-@@ -1098,7 +1098,7 @@
- /* }}} */
-
-
--#if GMAGICK_LIB_MASK >= 1004000
-+#if GMAGICK_LIB_MASK >= 1003000
- /* {{{ proto array GmagickDraw::getStrokeDashArray()
- Returns an array representing the pattern of dashes and gaps used to stroke paths (see DrawSetStrokeDashArray). The array must be freed once it is no longer required by the user.
- */
-@@ -1157,4 +1157,4 @@
- RETURN_TRUE;
- }
- /* }}} */
--#endif
-\ Pas de retour chariot à la fin du fichier
-+#endif
-Index: php_gmagick.h
-===================================================================
---- php_gmagick.h (révision 332363)
-+++ php_gmagick.h (copie de travail)
-@@ -335,7 +335,7 @@
- PHP_METHOD(gmagickdraw, getstrokelinecap);
- PHP_METHOD(gmagickdraw, getstrokelinejoin);
- PHP_METHOD(gmagickdraw, getstrokemiterlimit);
--#if GMAGICK_LIB_MASK >= 1004000
-+#if GMAGICK_LIB_MASK >= 1003000
- PHP_METHOD(gmagickdraw, setstrokedasharray);
- PHP_METHOD(gmagickdraw, getstrokedasharray);
- #endif
diff --git a/php-pecl-gmagick.spec b/php-pecl-gmagick.spec
index cba8509..704afaa 100644
--- a/php-pecl-gmagick.spec
+++ b/php-pecl-gmagick.spec
@@ -4,21 +4,18 @@
%{!?__php: %global __php %{_bindir}/php}
%global pecl_name gmagick
-%global prever RC1
+%global prever RC2
%global with_zts 0%{?__ztsphp:1}
Summary: Provides a wrapper to the GraphicsMagick library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.1.6
-Release: 0.1.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.2.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Libraries
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# http://svn.php.net/viewvc?view=revision&revision=332364
-Patch0: %{pecl_name}-svn.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-devel
@@ -66,10 +63,6 @@ of images using the GraphicsMagick API.
mv %{pecl_name}-%{version}%{?prever} NTS
-pushd NTS
-%patch0 -p0 -b .svn
-popd
-
# Don't install any font (and test using it)
sed -e '/\.ttf"/d' \
-e '/gmagickdraw-008-setfont_getfont.phpt/d' \
@@ -199,6 +192,9 @@ export TEST_PHP_EXECUTABLE=%{__ztsphp}
%changelog
+* Sat Dec 14 2013 Remi Collet <remi@fedoraproject.org> - 1.1.6-0.2.RC1
+- Update to 1.1.6RC2 (beta)
+
* Sat Dec 14 2013 Remi Collet <remi@fedoraproject.org> - 1.1.6-0.1.RC1
- Update to 1.1.6RC1 (beta)
- adapt for SCL