summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--42.patch36
-rw-r--r--php-pecl-fann.spec5
2 files changed, 39 insertions, 2 deletions
diff --git a/42.patch b/42.patch
index c9686bb..9d20a9a 100644
--- a/42.patch
+++ b/42.patch
@@ -1,7 +1,7 @@
From 23c34676e88ed6aef5fc6b6484a65abb554aa11a Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Tue, 25 Aug 2020 10:51:51 +0200
-Subject: [PATCH] adapt for PHP 8 and missing arginfo
+Subject: [PATCH 1/2] adapt for PHP 8 and missing arginfo
---
fann.c | 7 ++-----
@@ -71,3 +71,37 @@ index 3197a67..7008c04 100644
PHP_FANN_CONN_PROP_NAME(__name), (__value) TSRMLS_CC)
#define PHP_FANN_CONN_PROP_DECLARE(__type, __name) \
zend_declare_property_##__type(php_fann_FANNConnection_class, PHP_FANN_CONN_PROP_NAME(__name), \
+
+From f7bfc3d254d24f35462d03ccce19597bae593d38 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 2 Sep 2020 09:39:38 +0200
+Subject: [PATCH 2/2] fix for 8.0.0beta3
+
+---
+ fann.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/fann.c b/fann.c
+index a5c2e68..68dd96b 100644
+--- a/fann.c
++++ b/fann.c
+@@ -1618,7 +1618,8 @@ PHP_FUNCTION(fann_destroy)
+ return;
+ }
+
+- RETURN_BOOL(PHPC_RES_CLOSE(z_ann) == SUCCESS);
++ PHPC_RES_CLOSE(z_ann);
++ RETURN_TRUE;
+ }
+ /* }}} */
+
+@@ -2242,7 +2243,8 @@ PHP_FUNCTION(fann_destroy_train)
+ return;
+ }
+
+- RETURN_BOOL(PHPC_RES_CLOSE(z_train_data) == SUCCESS);
++ PHPC_RES_CLOSE(z_train_data);
++ RETURN_TRUE;
+ }
+ /* }}} */
+
diff --git a/php-pecl-fann.spec b/php-pecl-fann.spec
index 5adbc21..c60a748 100644
--- a/php-pecl-fann.spec
+++ b/php-pecl-fann.spec
@@ -27,7 +27,7 @@
Summary: Wrapper for FANN Library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.1.1
-Release: 17%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 18%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -238,6 +238,9 @@ fi
%changelog
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 1.1.1-18
+- rebuild for PHP 8.0.0beta3
+
* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 1.1.1-17
- add patches for PHP8 from
https://github.com/bukka/php-fann/pull/42