summaryrefslogtreecommitdiffstats
path: root/php-pecl-fann.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-10 16:30:56 +0200
committerRemi Collet <remi@remirepo.net>2021-06-10 16:30:56 +0200
commit24f91f05ee7f3971c05e4d4a3e2439bb7f871075 (patch)
tree4e064435aea2615512e9c7ab67d1a2e3b8e6eb09 /php-pecl-fann.spec
parent8f7e291b6a838d1ebd80a4abbdce9a33d8f43948 (diff)
add patch for PHP 8.1 from
https://github.com/bukka/phpc/pull/2 https://github.com/bukka/php-fann/pull/43
Diffstat (limited to 'php-pecl-fann.spec')
-rw-r--r--php-pecl-fann.spec14
1 files changed, 13 insertions, 1 deletions
diff --git a/php-pecl-fann.spec b/php-pecl-fann.spec
index 8106838..8772bae 100644
--- a/php-pecl-fann.spec
+++ b/php-pecl-fann.spec
@@ -29,11 +29,13 @@
Summary: Wrapper for FANN Library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: %{pecl_name}-php81.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: fann-devel > 2.1
@@ -64,6 +66,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -86,6 +91,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_FANN_VERSION/{s/.* "//;s/".*$//;p}' php_fann.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -216,6 +223,11 @@ fi
%changelog
+* Thu Jun 10 2021 Remi Collet <remi@remirepo.net> - 1.2.0~RC1-2
+- add patch for PHP 8.1 from
+ https://github.com/bukka/phpc/pull/2
+ https://github.com/bukka/php-fann/pull/43
+
* Mon Mar 15 2021 Remi Collet <remi@remirepo.net> - 1.2.0~RC1-1
- update to 1.2.0RC1
- drop all patches merged upstream