summaryrefslogtreecommitdiffstats
path: root/php-pecl-excimer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-excimer.spec')
-rw-r--r--php-pecl-excimer.spec32
1 files changed, 20 insertions, 12 deletions
diff --git a/php-pecl-excimer.spec b/php-pecl-excimer.spec
index 1e24a7c..ded895c 100644
--- a/php-pecl-excimer.spec
+++ b/php-pecl-excimer.spec
@@ -16,17 +16,18 @@
%global pecl_name excimer
%global ini_name 40-%{pecl_name}.ini
# segfault in test suite
-%global with_zts 0
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
Summary: Interrupting timer and low-overhead sampling profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/wikimedia/php-excimer/pull/1.patch
+Patch0: %{pecl_name}-php81.patch
+Patch1: %{pecl_name}-info.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -53,6 +54,9 @@ Obsoletes: php74-pecl-%{pecl_name}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name}
+%endif
%endif
@@ -75,7 +79,8 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1 -b .pr1
+%patch0 -p1
+%patch1 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_EXCIMER_VERSION/{s/.* "//;s/".*$//;p}' php_excimer.h)
@@ -172,11 +177,8 @@ cd NTS
--modules | grep '^%{pecl_name}$'
# Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q -P --show-diff
%if %{with_zts}
cd ../ZTS
@@ -186,11 +188,8 @@ cd ../ZTS
--modules | grep '^%{pecl_name}$'
# Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q -P --show-diff
%endif
@@ -209,6 +208,15 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+- drop patch merged upstream
+- add patch for PHP 8.1 from
+ https://github.com/wikimedia/php-excimer/pull/2
+- display extension version in phpinfo from
+ https://github.com/wikimedia/php-excimer/pull/3
+- enable ZTS build
+
* Tue Mar 2 2021 Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package
- add build fix with PHP 8 from