summaryrefslogtreecommitdiffstats
path: root/php-pecl-excimer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-04 16:30:47 +0200
committerRemi Collet <remi@php.net>2022-05-04 16:30:47 +0200
commit5c3e85a6c7e468a9352fddb93fe5db6c62820de1 (patch)
tree8585f1bfb4cd2b19631897013fa3797b83fd13a4 /php-pecl-excimer.spec
parentaaab85b9eda928db70d7fadc1206e1d8c3b73953 (diff)
update to 1.0.3
fix build with PHP 7.1 using patch from https://github.com/wikimedia/php-excimer/pull/4
Diffstat (limited to 'php-pecl-excimer.spec')
-rw-r--r--php-pecl-excimer.spec20
1 files changed, 17 insertions, 3 deletions
diff --git a/php-pecl-excimer.spec b/php-pecl-excimer.spec
index 60891ef..7096962 100644
--- a/php-pecl-excimer.spec
+++ b/php-pecl-excimer.spec
@@ -20,12 +20,14 @@
Summary: Interrupting timer and low-overhead sampling profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.2
+Version: 1.0.3
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/wikimedia/php-excimer/pull/4.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -76,6 +78,8 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
+%patch0 -p1 -b .pr4
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_EXCIMER_VERSION/{s/.* "//;s/".*$//;p}' php_excimer.h)
if test "x${extver}" != "x%{version}"; then
@@ -164,6 +168,11 @@ fi
%check
+OPT="-q -P --show-diff"
+%if "%{php_version}" > "7.4"
+OPT="$OPT %{?_smp_mflags}"
+%endif
+
cd NTS
# Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -172,7 +181,7 @@ cd NTS
# Upstream test suite for NTS extension
TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
-%{__php} -n run-tests.php -q -P --show-diff
+%{__php} -n run-tests.php $OPT
%if %{with_zts}
cd ../ZTS
@@ -183,7 +192,7 @@ cd ../ZTS
# Upstream test suite for ZTS extension
TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
-%{__ztsphp} -n run-tests.php -q -P --show-diff
+%{__ztsphp} -n run-tests.php $OPT
%endif
@@ -202,6 +211,11 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Wed May 4 2022 Remi Collet <remi@remirepo.net> - 1.0.3-1
+- update to 1.0.3
+- fix build with PHP 7.1 using patch from
+ https://github.com/wikimedia/php-excimer/pull/4
+
* Tue Oct 19 2021 Remi Collet <remi@remirepo.net> - 1.0.2-1
- update to 1.0.2
- drop patches merged upstream