summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-fix-tests-expectation-for-8.4.0alpha1.patch53
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-event.spec12
4 files changed, 8 insertions, 61 deletions
diff --git a/0001-fix-tests-expectation-for-8.4.0alpha1.patch b/0001-fix-tests-expectation-for-8.4.0alpha1.patch
deleted file mode 100644
index 74e2473..0000000
--- a/0001-fix-tests-expectation-for-8.4.0alpha1.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From b70cd8c7ecdec41092c504ad3dba820d389c2928 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 15 Jul 2024 15:50:31 +0200
-Subject: [PATCH] fix tests expectation for 8.4.0alpha1
-
----
- tests/33-bevent-read-cb-exception.phpt | 2 +-
- tests/33-bevent-write-cb-exception.phpt | 2 +-
- tests/61-issue.phpt | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/tests/33-bevent-read-cb-exception.phpt b/tests/33-bevent-read-cb-exception.phpt
-index 2b0c4b3..cbf07d2 100644
---- a/tests/33-bevent-read-cb-exception.phpt
-+++ b/tests/33-bevent-read-cb-exception.phpt
-@@ -34,7 +34,7 @@ Warning: EventBase::loop(): Breaking the loop due to exception RuntimeException
-
- Fatal error: Uncaught RuntimeException: from EventBufferEvent callback in %s/33-bevent-read-cb-exception.php:%d
- Stack trace:
--#0 [internal function]: {closure}(Object(EventBufferEvent), NULL)
-+#0 [internal function]: {closur%s}(Object(EventBufferEvent), NULL)
- #1 %s/33-bevent-read-cb-exception.php(%d): %SEventBase->loop()
- #2 {main}
- %wthrown in %s/33-bevent-read-cb-exception.php on line %d
-diff --git a/tests/33-bevent-write-cb-exception.phpt b/tests/33-bevent-write-cb-exception.phpt
-index a84d074..b326282 100644
---- a/tests/33-bevent-write-cb-exception.phpt
-+++ b/tests/33-bevent-write-cb-exception.phpt
-@@ -34,7 +34,7 @@ Warning: EventBase::loop(): Breaking the loop due to exception RuntimeException
-
- Fatal error: Uncaught RuntimeException: from EventBufferEvent callback in %s/33-bevent-write-cb-exception.php:%d
- Stack trace:
--#0 [internal function]: {closure}(Object(EventBufferEvent), NULL)
-+#0 [internal function]: {closur%s}(Object(EventBufferEvent), NULL)
- #1 %s/33-bevent-write-cb-exception.php(%d): %SEventBase->loop()
- #2 {main}
- %wthrown in %s/33-bevent-write-cb-exception.php on line %d
-diff --git a/tests/61-issue.phpt b/tests/61-issue.phpt
-index 812e52f..bb29012 100644
---- a/tests/61-issue.phpt
-+++ b/tests/61-issue.phpt
-@@ -24,7 +24,7 @@ Warning: EventBase::loop(): Breaking the loop due to exception Exception in %s o
-
- Fatal error: Uncaught Exception: issue61 in %s/61-issue.php:%d
- Stack trace:
--#0 [internal function]: {closure}(-1, 1, NULL)
-+#0 [internal function]: {closur%s}(-1, 1, NULL)
- #1 %s/61-issue.php(%d): %SEventBase->loop()
- #2 {main}
- thrown in %s/61-issue.php on line %d
---
-2.45.2
-
diff --git a/PHPINFO b/PHPINFO
index 23a5e02..7ca7ab2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,5 +7,5 @@ Debug support => disabled
Extra functionality support including HTTP, DNS, and RPC => enabled
OpenSSL support => enabled
Thread safety support => disabled
-Extension version => 3.1.3
+Extension version => 3.1.4
libevent2 headers version => 2.1.12-stable
diff --git a/REFLECTION b/REFLECTION
index d7df285..4d5bd2b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #65 event version 3.1.3 ] {
+Extension [ <persistent> extension #71 event version 3.1.4 ] {
- Dependencies {
Dependency [ sockets (Required) ]
diff --git a/php-pecl-event.spec b/php-pecl-event.spec
index 1cfc1b6..a4bc9ef 100644
--- a/php-pecl-event.spec
+++ b/php-pecl-event.spec
@@ -27,7 +27,7 @@
# After 20-sockets.so
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.1.3
+%global upstream_version 3.1.4
#global upstream_prever RC1
#global upstream_postver r1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -36,13 +36,11 @@
Summary: Provides interface to libevent library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}%{?upstream_postver:+%{upstream_postver}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/event
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}%{?upstream_postver}.tgz
-Patch0: 0001-fix-tests-expectation-for-8.4.0alpha1.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -89,8 +87,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-
# Sanity check, really often broken
DIR=$(%{__php} -r 'echo "php" . PHP_MAJOR_VERSION;')
#sed -e '/PHP_EVENT_VERSION/s/2.4.2/2.4.3/' -i $DIR/php_event.h
@@ -228,6 +224,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Jul 16 2024 Remi Collet <remi@remirepo.net> - 3.1.4-1
+- update to 3.1.4 (no change)
+- drop patch merged upstream
+
* Mon Jan 29 2024 Remi Collet <remi@remirepo.net> - 3.1.3-1
- update to 3.1.3