summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--ev-php5.patch25
-rw-r--r--ev-php81.patch42
-rw-r--r--php-pecl-ev.spec17
5 files changed, 85 insertions, 3 deletions
diff --git a/PHPINFO b/PHPINFO
index 7d78bbb..f97c1ac 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,4 +3,4 @@ ev
Ev support => enabled
Debug support => disabled
-Version => 1.1.2
+Version => 1.1.3
diff --git a/REFLECTION b/REFLECTION
index 53005f5..607a4e3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 ev version 1.1.2 ] {
+Extension [ <persistent> extension #122 ev version 1.1.3 ] {
- Dependencies {
Dependency [ sockets (Optional) ]
diff --git a/ev-php5.patch b/ev-php5.patch
new file mode 100644
index 0000000..0f4583b
--- /dev/null
+++ b/ev-php5.patch
@@ -0,0 +1,25 @@
+From 8296b29a380ce2767ef07a7ebb0ca5b5c37c1832 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 26 Jul 2021 14:21:22 +0200
+Subject: [PATCH 2/2] Fix PHP 5 and ZTS build
+
+---
+ php5/watcher.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/php5/watcher.c b/php5/watcher.c
+index 9ff4d78..a5a2918 100644
+--- a/php5/watcher.c
++++ b/php5/watcher.c
+@@ -73,7 +73,7 @@ void php_ev_watcher_callback(EV_P_ ev_watcher *watcher, int revents)
+ php_error_docref(NULL, E_WARNING,
+ "Stopping %s watcher because of uncaught exception in the callback",
+ Z_OBJCE_P(self)->name);
+- php_ev_stop_watcher(watcher);
++ php_ev_stop_watcher(watcher TSRMLS_CC);
+ }
+
+ zval_ptr_dtor(&self);
+--
+2.31.1
+
diff --git a/ev-php81.patch b/ev-php81.patch
new file mode 100644
index 0000000..b9f9657
--- /dev/null
+++ b/ev-php81.patch
@@ -0,0 +1,42 @@
+From 5550acb75a6f567f5a4a612f442ccde237198a33 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 26 Jul 2021 14:11:12 +0200
+Subject: [PATCH] fix tests for PHP 8.1.0beta1
+
+---
+ tests/12_watcher_leak.phpt | 4 ++--
+ tests/bug33.phpt | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/12_watcher_leak.phpt b/tests/12_watcher_leak.phpt
+index 4b08da3..9d34ee6 100644
+--- a/tests/12_watcher_leak.phpt
++++ b/tests/12_watcher_leak.phpt
+@@ -1,9 +1,9 @@
+ --TEST--
+ Check for EvWatcher object destructors(leaks)
++--INI--
++memory_limit=2M
+ --FILE--
+ <?php
+-ini_set('memory_limit', '1M');
+-
+ $limit = 100000;
+
+ $callback = function() {
+diff --git a/tests/bug33.phpt b/tests/bug33.phpt
+index 2490896..110d7c1 100644
+--- a/tests/bug33.phpt
++++ b/tests/bug33.phpt
+@@ -17,7 +17,7 @@ $reschedule_cb = function ($watcher, $now) use ($time_delta, $time_steps) {
+ return $now + $time_delta;
+ };
+
+-$w = new EvPeriodic(null, null, $reschedule_cb, function () {
++$w = new EvPeriodic(0, 0, $reschedule_cb, function () {
+ static $counter = 0;
+
+ echo ++$counter, PHP_EOL;
+--
+2.31.1
+
diff --git a/php-pecl-ev.spec b/php-pecl-ev.spec
index e918225..a520a63 100644
--- a/php-pecl-ev.spec
+++ b/php-pecl-ev.spec
@@ -24,7 +24,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 1.1.2
+%global upstream_version 1.1.3
#global upstream_prever RC3
#global upstream_postver r1
@@ -36,6 +36,9 @@ License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}%{?upstream_postver}.tgz
+Patch0: %{pecl_name}-php5.patch
+Patch1: %{pecl_name}-php81.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -69,6 +72,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -89,6 +95,9 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1
+%patch1 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/define PHP_EV_VERSION/{s/.* "//;s/".*$//;p}' php%(%{__php} -r 'echo PHP_MAJOR_VERSION;')/php_ev.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?upstream_postver}"; then
@@ -198,6 +207,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
: Minimal load test for ZTS extension
cd ../ZTS
+rm tests/bug43-uncaught-exception.php5.phpt
%{__ztsphp} \
$DEPMOD \
@@ -228,6 +238,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Jul 26 2021 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+- add patch for PHP 5 and ZTS (send upstream by email)
+- add patch for PHP 8.1.0beta1 (send upstream by email)
+
* Tue Feb 16 2021 Remi Collet <remi@remirepo.net> - 1.1.2-1
- update to 1.1.2