summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-09 11:40:07 +0200
committerRemi Collet <remi@remirepo.net>2021-09-09 11:40:07 +0200
commitbccc686442168a4934625ac0fe0af1029cfb175b (patch)
tree8267d851f8cc7c2b3c8d0152fb5c7df802e87808
parentf9eae5b4128a783a2103477a3caec1dcc7143510 (diff)
ignore 4 tests for 8.1 (deprecated calls)HEADmaster
-rw-r--r--php-pecl-eio.spec17
1 files changed, 15 insertions, 2 deletions
diff --git a/php-pecl-eio.spec b/php-pecl-eio.spec
index f554624..fc4d9f4 100644
--- a/php-pecl-eio.spec
+++ b/php-pecl-eio.spec
@@ -31,7 +31,7 @@
Summary: Provides interface to the libeio library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -75,6 +75,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -189,7 +192,14 @@ fi
%check
# Need investigation (output order, erratic results)
-rm ?TS/tests/eio_custom_basic.phpt
+rm ?TS/tests/eio_custom_basic.phpt
+%if "%{php_version}" > "8.1"
+# deprecated calls
+rm ?TS/tests/eio_grp_add.phpt
+rm ?TS/tests/eio_stat_error.phpt
+rm ?TS/tests/eio_write_variation.phpt
+rm ?TS/tests/fork.phpt
+%endif
DEPMOD=
[ -f %{php_extdir}/sockets.so ] && DEPMOD="$DEPMOD -d extension=sockets.so"
@@ -242,6 +252,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 3.0.0~RC2-2
+- ignore 4 tests for 8.1 (deprecated calls)
+
* Mon Apr 19 2021 Remi Collet <remi@remirepo.net> - 3.0.0~RC2-1
- update to 3.0.0RC2