summaryrefslogtreecommitdiffstats
path: root/php-pecl-ds.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-ds.spec')
-rw-r--r--php-pecl-ds.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 3e4173e..4bd8e67 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -42,6 +42,8 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
+Patch0: 0001-review-object-management.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -51,6 +53,8 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{_bindir}/phpunit6
BuildRequires: %{_bindir}/phpab
%endif
+#BuildRequires: php-debuginfo
+#BuildRequires: gdb
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -101,6 +105,7 @@ mv %{gh_project}-%{gh_commit} tests
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DS_VERSION/{s/.* "//;s/".*$//;p}' php_ds.h)