summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-ds.spec7
2 files changed, 9 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index 4d2b432..857791f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 ds version 1.1.10 ] {
+Extension [ <persistent> extension #81 ds version 1.2.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -325,7 +325,7 @@ Extension [ <persistent> extension #81 ds version 1.1.10 ] {
Class [ <internal:ds> <iterateable> final class Ds\Vector implements Ds\Sequence, Traversable, Countable, JsonSerializable, Ds\Collection ] {
- Constants [1] {
- Constant [ integer MIN_CAPACITY ] { 10 }
+ Constant [ integer MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -1038,7 +1038,7 @@ Extension [ <persistent> extension #81 ds version 1.1.10 ] {
Class [ <internal:ds> <iterateable> final class Ds\Map implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
- Constants [1] {
- Constant [ integer MIN_CAPACITY ] { 16 }
+ Constant [ integer MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -1336,7 +1336,7 @@ Extension [ <persistent> extension #81 ds version 1.1.10 ] {
Class [ <internal:ds> <iterateable> final class Ds\Set implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
- Constants [1] {
- Constant [ integer MIN_CAPACITY ] { 16 }
+ Constant [ integer MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index dd4dded..aa59564 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -29,8 +29,8 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.1.10
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -233,6 +233,9 @@ cd ..
%changelog
+* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- Update to 1.2.0
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.1.10-2
- rebuild for PHP 7.2.0beta1 new API