summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-07 13:50:01 +0200
committerRemi Collet <remi@remirepo.net>2017-07-07 13:50:01 +0200
commitd861fa756adfba5c0f5fb07b5c7ec52fea7e2d51 (patch)
treef2a61c80811ca86893d3d6a5f54d3f5904570bd2
parentcb9a40ae1f1bf86d8294e739ab4c5fd8fe6d0e66 (diff)
cleaup
-rw-r--r--php-pecl-ds.spec96
1 files changed, 22 insertions, 74 deletions
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index ae17959..e23bdb0 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -1,3 +1,6 @@
+# Fedora spec file for php-pecl-ds
+# without SCL compatibility from:
+#
# remirepo spec file for php-pecl-ds
#
# Copyright (c) 2016-2017 Remi Collet
@@ -6,15 +9,7 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%scl_package php-pecl-ds
-%global sub_prefix %{scl_prefix}
-# No phpunit in SCL
-%global with_tests 0
-%else
%global with_tests 0%{!?_without_tests:1}
-%endif
-
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name ds
# After json
@@ -28,9 +23,9 @@
Summary: Data Structures for PHP
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: php-pecl-%{pecl_name}
Version: 1.1.10
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -39,51 +34,27 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
-BuildRequires: %{?scl_prefix}php-devel >= 7
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: %{?scl_prefix}php-json
+BuildRequires: php-devel >= 7
+BuildRequires: php-pear
+BuildRequires: php-json
%if %{with_tests}
BuildRequires: %{_bindir}/phpunit
BuildRequires: %{_bindir}/phpab
%endif
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Requires: %{?scl_prefix}php-json%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires: php-json%{?_isa}
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
%description
-%{summary}.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+An extension providing specialized data structures as efficient alternatives
+to the PHP array.
%prep
@@ -117,8 +88,6 @@ EOF
%build
-%{?dtsenable}
-
peclbuild() {
%configure \
--enable-ds \
@@ -139,10 +108,7 @@ peclbuild %{_bindir}/zts-php-config
%install
-%{?dtsenable}
-
-make -C NTS \
- install INSTALL_ROOT=%{buildroot}
+make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -151,8 +117,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS \
- install INSTALL_ROOT=%{buildroot}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -163,26 +128,6 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
modules="-d extension=json.so"
@@ -233,6 +178,9 @@ cd ..
%changelog
+* Fri Jul 7 2017 Remi Collet <remi@remirepo.net> - 1.1.10-1
+- cleanup for Fedora review
+
* Thu Jun 22 2017 Remi Collet <remi@remirepo.net> - 1.1.10-1
- Update to 1.1.10