summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-01 07:05:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-01 07:05:11 +0200
commit9551a58f9fe606e797bf752d4a4b35106b34cfbe (patch)
treedc505485e9393431924e7f8d8dcef7a865985a6e
parent773a50072d5a2f50866afb6b370c6d1a211914fb (diff)
php-pecl-ds: 1.0.3
-rw-r--r--REFLECTION21
-rw-r--r--php-pecl-ds.spec7
2 files changed, 16 insertions, 12 deletions
diff --git a/REFLECTION b/REFLECTION
index 0434be4..31081d6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #144 ds version 1.0.2 ] {
+Extension [ <persistent> extension #145 ds version 1.0.3 ] {
- Classes [11] {
Interface [ <internal:ds> interface Ds\Hashable ] {
@@ -332,7 +332,7 @@ Extension [ <persistent> extension #144 ds version 1.0.2 ] {
- Properties [0] {
}
- - Methods [35] {
+ - Methods [34] {
Method [ <internal:ds, prototype Ds\Sequence, ctor> public method __construct ] {
- Parameters [1] {
@@ -573,13 +573,6 @@ Extension [ <persistent> extension #144 ds version 1.0.2 ] {
}
- Return [ array ]
}
-
- Method [ <internal:ds> public method push_one ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $value ]
- }
- }
}
}
@@ -1350,7 +1343,7 @@ Extension [ <persistent> extension #144 ds version 1.0.2 ] {
- Properties [0] {
}
- - Methods [28] {
+ - Methods [29] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1437,6 +1430,14 @@ Extension [ <persistent> extension #144 ds version 1.0.2 ] {
}
}
+ Method [ <internal:ds> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $values ]
+ }
+ - Return [ Ds\Set or NULL ]
+ }
+
Method [ <internal:ds> public method reduce ] {
- Parameters [2] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 359a0f4..5bd3f63 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -21,7 +21,7 @@
%global ini_name 40-%{pecl_name}.ini
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit bff759ed81f7cb2042700700eb9c1d68e74fb3dd
+%global gh_commit 664c3281858ffd04da8017e3d7c80cbd4e8c55e7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -29,7 +29,7 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.2
+Version: 1.0.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -225,6 +225,9 @@ cd ..
%changelog
+* Mon Aug 01 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- Update to 1.0.3 (stable)
+
* Sat Jul 30 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
- Update to 1.0.2 (stable)