summaryrefslogtreecommitdiffstats
path: root/php-pecl-datadog-trace.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-datadog-trace.spec')
-rw-r--r--php-pecl-datadog-trace.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 75ed197..151a966 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -12,6 +12,12 @@
%global _root_libdir %{_libdir}
%endif
+# Defined in Fedora >= 37 and RHEL >= 10, in PHP >= 7.4 for remirepo
+%{!?__phpize: %global __phpize %{_bindir}/phpize}
+%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
+%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
+%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
+
# pecl name
%global proj_name datadog_trace
# no underscore for package name
@@ -26,7 +32,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?scl_prefix}php-pecl-datadog-trace
-Version: 0.86.3
+Version: 0.87.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -124,18 +130,18 @@ EOF
%{?dtsenable}
cd NTS
-%{_bindir}/phpize
+%{__phpize}
%configure \
--enable-ddtrace \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
+%{__ztsphpize}
%configure \
--enable-ddtrace \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -251,6 +257,9 @@ fi
%changelog
+* Sat May 13 2023 Remi Collet <remi@remirepo.net> - 0.87.0-1
+- update to 0.87.0
+
* Thu Apr 6 2023 Remi Collet <remi@remirepo.net> - 0.86.3-1
- update to 0.86.3