summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--952.patch21
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-datadog-trace.spec13
4 files changed, 24 insertions, 30 deletions
diff --git a/952.patch b/952.patch
index 3cba6f5..24e141d 100644
--- a/952.patch
+++ b/952.patch
@@ -27,25 +27,4 @@ index 17235e11e..869e65da5 100644
function dd_get_startup_logs(array $args = [], array $env = [])
-From 60396869f4ee09a68d532d40a5e72c4c0cfcc102 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 9 Jul 2020 08:09:50 +0200
-Subject: [PATCH 2/2] relax test expectation
-
----
- tests/ext/startup_logging_diagnostics.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/tests/ext/startup_logging_diagnostics.phpt b/tests/ext/startup_logging_diagnostics.phpt
-index 13c458997..581b6098b 100644
---- a/tests/ext/startup_logging_diagnostics.phpt
-+++ b/tests/ext/startup_logging_diagnostics.phpt
-@@ -31,7 +31,7 @@ dd_dump_startup_logs($logs, [
- ]);
- ?>
- --EXPECTF--
--agent_error: "Could not resolve host: invalid_host"
-+agent_error: %sinvalid_host%s
- open_basedir_init_hook_allowed: false
- open_basedir_container_tagging_allowed: false
- service_name: "foo_service"
diff --git a/PHPINFO b/PHPINFO
index 8ce7127..715643a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,8 +7,8 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2020
Datadog tracing support => enabled
-Version => 0.47.0
-DATADOG TRACER CONFIGURATION => {"date":"2020-07-09T06:04:15Z","os_name":"Linux builder.remirepo.net 5.7.7-100.fc31.x86_64 #1 SMP Wed Jul 1 20:37:05 UTC 2020 x86_64","os_version":"5.7.7-100.fc31.x86_64","version":"0.47.0","lang":"php","lang_version":"7.3.20","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1.000000,"sampling_rules":null,"tags":null,"service_mapping":null,"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","ddtrace.request_init_hook":null,"open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":null,"enabled_from_env":true,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connection refused","ddtrace.request_init_hook_reachable":false}
+Version => 0.47.1
+DATADOG TRACER CONFIGURATION => {"date":"2020-08-02T05:10:02Z","os_name":"Linux builder.remirepo.net 5.7.9-100.fc31.x86_64 #1 SMP Fri Jul 17 17:18:38 UTC 2020 x86_64","os_version":"5.7.9-100.fc31.x86_64","version":"0.47.1","lang":"php","lang_version":"7.3.20","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1.000000,"sampling_rules":null,"tags":null,"service_mapping":null,"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","ddtrace.request_init_hook":null,"open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":null,"enabled_from_env":true,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connection refused","ddtrace.request_init_hook_reachable":false}
Diagnostics
agent_error => Failed to connect to localhost port 8126: Connection refused
diff --git a/REFLECTION b/REFLECTION
index 23a5f56..3d583d0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #116 ddtrace version 0.47.0 ] {
+Extension [ <persistent> extension #116 ddtrace version 0.47.1 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -13,7 +13,7 @@ Extension [ <persistent> extension #116 ddtrace version 0.47.0 ] {
}
- Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.47.0 }
+ Constant [ string DD_TRACE_VERSION ] { 0.47.1 }
}
- Functions {
@@ -166,6 +166,18 @@ Extension [ <persistent> extension #116 ddtrace version 0.47.0 ] {
- Parameters [0] {
}
}
+ Function [ <internal:ddtrace> function DDTrace\Config\integration_analytics_enabled ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $integration_name ]
+ }
+ }
+ Function [ <internal:ddtrace> function DDTrace\Config\integration_analytics_sample_rate ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $integration_name ]
+ }
+ }
}
- Classes [1] {
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 2554b3e..8877f9b 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -34,7 +34,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.47.0
+Version: 0.47.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -42,9 +42,9 @@ License: (ASL 2.0 or BSD) and MIT
URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{version}.tgz
-Source1: https://raw.githubusercontent.com/DataDog/dd-trace-php/0.47.0/src/ext/php5/engine_api.c
-Source2: https://raw.githubusercontent.com/DataDog/dd-trace-php/0.47.0/src/ext/php5/engine_api.h
-Source3: https://raw.githubusercontent.com/DataDog/dd-trace-php/0.47.0/src/ext/php5/handlers_curl.c
+Source1: https://raw.githubusercontent.com/DataDog/dd-trace-php/%{version}/src/ext/php5/engine_api.c
+Source2: https://raw.githubusercontent.com/DataDog/dd-trace-php/%{version}/src/ext/php5/engine_api.h
+Source3: https://raw.githubusercontent.com/DataDog/dd-trace-php/%{version}/src/ext/php5/handlers_curl.c
Patch0: https://patch-diff.githubusercontent.com/raw/DataDog/dd-trace-php/pull/952.patch
@@ -80,7 +80,7 @@ Provides: %{?scl_prefix}php-pecl-%{safe_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{safe_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{safe_name} <= %{version}
@@ -268,6 +268,9 @@ fi
%changelog
+* Sat Aug 1 2020 Remi Collet <remi@remirepo.net> - 0.47.1-1
+- update to 0.47.1
+
* Thu Jul 9 2020 Remi Collet <remi@remirepo.net> - 0.47.0-1
- update to 0.47.0
- open https://github.com/DataDog/dd-trace-php/pull/952