summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION21
-rw-r--r--php-pecl-datadog-trace.spec5
3 files changed, 24 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
index d6af04f..946afee 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,7 +7,7 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2019
Datadog tracing support => enabled
-Version => 0.42.0
+Version => 0.43.0
Directive => Local Value => Master Value
ddtrace.disable => Off => Off
diff --git a/REFLECTION b/REFLECTION
index da3625b..a403e9b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 ddtrace version 0.42.0 ] {
+Extension [ <persistent> extension #113 ddtrace version 0.43.0 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -16,7 +16,7 @@ Extension [ <persistent> extension #113 ddtrace version 0.42.0 ] {
}
- Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.42.0 }
+ Constant [ string DD_TRACE_VERSION ] { 0.43.0 }
}
- Functions {
@@ -121,6 +121,23 @@ Extension [ <persistent> extension #113 ddtrace version 0.42.0 ] {
- Parameters [0] {
}
}
+ Function [ <internal:ddtrace> function ddtrace_config_app_name ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $default_name ]
+ }
+ }
+ Function [ <internal:ddtrace> function ddtrace_config_integration_enabled ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $integration_name ]
+ }
+ }
+ Function [ <internal:ddtrace> function ddtrace_config_trace_enabled ] {
+
+ - Parameters [0] {
+ }
+ }
}
- Classes [1] {
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 913cb3c..a7de3e8 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -34,7 +34,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.42.0
+Version: 0.43.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -269,6 +269,9 @@ fi
%changelog
+* Thu Apr 23 2020 Remi Collet <remi@remirepo.net> - 0.43.0-1
+- update to 0.43.0
+
* Thu Apr 2 2020 Remi Collet <remi@remirepo.net> - 0.42.0-1
- update to 0.42.0