summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION60
-rw-r--r--php-pecl-datadog-trace.spec16
-rw-r--r--php74.patch37
4 files changed, 70 insertions, 45 deletions
diff --git a/PHPINFO b/PHPINFO
index 85edbc6..7f61ef1 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,7 +7,7 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2019
Datadog tracing support => enabled
-Version => 0.30.2
+Version => 0.31.0
Directive => Local Value => Master Value
ddtrace.disable => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 0b217fe..39e73e0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #85 ddtrace version 0.30.2 ] {
+Extension [ <persistent> extension #85 ddtrace version 0.31.0 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -16,12 +16,32 @@ Extension [ <persistent> extension #85 ddtrace version 0.30.2 ] {
}
- Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.30.2 }
+ Constant [ string DD_TRACE_VERSION ] { 0.31.0 }
}
- Functions {
Function [ <internal:ddtrace> function dd_trace ] {
}
+ Function [ <internal:ddtrace> function dd_trace_method ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $class_name ]
+ Parameter #1 [ <required> $method_name ]
+ Parameter #2 [ <required> $tracing_closure ]
+ }
+ }
+ Function [ <internal:ddtrace> function dd_trace_function ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $function_name ]
+ Parameter #1 [ <required> $tracing_closure ]
+ }
+ }
+ Function [ <internal:ddtrace> function dd_trace_serialize_closed_spans ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:ddtrace> function dd_trace_forward_call ] {
}
Function [ <internal:ddtrace> function dd_trace_reset ] {
@@ -66,8 +86,44 @@ Extension [ <persistent> extension #85 ddtrace version 0.30.2 ] {
Parameter #0 [ <required> $trace_array ]
}
}
+ Function [ <internal:ddtrace> function dd_trace_push_span_id ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_pop_span_id ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_peek_span_id ] {
+ }
Function [ <internal:ddtrace> function dd_trace_generate_id ] {
}
+ Function [ <internal:ddtrace> function dd_trace_closed_spans_count ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_tracer_is_limited ] {
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:ddtrace> class DDTrace\SpanData ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [6] {
+ Property [ <default> public $name ]
+ Property [ <default> public $resource ]
+ Property [ <default> public $service ]
+ Property [ <default> public $type ]
+ Property [ <default> public $meta ]
+ Property [ <default> public $metrics ]
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 3152ea5..8c40354 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -34,14 +34,12 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.30.2
+Version: 0.31.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{proj_name}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
-Patch0: php74.patch
-
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -111,8 +109,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
cp src/ext/mpack/LICENSE LICENSE.mpack
-%patch0 -p1
-
: Sanity check, really often broken
extver=$(sed -n '/#define PHP_DDTRACE_VERSION /{s/.* "//;s/".*$//;p}' src/ext/version.h)
if test "x${extver}" != "x%{version}"; then
@@ -195,6 +191,13 @@ rm ?TS/tests/ext/segfault_backtrace_*.phpt
# see https://github.com/DataDog/dd-trace-php/issues/394
rm ?TS/tests/ext/dd_trace_coms_test_parallel_writer_consistency.phpt
rm ?TS/tests/ext/circuit_breaker_info.phpt
+rm ?TS/tests/ext/sandbox/dd_trace_function_complex.phpt
+rm ?TS/tests/ext/sandbox/dd_trace_function_internal.phpt
+rm ?TS/tests/ext/sandbox/dd_trace_function_userland.phpt
+rm ?TS/tests/ext/sandbox/dd_trace_method.phpt
+rm ?TS/tests/ext/sandbox/dd_trace_method_works_with_dd_trace.phpt
+rm ?TS/tests/ext/sandbox/errors_are_flagged_from_userland.phpt
+rm ?TS/tests/ext/sandbox/exceptions_and_errors_are_ignored_in_tracing_closure.phpt
%endif
@@ -264,6 +267,9 @@ fi
%changelog
+* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.31.0-1
+- update to 0.31.0
+
* Thu Sep 19 2019 Remi Collet <remi@remirepo.net> - 0.30.2-1
- update to 0.30.2
- add upstream patch for PHP 7.4
diff --git a/php74.patch b/php74.patch
deleted file mode 100644
index 41926ff..0000000
--- a/php74.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Adapted for 0.30.2 from upstream patch
-
-
-
-From 433177dd98f81585748e697ebaa104d0ad76a234 Mon Sep 17 00:00:00 2001
-From: Levi Morrison <levi.morrison@datadoghq.com>
-Date: Fri, 23 Aug 2019 08:06:27 -0600
-Subject: [PATCH] Avoid reserved word "fn"
-
-In PHP 7.4 and forward "fn" is a keyword.
-Also fixes misspelling in the name of the file.
-diff --git a/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt b/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt
---- a/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt
-+++ b/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt
-@@ -16,18 +16,18 @@ class Test {
- dd_trace("Test", "m", function() {
- return dd_trace_forward_call() . " OVERRIDE";
- });
--function fn() {
-+function func() {
- $test = new Test();
- echo $test->m() . PHP_EOL;
-- echo "FN" . PHP_EOL;
-+ echo "FUNC" . PHP_EOL;
- }
-
--fn();
-+func();
- echo "FINISH" . PHP_EOL;
- ?>
-
- --EXPECT--
- M OVERRIDE
--FN
-+FUNC
- DESTRUCT
- FINISH