summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-datadog-trace.spec34
3 files changed, 31 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index 174d943..d902642 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,8 +7,8 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2020
Datadog tracing support => enabled
-Version => 0.54.0
-DATADOG TRACER CONFIGURATION => {"date":"2021-01-21T06:25:49Z","os_name":"Linux builder.remirepo.net 5.10.8-200.fc33.x86_64 #1 SMP Sun Jan 17 19:53:01 UTC 2021 x86_64","os_version":"5.10.8-200.fc33.x86_64","version":"0.54.0","lang":"php","lang_version":"7.4.14","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1.000000,"sampling_rules":null,"tags":null,"service_mapping":null,"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","ddtrace.request_init_hook":"/usr/share/pear/datadog_trace/bridge/dd_wrap_autoloader.php","open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":null,"enabled_from_env":true,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connection refused"}
+Version => 0.56.0
+DATADOG TRACER CONFIGURATION => {"date":"2021-03-05T05:57:37Z","os_name":"Linux builder.remirepo.net 5.10.19-200.fc33.x86_64 #1 SMP Fri Feb 26 16:21:30 UTC 2021 x86_64","os_version":"5.10.19-200.fc33.x86_64","version":"0.56.0","lang":"php","lang_version":"7.4.16","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1.000000,"sampling_rules":null,"tags":null,"service_mapping":null,"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","ddtrace.request_init_hook":"/usr/share/pear/datadog_trace/bridge/dd_wrap_autoloader.php","open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":null,"enabled_from_env":true,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connection refused"}
Diagnostics
agent_error => Failed to connect to localhost port 8126: Connection refused
diff --git a/REFLECTION b/REFLECTION
index 839b2f8..4c01e2a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 ddtrace version 0.54.0 ] {
+Extension [ <persistent> extension #119 ddtrace version 0.56.0 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -10,7 +10,7 @@ Extension [ <persistent> extension #119 ddtrace version 0.54.0 ] {
}
- Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.54.0 }
+ Constant [ string DD_TRACE_VERSION ] { 0.56.0 }
}
- Functions {
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index e278fa4..ac727b2 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -26,7 +26,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.54.0
+Version: 0.56.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -59,6 +59,9 @@ BuildRequires: %{?scl_prefix}php-posix
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+%if "%{php_version}" > "8.0"
+Requires: %{?scl_prefix}php-curl%{?_isa}
+%endif
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -183,34 +186,43 @@ rm ?TS/tests/ext/sandbox/memory_limit_graceful_bailout.phpt
%if "%{php_version}" > "8.0"
rm ?TS/tests/ext/sandbox/fatal_errors_are_tracked_005.phpt
%endif
+# XFAIL
+rm ?TS/tests/ext/sandbox/hook_function/01.phpt
+rm ?TS/tests/ext/sandbox/hook_method/01.phpt
+# DEP for ext dependencies, MOD for ext used in tests
+DEP=""
MOD="-n -d ddtrace.request_init_hook="
+%if "%{php_version}" > "8.0"
+[ -f %{php_extdir}/curl.so ] && DEP="$DEP -d extension=curl.so"
+%else
[ -f %{php_extdir}/curl.so ] && MOD="$MOD -d extension=curl.so"
+%endif
[ -f %{php_extdir}/json.so ] && MOD="$MOD -d extension=json.so"
[ -f %{php_extdir}/posix.so ] && MOD="$MOD -d extension=posix.so"
cd NTS
: Minimal load test for NTS extension
-%{__php} --no-php-ini \
+%{__php} --no-php-ini $DEP \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
+ --modules | grep -i '^%{pecl_name}$'
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="$MOD -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="$DEP $MOD -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
+%{__ztsphp} --no-php-ini $DEP \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
+ --modules | grep -i '^%{pecl_name}$'
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="$MOD -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="$DEP $MOD -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -253,6 +265,14 @@ fi
%changelog
+* Fri Mar 5 2021 Remi Collet <remi@remirepo.net> - 0.56.0-1
+- update to 0.56.0
+
+* Fri Feb 5 2021 Remi Collet <remi@remirepo.net> - 0.55.0-1
+- update to 0.55.0
+- open https://github.com/DataDog/dd-trace-php/pull/1144
+ add missing dependency on curl extension for PHP 8
+
* Thu Jan 21 2021 Remi Collet <remi@remirepo.net> - 0.54.0-1
- update to 0.54.0