summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-datadog-trace.spec11
-rw-r--r--php74.patch37
4 files changed, 49 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
index fb3ced5..85edbc6 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,7 +7,7 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2019
Datadog tracing support => enabled
-Version => 0.30.0
+Version => 0.30.2
Directive => Local Value => Master Value
ddtrace.disable => Off => Off
diff --git a/REFLECTION b/REFLECTION
index d8ca804..0b217fe 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #85 ddtrace version 0.30.0 ] {
+Extension [ <persistent> extension #85 ddtrace version 0.30.2 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -16,7 +16,7 @@ Extension [ <persistent> extension #85 ddtrace version 0.30.0 ] {
}
- Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.30.0 }
+ Constant [ string DD_TRACE_VERSION ] { 0.30.2 }
}
- Functions {
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 32cdcd5..3152ea5 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -34,12 +34,14 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.30.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.30.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{proj_name}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
+Patch0: php74.patch
+
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -109,6 +111,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
cp src/ext/mpack/LICENSE LICENSE.mpack
+%patch0 -p1
: Sanity check, really often broken
extver=$(sed -n '/#define PHP_DDTRACE_VERSION /{s/.* "//;s/".*$//;p}' src/ext/version.h)
@@ -261,6 +264,10 @@ fi
%changelog
+* Thu Sep 19 2019 Remi Collet <remi@remirepo.net> - 0.30.2-1
+- update to 0.30.2
+- add upstream patch for PHP 7.4
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.30.0-2
- rebuild for 7.4.0RC1
diff --git a/php74.patch b/php74.patch
new file mode 100644
index 0000000..41926ff
--- /dev/null
+++ b/php74.patch
@@ -0,0 +1,37 @@
+Adapted for 0.30.2 from upstream patch
+
+
+
+From 433177dd98f81585748e697ebaa104d0ad76a234 Mon Sep 17 00:00:00 2001
+From: Levi Morrison <levi.morrison@datadoghq.com>
+Date: Fri, 23 Aug 2019 08:06:27 -0600
+Subject: [PATCH] Avoid reserved word "fn"
+
+In PHP 7.4 and forward "fn" is a keyword.
+Also fixes misspelling in the name of the file.
+diff --git a/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt b/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt
+--- a/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt
++++ b/tests/ext/desctructor_called_when_this_gets_out_of_scope.phpt
+@@ -16,18 +16,18 @@ class Test {
+ dd_trace("Test", "m", function() {
+ return dd_trace_forward_call() . " OVERRIDE";
+ });
+-function fn() {
++function func() {
+ $test = new Test();
+ echo $test->m() . PHP_EOL;
+- echo "FN" . PHP_EOL;
++ echo "FUNC" . PHP_EOL;
+ }
+
+-fn();
++func();
+ echo "FINISH" . PHP_EOL;
+ ?>
+
+ --EXPECT--
+ M OVERRIDE
+-FN
++FUNC
+ DESTRUCT
+ FINISH