summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION134
-rw-r--r--php-pecl-datadog-trace.spec17
3 files changed, 148 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index c92f67b..a1bb389 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,8 +7,8 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2020
Datadog tracing support => enabled
-Version => 0.48.2
-DATADOG TRACER CONFIGURATION => {"date":"2020-09-11T05:32:23Z","os_name":"Linux builder.remirepo.net 5.7.15-100.fc31.x86_64 #1 SMP Tue Aug 11 17:18:01 UTC 2020 x86_64","os_version":"5.7.15-100.fc31.x86_64","version":"0.48.2","lang":"php","lang_version":"7.3.22","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1.000000,"sampling_rules":null,"tags":null,"service_mapping":null,"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","ddtrace.request_init_hook":"/usr/share/pear/datadog_trace/bridge/dd_wrap_autoloader.php","open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":null,"enabled_from_env":true,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connection refused"}
+Version => 0.49.0
+DATADOG TRACER CONFIGURATION => {"date":"2020-10-15T07:26:43Z","os_name":"Linux builder.remirepo.net 5.8.13-100.fc31.x86_64 #1 SMP Thu Oct 1 21:46:25 UTC 2020 x86_64","os_version":"5.8.13-100.fc31.x86_64","version":"0.49.0","lang":"php","lang_version":"7.3.23","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1.000000,"sampling_rules":null,"tags":null,"service_mapping":null,"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","ddtrace.request_init_hook":"/usr/share/pear/datadog_trace/bridge/dd_wrap_autoloader.php","open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":null,"enabled_from_env":true,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connection refused"}
Diagnostics
agent_error => Failed to connect to localhost port 8126: Connection refused
diff --git a/REFLECTION b/REFLECTION
index 65b38e8..324a211 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
+Extension [ <persistent> extension #116 ddtrace version 0.49.0 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -10,11 +10,17 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
}
- Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.48.2 }
+ Constant [ string DD_TRACE_VERSION ] { 0.49.0 }
}
- Functions {
Function [ <internal:ddtrace> function dd_trace ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $class_or_function_name ]
+ Parameter #1 [ <required> $method_name_or_tracing_closure ]
+ Parameter #2 [ <optional> $tracing_closure ]
+ }
}
Function [ <internal:ddtrace> function dd_trace_buffer_span ] {
@@ -23,14 +29,29 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
}
}
Function [ <internal:ddtrace> function dd_trace_check_memory_under_limit ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_closed_spans_count ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_coms_trigger_writer_flush ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_dd_get_memory_limit ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_disable_in_request ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_env_config ] {
@@ -39,16 +60,37 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
}
}
Function [ <internal:ddtrace> function dd_trace_forward_call ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_generate_id ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $existing_id ]
+ }
}
Function [ <internal:ddtrace> function dd_trace_internal_fn ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $function_name ]
+ Parameter #1 [ <optional> ...$vars ]
+ }
}
Function [ <internal:ddtrace> function dd_trace_noop ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_peek_span_id ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_pop_span_id ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_push_span_id ] {
@@ -57,6 +99,9 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
}
}
Function [ <internal:ddtrace> function dd_trace_reset ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_trace_send_traces_via_thread ] {
@@ -84,16 +129,35 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
}
}
Function [ <internal:ddtrace> function dd_trace_tracer_is_limited ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_can_try ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_info ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_register_error ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_register_success ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:ddtrace> function dd_untrace ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $function_name ]
+ }
}
Function [ <internal:ddtrace> function dd_trace_compile_time_microseconds ] {
@@ -192,9 +256,16 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
Parameter #0 [ <required> $integration_name ]
}
}
+ Function [ <internal:ddtrace> function DDTrace\Testing\trigger_error ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $level ]
+ Parameter #1 [ <required> $message ]
+ }
+ }
}
- - Classes [1] {
+ - Classes [2] {
Class [ <internal:ddtrace> class DDTrace\SpanData ] {
- Constants [0] {
@@ -218,6 +289,63 @@ Extension [ <persistent> extension #117 ddtrace version 0.48.2 ] {
- Methods [0] {
}
}
+
+ Class [ <internal:ddtrace> class DDTrace\FatalError extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 3118678..8c81ce1 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -26,7 +26,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.48.2
+Version: 0.49.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -42,7 +42,7 @@ BuildRequires: devtoolset-6-toolchain
%else
BuildRequires: %{?dtsprefix}gcc
%endif
-BuildRequires: %{?scl_prefix}php-devel > 5.6
+BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: curl-devel
# For tests
@@ -77,6 +77,9 @@ Obsoletes: php73-pecl-%{safe_name} <= %{version}
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{safe_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{safe_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -189,6 +192,9 @@ done
# Erratic results
rm ?TS/tests/ext/segfault_backtrace_*.phpt
rm ?TS/tests/ext/sandbox/memory_limit_graceful_bailout.phpt
+%if "%{php_version}" > "8.0"
+rm ?TS/tests/ext/sandbox/fatal_errors_are_tracked_005.phpt
+%endif
MOD="-n -d ddtrace.request_init_hook="
[ -f %{php_extdir}/curl.so ] && MOD="$MOD -d extension=curl.so"
@@ -259,6 +265,13 @@ fi
%changelog
+* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 0.49.0-1
+- update to 0.49.0
+- allow PHP 5.4 and 5.5
+
+* Tue Sep 22 2020 Remi Collet <remi@remirepo.net> - 0.48.3-1
+- update to 0.48.3
+
* Fri Sep 11 2020 Remi Collet <remi@remirepo.net> - 0.48.2-1
- update to 0.48.2