summaryrefslogtreecommitdiffstats
path: root/php-pecl-datadog-trace.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-23 09:10:22 +0100
committerRemi Collet <remi@php.net>2021-12-23 09:10:22 +0100
commitc89404063dc9d2d3decd4463fdc9f8b72386295f (patch)
tree7dd210c5cf4fb4510544182947efa404f0aa82f0 /php-pecl-datadog-trace.spec
parente3c444ac995a040639768036c3589c6857e2b315 (diff)
update to 0.68.0
Diffstat (limited to 'php-pecl-datadog-trace.spec')
-rw-r--r--php-pecl-datadog-trace.spec19
1 files changed, 8 insertions, 11 deletions
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index b5e5a46..891e52b 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -26,7 +26,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.67.0
+Version: 0.68.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -48,9 +48,9 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: curl-devel
-# For tests
-BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
+BuildRequires: %{?scl_prefix}php-curl
+# For tests
BuildRequires: %{?scl_prefix}php-posix
#BuildRequires: gdb
#BuildRequires: %%{?scl_prefix}php-debuginfo
@@ -59,6 +59,7 @@ BuildRequires: %{?scl_prefix}php-posix
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+Requires: %{?scl_prefix}php-json%{?_isa}
%if "%{php_version}" > "8.0"
Requires: %{?scl_prefix}php-curl%{?_isa}
%endif
@@ -110,7 +111,6 @@ sed -e 's:@php_dir@:%{pear_phpdir}:' \
-i ext/php?/ddtrace.c \
ext/php?/configuration.h
-cp ext/vendor/mpack/LICENSE LICENSE.mpack
: Sanity check, really often broken
extver=$(sed -n '/#define PHP_DDTRACE_VERSION /{s/.* "//;s/".*$//;p}' ext/version.h)
if test "x${extver}" != "x%{version}"; then
@@ -204,7 +204,7 @@ MOD="-n -d ddtrace.request_init_hook="
%else
[ -f %{php_extdir}/curl.so ] && MOD="$MOD -d extension=curl.so"
%endif
-[ -f %{php_extdir}/json.so ] && MOD="$MOD -d extension=json.so"
+[ -f %{php_extdir}/json.so ] && DEP="$DEP -d extension=json.so"
[ -f %{php_extdir}/posix.so ] && MOD="$MOD -d extension=posix.so"
cd NTS
@@ -225,12 +225,6 @@ cd ../ZTS
%{__ztsphp} --no-php-ini $DEP \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep -i '^%{pecl_name}$'
-
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="$DEP $MOD -d extension=$PWD/modules/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -271,6 +265,9 @@ fi
%changelog
+* Thu Dec 23 2021 Remi Collet <remi@remirepo.net> - 0.68.0-1
+- update to 0.68.0
+
* Tue Nov 2 2021 Remi Collet <remi@remirepo.net> - 0.67.0-1
- update to 0.67.0