summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION466
-rw-r--r--php-pecl-crypto.spec73
2 files changed, 435 insertions, 104 deletions
diff --git a/REFLECTION b/REFLECTION
index 522642d..d26d2dc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
+Extension [ <persistent> extension #84 crypto version 0.2.1 ] {
- - Classes [9] {
- Class [ <internal:crypto> class Crypto\Algorithm ] {
+ - Classes [13] {
+ Class [ <internal:crypto> class Crypto\CryptoException extends Exception ] {
- Constants [0] {
}
@@ -12,57 +12,85 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ <default> protected $algorithm ]
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
}
- - Methods [2] {
- Method [ <internal:crypto, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- - Parameters [1] {
- Parameter #0 [ <required> $algorithm ]
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
}
}
- Method [ <internal:crypto> public method getAlgorithmName ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:crypto> class Crypto\AlgorithmException extends Exception ] {
-
- - Constants [31] {
- Constant [ integer CIPHER_NOT_FOUND ] { 1 }
- Constant [ integer CIPHER_MODE_NOT_FOUND ] { 2 }
- Constant [ integer CIPHER_MODE_NOT_AVAILABLE ] { 3 }
- Constant [ integer CIPHER_AUTHENTICATION_NOT_SUPPORTED ] { 4 }
- Constant [ integer CIPHER_AUTHENTICATION_FAILED ] { 5 }
- Constant [ integer CIPHER_KEY_LENGTH ] { 6 }
- Constant [ integer CIPHER_IV_LENGTH ] { 7 }
- Constant [ integer CIPHER_AAD_SETTER_FLOW ] { 8 }
- Constant [ integer CIPHER_AAD_SETTER_FAILED ] { 9 }
- Constant [ integer CIPHER_TAG_GETTER_FLOW ] { 10 }
- Constant [ integer CIPHER_TAG_SETTER_FLOW ] { 11 }
- Constant [ integer CIPHER_TAG_GETTER_FAILED ] { 12 }
- Constant [ integer CIPHER_TAG_SETTER_FAILED ] { 13 }
- Constant [ integer CIPHER_TAG_LENGTH_UNDER ] { 14 }
- Constant [ integer CIPHER_TAG_LENGTH_OVER ] { 15 }
- Constant [ integer CIPHER_TAG_VARIFY_FAILED ] { 16 }
- Constant [ integer CIPHER_INIT_ALG_FAILED ] { 17 }
- Constant [ integer CIPHER_INIT_CTX_FAILED ] { 18 }
- Constant [ integer CIPHER_UPDATE_FAILED ] { 19 }
- Constant [ integer CIPHER_FINISH_FAILED ] { 20 }
- Constant [ integer ENCRYPT_INIT_STATUS ] { 21 }
- Constant [ integer ENCRYPT_UPDATE_STATUS ] { 22 }
- Constant [ integer ENCRYPT_FINISH_STATUS ] { 23 }
- Constant [ integer DECRYPT_INIT_STATUS ] { 24 }
- Constant [ integer DECRYPT_UPDATE_STATUS ] { 25 }
- Constant [ integer DECRYPT_FINISH_STATUS ] { 26 }
- Constant [ integer HASH_ALGORITHM_NOT_FOUND ] { 27 }
- Constant [ integer HASH_STATIC_NOT_FOUND ] { 28 }
- Constant [ integer HASH_INIT_FAILED ] { 29 }
- Constant [ integer HASH_UPDATE_FAILED ] { 30 }
- Constant [ integer HASH_DIGEST_FAILED ] { 31 }
+ Class [ <internal:crypto> class Crypto\CipherException extends Crypto\CryptoException ] {
+
+ - Constants [30] {
+ Constant [ integer ALGORITHM_NOT_FOUND ] { 1 }
+ Constant [ integer STATIC_METHOD_NOT_FOUND ] { 2 }
+ Constant [ integer STATIC_METHOD_TOO_MANY_ARGS ] { 3 }
+ Constant [ integer MODE_NOT_FOUND ] { 4 }
+ Constant [ integer MODE_NOT_AVAILABLE ] { 5 }
+ Constant [ integer AUTHENTICATION_NOT_SUPPORTED ] { 6 }
+ Constant [ integer KEY_LENGTH_INVALID ] { 7 }
+ Constant [ integer IV_LENGTH_INVALID ] { 8 }
+ Constant [ integer AAD_SETTER_FORBIDDEN ] { 9 }
+ Constant [ integer AAD_SETTER_FAILED ] { 10 }
+ Constant [ integer AAD_LENGTH_HIGH ] { 11 }
+ Constant [ integer TAG_GETTER_FORBIDDEN ] { 12 }
+ Constant [ integer TAG_SETTER_FORBIDDEN ] { 13 }
+ Constant [ integer TAG_GETTER_FAILED ] { 14 }
+ Constant [ integer TAG_SETTER_FAILED ] { 15 }
+ Constant [ integer TAG_LENGTH_SETTER_FORBIDDEN ] { 16 }
+ Constant [ integer TAG_LENGTH_LOW ] { 17 }
+ Constant [ integer TAG_LENGTH_HIGH ] { 18 }
+ Constant [ integer TAG_VERIFY_FAILED ] { 19 }
+ Constant [ integer INIT_ALG_FAILED ] { 20 }
+ Constant [ integer INIT_CTX_FAILED ] { 21 }
+ Constant [ integer INIT_ENCRYPT_FORBIDDEN ] { 22 }
+ Constant [ integer INIT_DECRYPT_FORBIDDEN ] { 23 }
+ Constant [ integer UPDATE_FAILED ] { 24 }
+ Constant [ integer UPDATE_ENCRYPT_FORBIDDEN ] { 25 }
+ Constant [ integer UPDATE_DECRYPT_FORBIDDEN ] { 26 }
+ Constant [ integer FINISH_FAILED ] { 27 }
+ Constant [ integer FINISH_ENCRYPT_FORBIDDEN ] { 28 }
+ Constant [ integer FINISH_DECRYPT_FORBIDDEN ] { 29 }
+ Constant [ integer INPUT_DATA_LENGTH_HIGH ] { 30 }
}
- Static properties [0] {
@@ -78,7 +106,7 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -88,6 +116,9 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -114,7 +145,7 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
- Class [ <internal:crypto> class Crypto\Cipher extends Crypto\Algorithm ] {
+ Class [ <internal:crypto> class Crypto\Cipher ] {
- Constants [8] {
Constant [ integer MODE_ECB ] { 1 }
@@ -166,8 +197,8 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Property [ <default> protected $algorithm ]
}
- - Methods [17] {
- Method [ <internal:crypto, overwrites Crypto\Algorithm, ctor> public method __construct ] {
+ - Methods [18] {
+ Method [ <internal:crypto, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <required> $algorithm ]
@@ -176,6 +207,9 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
+ Method [ <internal:crypto> public method getAlgorithmName ] {
+ }
+
Method [ <internal:crypto> public method encryptInit ] {
- Parameters [2] {
@@ -243,16 +277,19 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
Method [ <internal:crypto> public method getTag ] {
+ }
+
+ Method [ <internal:crypto> public method setTag ] {
- Parameters [1] {
- Parameter #0 [ <required> $tag_size ]
+ Parameter #0 [ <required> $tag ]
}
}
- Method [ <internal:crypto> public method setTag ] {
+ Method [ <internal:crypto> public method setTagLength ] {
- Parameters [1] {
- Parameter #0 [ <required> $tag ]
+ Parameter #0 [ <required> $tag_length ]
}
}
@@ -262,13 +299,10 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Parameter #0 [ <required> $aad ]
}
}
-
- Method [ <internal:crypto, inherits Crypto\Algorithm> public method getAlgorithmName ] {
- }
}
}
- Class [ <internal:crypto> class Crypto\Hash extends Crypto\Algorithm ] {
+ Class [ <internal:crypto> class Crypto\Hash ] {
- Constants [0] {
}
@@ -306,7 +340,7 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
- Methods [7] {
- Method [ <internal:crypto, overwrites Crypto\Algorithm, ctor> public method __construct ] {
+ Method [ <internal:crypto, ctor> public method __construct ] {
- Parameters [1] {
Parameter #0 [ <required> $algorithm ]
@@ -320,6 +354,9 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
+ Method [ <internal:crypto> public method getAlgorithmName ] {
+ }
+
Method [ <internal:crypto> public method digest ] {
}
@@ -331,13 +368,74 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Method [ <internal:crypto> public method getBlockSize ] {
}
+ }
+ }
+
+ Class [ <internal:crypto> class Crypto\HashException extends Crypto\CryptoException ] {
+
+ - Constants [7] {
+ Constant [ integer ALGORITHM_NOT_FOUND ] { 1 }
+ Constant [ integer STATIC_METHOD_NOT_FOUND ] { 2 }
+ Constant [ integer STATIC_METHOD_TOO_MANY_ARGS ] { 3 }
+ Constant [ integer INIT_FAILED ] { 4 }
+ Constant [ integer UPDATE_FAILED ] { 5 }
+ Constant [ integer DIGEST_FAILED ] { 6 }
+ Constant [ integer INPUT_DATA_LENGTH_HIGH ] { 7 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
- Method [ <internal:crypto, inherits Crypto\Algorithm> public method getAlgorithmName ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:crypto> class Crypto\HMAC extends Crypto\Hash ] {
+ Class [ <internal:crypto> abstract class Crypto\MAC extends Crypto\Hash ] {
- Constants [0] {
}
@@ -375,10 +473,146 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
- Methods [7] {
- Method [ <internal:crypto, inherits Crypto\Hash, ctor> public method __construct ] {
+ Method [ <internal:crypto, overwrites Crypto\Hash, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $algorithm ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method update ] {
- Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getAlgorithmName ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method digest ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method hexdigest ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getSize ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getBlockSize ] {
+ }
+ }
+ }
+
+ Class [ <internal:crypto> class Crypto\MACException extends Crypto\HashException ] {
+
+ - Constants [8] {
+ Constant [ integer ALGORITHM_NOT_FOUND ] { 1 }
+ Constant [ integer STATIC_METHOD_NOT_FOUND ] { 2 }
+ Constant [ integer STATIC_METHOD_TOO_MANY_ARGS ] { 3 }
+ Constant [ integer INIT_FAILED ] { 4 }
+ Constant [ integer UPDATE_FAILED ] { 5 }
+ Constant [ integer DIGEST_FAILED ] { 6 }
+ Constant [ integer INPUT_DATA_LENGTH_HIGH ] { 7 }
+ Constant [ integer KEY_LENGTH_INVALID ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:crypto> class Crypto\HMAC extends Crypto\MAC ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:crypto, inherits Crypto\Hash> static public method getAlgorithms ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $aliases ]
+ Parameter #1 [ <optional> $prefix ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> static public method hasAlgorithm ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $algorithm ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> static public method __callStatic ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $arguments ]
+ }
+ }
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $algorithm ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:crypto, inherits Crypto\MAC, ctor> public method __construct ] {
+
+ - Parameters [2] {
Parameter #0 [ <required> $algorithm ]
+ Parameter #1 [ <required> $key ]
}
}
@@ -389,6 +623,9 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getAlgorithmName ] {
+ }
+
Method [ <internal:crypto, inherits Crypto\Hash> public method digest ] {
}
@@ -400,8 +637,75 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Method [ <internal:crypto, inherits Crypto\Hash> public method getBlockSize ] {
}
+ }
+ }
+
+ Class [ <internal:crypto> class Crypto\CMAC extends Crypto\MAC ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:crypto, inherits Crypto\Hash> static public method getAlgorithms ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $aliases ]
+ Parameter #1 [ <optional> $prefix ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> static public method hasAlgorithm ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $algorithm ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> static public method __callStatic ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $arguments ]
+ }
+ }
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $algorithm ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:crypto, inherits Crypto\MAC, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $algorithm ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method update ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getAlgorithmName ] {
+ }
- Method [ <internal:crypto, inherits Crypto\Algorithm> public method getAlgorithmName ] {
+ Method [ <internal:crypto, inherits Crypto\Hash> public method digest ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method hexdigest ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getSize ] {
+ }
+
+ Method [ <internal:crypto, inherits Crypto\Hash> public method getBlockSize ] {
}
}
}
@@ -459,14 +763,15 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
- Class [ <internal:crypto> class Crypto\Base64Exception extends Exception ] {
+ Class [ <internal:crypto> class Crypto\Base64Exception extends Crypto\CryptoException ] {
- - Constants [5] {
- Constant [ integer ENCODE_UPDATE_STATUS ] { 1 }
- Constant [ integer ENCODE_FINISH_STATUS ] { 2 }
- Constant [ integer DECODE_UPDATE_STATUS ] { 3 }
- Constant [ integer DECODE_FINISH_STATUS ] { 4 }
- Constant [ integer DECODE_FAILED ] { 5 }
+ - Constants [6] {
+ Constant [ integer ENCODE_UPDATE_FORBIDDEN ] { 1 }
+ Constant [ integer ENCODE_FINISH_FORBIDDEN ] { 2 }
+ Constant [ integer DECODE_UPDATE_FORBIDDEN ] { 3 }
+ Constant [ integer DECODE_FINISH_FORBIDDEN ] { 4 }
+ Constant [ integer DECODE_UPDATE_FAILED ] { 5 }
+ Constant [ integer INPUT_DATA_LENGTH_HIGH ] { 6 }
}
- Static properties [0] {
@@ -482,7 +787,7 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -492,6 +797,9 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -526,7 +834,7 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
- Static properties [0] {
}
- - Static methods [6] {
+ - Static methods [5] {
Method [ <internal:crypto> static public method generate ] {
- Parameters [3] {
@@ -561,15 +869,6 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Parameter #0 [ <required> $filename ]
}
}
-
- Method [ <internal:crypto> static public method egd ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $bytes ]
- Parameter #2 [ <optional> $seed ]
- }
- }
}
- Properties [0] {
@@ -579,11 +878,13 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
- Class [ <internal:crypto> class Crypto\RandException extends Exception ] {
+ Class [ <internal:crypto> class Crypto\RandException extends Crypto\CryptoException ] {
- - Constants [2] {
+ - Constants [4] {
Constant [ integer GENERATE_PREDICTABLE ] { 1 }
Constant [ integer FILE_WRITE_PREDICTABLE ] { 2 }
+ Constant [ integer REQUESTED_BYTES_NUMBER_TOO_HIGH ] { 3 }
+ Constant [ integer SEED_LENGTH_TOO_HIGH ] { 4 }
}
- Static properties [0] {
@@ -599,7 +900,7 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -609,6 +910,9 @@ Extension [ <persistent> extension #78 crypto version 0.1.1 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
diff --git a/php-pecl-crypto.spec b/php-pecl-crypto.spec
index 6d54b0d..07def8f 100644
--- a/php-pecl-crypto.spec
+++ b/php-pecl-crypto.spec
@@ -11,7 +11,7 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name crypto
%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
%if "%{php_version}" < "5.6"
@@ -22,13 +22,16 @@
Summary: Wrapper for OpenSSL Crypto Library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.1.1
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 0.2.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# https://github.com/bukka/php-crypto/pull/13
+Patch0: %{pecl_name}-ccm.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
@@ -38,8 +41,6 @@ BuildRequires: openssl-devel
BuildRequires: pkgconfig(openssl)
%endif
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -48,20 +49,27 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# For morephp SCLs
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name}
-Obsoletes: php56w-pecl-%{pecl_name}
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -75,12 +83,19 @@ Obsoletes: php56w-pecl-%{pecl_name}
%description
This package provides an objective wrapper for OpenSSL Crypto Library.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
%prep
%setup -q -c
mv %{pecl_name}-%{version} NTS
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
cd NTS
+%patch0 -p1 -b .ccm
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_CRYPTO_VERSION/{s/.* "//;s/".*$//;p}' php_crypto.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -136,21 +151,26 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
-for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
+# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -168,7 +188,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
+%{__php} -n run-tests.php --show-diff
%endif
%if %{with_zts}
@@ -184,7 +204,7 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
+%{__ztsphp} -n run-tests.php --show-diff
%endif
%endif
@@ -195,8 +215,8 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
-%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -209,6 +229,13 @@ rm -rf %{buildroot}
%changelog
+* Mon Nov 16 2015 Remi Collet <remi@fedoraproject.org> - 0.2.1-1
+- Update to 0.2.1
+- don't install/register tests
+- drop runtime dependency on pear, new scriptlets
+- improve skip check for CCM test when not available
+ open https://github.com/bukka/php-crypto/pull/13
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-3.1
- Fedora 21 SCL mass rebuild