summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION144
-rw-r--r--php-pecl-couchbase3.spec9
3 files changed, 132 insertions, 29 deletions
diff --git a/PHPINFO b/PHPINFO
index 15d1842..b8e1ac8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase support => enabled
-extension version => 3.0.4
-libcouchbase runtime version => 3.0.6 (git: e7b53f01b5c8653e4f4c3ea87e6e1af9c1277a34)
-libcouchbase headers version => 3.0.6 (git: e7b53f01b5c8653e4f4c3ea87e6e1af9c1277a34)
+extension version => 3.1.0
+libcouchbase runtime version => 3.0.7 (git: d2d3666e269b41413408aaae96eb289f1cb4f8ec)
+libcouchbase headers version => 3.0.7 (git: d2d3666e269b41413408aaae96eb289f1cb4f8ec)
zlib compressor => enabled
Directive => Local Value => Master Value
@@ -13,6 +13,6 @@ couchbase.encoder.format => json => json
couchbase.encoder.compression => off => off
couchbase.encoder.compression_threshold => 0 => 0
couchbase.encoder.compression_factor => 0.0 => 0.0
-couchbase.decoder.json_arrays => 0 => 0
+couchbase.decoder.json_arrays => 1 => 1
couchbase.pool.max_idle_time_sec => 60 => 60
couchbase.allow_fallback_to_bucket_connection => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index a919ee4..a653fdc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
+Extension [ <persistent> extension #119 couchbase version 3.1.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -21,7 +21,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
Current = '0.0'
}
Entry [ couchbase.decoder.json_arrays <ALL> ]
- Current = '0'
+ Current = '1'
}
Entry [ couchbase.pool.max_idle_time_sec <ALL> ]
Current = '60'
@@ -880,7 +880,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [7] {
+ - Properties [8] {
Property [ <default> private $cas ]
Property [ <default> private $data ]
Property [ <default> private $expiry ]
@@ -888,6 +888,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
Property [ <default> private $status ]
Property [ <default> private $err_ctx ]
Property [ <default> private $err_ref ]
+ Property [ <default> private $decoder ]
}
- Methods [3] {
@@ -4983,7 +4984,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
Property [ <default> private $name ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase, ctor> public method __construct ] {
- Parameters [2] {
@@ -5006,6 +5007,15 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\Collection ]
}
+
+ Method [ <internal:couchbase> public method query ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $statement ]
+ Parameter #1 [ <optional> Couchbase\QueryOptions or NULL $queryOptions ]
+ }
+ - Return [ Couchbase\QueryResult ]
+ }
}
}
@@ -9035,13 +9045,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
Property [ <default> private $timeout ]
Property [ <default> private $with_expiry ]
Property [ <default> private $project ]
+ Property [ <default> private $decoder ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9065,6 +9076,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\GetOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetOptions ]
+ }
}
}
@@ -9079,11 +9098,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9091,6 +9111,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\GetAndTouchOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAndTouchOptions ]
+ }
}
}
@@ -9105,11 +9133,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9117,6 +9146,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\GetAndLockOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAndLockOptions ]
+ }
}
}
@@ -9131,11 +9168,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9143,6 +9181,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\GetAllReplicasOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAllReplicasOptions ]
+ }
}
}
@@ -9157,11 +9203,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9169,6 +9216,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\GetAnyReplicaOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAnyReplicaOptions ]
+ }
}
}
@@ -9235,13 +9290,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
Property [ <default> private $timeout ]
Property [ <default> private $expiry ]
Property [ <default> private $durability_level ]
+ Property [ <default> private $encoder ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9265,6 +9321,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\InsertOptions ]
}
+
+ Method [ <internal:couchbase> public method encoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\InsertOptions ]
+ }
}
}
@@ -9279,14 +9343,15 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> private $cas ]
Property [ <default> private $timeout ]
Property [ <default> private $expiry ]
Property [ <default> private $durability_level ]
+ Property [ <default> private $encoder ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase> public method cas ] {
- Parameters [1] {
@@ -9318,6 +9383,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\UpsertOptions ]
}
+
+ Method [ <internal:couchbase> public method encoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\UpsertOptions ]
+ }
}
}
@@ -9332,14 +9405,15 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> private $cas ]
Property [ <default> private $timeout ]
Property [ <default> private $expiry ]
Property [ <default> private $durability_level ]
+ Property [ <default> private $encoder ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase> public method cas ] {
- Parameters [1] {
@@ -9371,6 +9445,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\ReplaceOptions ]
}
+
+ Method [ <internal:couchbase> public method encoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\ReplaceOptions ]
+ }
}
}
@@ -10006,7 +10088,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [16] {
+ - Properties [18] {
Property [ <default> private $timeout ]
Property [ <default> private $adhoc ]
Property [ <default> private $metrics ]
@@ -10023,9 +10105,11 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
Property [ <default> private $max_parallelism ]
Property [ <default> private $profile ]
Property [ <default> private $client_context_id ]
+ Property [ <default> private $scope_name ]
+ Property [ <default> private $scope_qualifier ]
}
- - Methods [16] {
+ - Methods [18] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -10154,6 +10238,22 @@ Extension [ <persistent> extension #117 couchbase version 3.0.4 ] {
}
- Return [ Couchbase\QueryOptions ]
}
+
+ Method [ <internal:couchbase> public method scopeName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $value ]
+ }
+ - Return [ Couchbase\QueryOptions ]
+ }
+
+ Method [ <internal:couchbase> public method scopeQualifier ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $value ]
+ }
+ - Return [ Couchbase\QueryOptions ]
+ }
}
}
diff --git a/php-pecl-couchbase3.spec b/php-pecl-couchbase3.spec
index 5863945..71e04ac 100644
--- a/php-pecl-couchbase3.spec
+++ b/php-pecl-couchbase3.spec
@@ -3,7 +3,7 @@
#
# remirepo spec file for php-pecl-couchbase3
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,7 +22,7 @@
Summary: Couchbase Server PHP extension
Name: php-pecl-couchbase3
-Version: 3.0.5
+Version: 3.1.0
Release: 1%{?dist}
License: PHP
URL: https://pecl.php.net/package/couchbase
@@ -91,7 +91,7 @@ extension=%{pecl_name}.so
;couchbase.encoder.compression = 'off'
;couchbase.encoder.compression_threshold = 0
;couchbase.encoder.compression_factor = 0.0
-;couchbase.decoder.json_arrays = 0
+;couchbase.decoder.json_arrays = 1
;couchbase.pool.max_idle_time_sec = 60
;couchbase.allow_fallback_to_bucket_connection = 0
EOF
@@ -179,6 +179,9 @@ done
%changelog
+* Thu Jan 21 2021 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 3.0.5-1
- update to 3.0.5