summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION374
-rw-r--r--php-pecl-couchbase2.spec24
3 files changed, 199 insertions, 203 deletions
diff --git a/PHPINFO b/PHPINFO
index 7916873..39b6a80 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ couchbase
couchbase support => enabled
extension version => 2.6.1
-libcouchbase runtime version => 2.10.3 (git: b387722192f0bc49b0a846859610493e2f8129cd)
-libcouchbase headers version => 2.10.3 (git: b387722192f0bc49b0a846859610493e2f8129cd)
+libcouchbase runtime version => 2.10.5 (git: dabf6d58c2e89b4e75009a7f959e8ad30f85ff98)
+libcouchbase headers version => 2.10.5 (git: dabf6d58c2e89b4e75009a7f959e8ad30f85ff98)
igbinary transcoder => enabled
zlib compressor => enabled
diff --git a/REFLECTION b/REFLECTION
index 3265a08..1348b10 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
+Extension [ <persistent> extension #108 couchbase version 2.6.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -29,168 +29,170 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
}
}
- - Constants [161] {
- Constant [ integer COUCHBASE_PERSISTTO_MASTER ] { 1 }
- Constant [ integer COUCHBASE_PERSISTTO_ONE ] { 1 }
- Constant [ integer COUCHBASE_PERSISTTO_TWO ] { 2 }
- Constant [ integer COUCHBASE_PERSISTTO_THREE ] { 4 }
- Constant [ integer COUCHBASE_REPLICATETO_ONE ] { 16 }
- Constant [ integer COUCHBASE_REPLICATETO_TWO ] { 32 }
- Constant [ integer COUCHBASE_REPLICATETO_THREE ] { 64 }
- Constant [ integer COUCHBASE_SDCMD_GET ] { 1 }
- Constant [ integer COUCHBASE_SDCMD_REPLACE ] { 3 }
- Constant [ integer COUCHBASE_SDCMD_EXISTS ] { 2 }
- Constant [ integer COUCHBASE_SDCMD_DICT_ADD ] { 4 }
- Constant [ integer COUCHBASE_SDCMD_DICT_UPSERT ] { 5 }
- Constant [ integer COUCHBASE_SDCMD_ARRAY_ADD_FIRST ] { 6 }
- Constant [ integer COUCHBASE_SDCMD_ARRAY_ADD_LAST ] { 7 }
- Constant [ integer COUCHBASE_SDCMD_ARRAY_INSERT ] { 9 }
- Constant [ integer COUCHBASE_SDCMD_ARRAY_ADD_UNIQUE ] { 8 }
- Constant [ integer COUCHBASE_SDCMD_COUNTER ] { 10 }
- Constant [ integer COUCHBASE_SDCMD_REMOVE ] { 11 }
- Constant [ integer COUCHBASE_CNTL_OP_TIMEOUT ] { 0 }
- Constant [ integer COUCHBASE_CNTL_VIEW_TIMEOUT ] { 1 }
- Constant [ integer COUCHBASE_CNTL_DURABILITY_INTERVAL ] { 14 }
- Constant [ integer COUCHBASE_CNTL_DURABILITY_TIMEOUT ] { 13 }
- Constant [ integer COUCHBASE_CNTL_HTTP_TIMEOUT ] { 15 }
- Constant [ integer COUCHBASE_CNTL_CONFIGURATION_TIMEOUT ] { 18 }
- Constant [ integer COUCHBASE_CNTL_CONFDELAY_THRESH ] { 25 }
- Constant [ integer COUCHBASE_CNTL_CONFIG_NODE_TIMEOUT ] { 27 }
- Constant [ integer COUCHBASE_CNTL_HTCONFIG_IDLE_TIMEOUT ] { 28 }
- Constant [ integer COUCHBASE_VALUE_F_JSON ] { 1 }
- Constant [ integer COUCHBASE_N1XSPEC_T_DEFAULT ] { 0 }
- Constant [ integer COUCHBASE_N1XSPEC_T_GSI ] { 1 }
- Constant [ integer COUCHBASE_N1XSPEC_T_VIEW ] { 2 }
- Constant [ integer COUCHBASE_SUCCESS ] { 0 }
- Constant [ integer COUCHBASE_AUTH_CONTINUE ] { 1 }
- Constant [ integer COUCHBASE_AUTH_ERROR ] { 2 }
- Constant [ integer COUCHBASE_DELTA_BADVAL ] { 3 }
- Constant [ integer COUCHBASE_E2BIG ] { 4 }
- Constant [ integer COUCHBASE_EBUSY ] { 5 }
- Constant [ integer COUCHBASE_EINTERNAL ] { 6 }
- Constant [ integer COUCHBASE_EINVAL ] { 7 }
- Constant [ integer COUCHBASE_ENOMEM ] { 8 }
- Constant [ integer COUCHBASE_ERANGE ] { 9 }
- Constant [ integer COUCHBASE_ERROR ] { 10 }
- Constant [ integer COUCHBASE_ETMPFAIL ] { 11 }
- Constant [ integer COUCHBASE_KEY_EEXISTS ] { 12 }
- Constant [ integer COUCHBASE_KEY_ENOENT ] { 13 }
- Constant [ integer COUCHBASE_DLOPEN_FAILED ] { 14 }
- Constant [ integer COUCHBASE_DLSYM_FAILED ] { 15 }
- Constant [ integer COUCHBASE_NETWORK_ERROR ] { 16 }
- Constant [ integer COUCHBASE_NOT_MY_VBUCKET ] { 17 }
- Constant [ integer COUCHBASE_NOT_STORED ] { 18 }
- Constant [ integer COUCHBASE_NOT_SUPPORTED ] { 19 }
- Constant [ integer COUCHBASE_UNKNOWN_COMMAND ] { 20 }
- Constant [ integer COUCHBASE_UNKNOWN_HOST ] { 21 }
- Constant [ integer COUCHBASE_PROTOCOL_ERROR ] { 22 }
- Constant [ integer COUCHBASE_ETIMEDOUT ] { 23 }
- Constant [ integer COUCHBASE_CONNECT_ERROR ] { 24 }
- Constant [ integer COUCHBASE_BUCKET_ENOENT ] { 25 }
- Constant [ integer COUCHBASE_CLIENT_ENOMEM ] { 26 }
- Constant [ integer COUCHBASE_CLIENT_ENOCONF ] { 27 }
- Constant [ integer COUCHBASE_EBADHANDLE ] { 28 }
- Constant [ integer COUCHBASE_SERVER_BUG ] { 29 }
- Constant [ integer COUCHBASE_PLUGIN_VERSION_MISMATCH ] { 30 }
- Constant [ integer COUCHBASE_INVALID_HOST_FORMAT ] { 31 }
- Constant [ integer COUCHBASE_INVALID_CHAR ] { 32 }
- Constant [ integer COUCHBASE_DURABILITY_ETOOMANY ] { 33 }
- Constant [ integer COUCHBASE_DUPLICATE_COMMANDS ] { 34 }
- Constant [ integer COUCHBASE_NO_MATCHING_SERVER ] { 35 }
- Constant [ integer COUCHBASE_BAD_ENVIRONMENT ] { 36 }
- Constant [ integer COUCHBASE_BUSY ] { 37 }
- Constant [ integer COUCHBASE_INVALID_USERNAME ] { 38 }
- Constant [ integer COUCHBASE_CONFIG_CACHE_INVALID ] { 39 }
- Constant [ integer COUCHBASE_SASLMECH_UNAVAILABLE ] { 40 }
- Constant [ integer COUCHBASE_TOO_MANY_REDIRECTS ] { 41 }
- Constant [ integer COUCHBASE_MAP_CHANGED ] { 42 }
- Constant [ integer COUCHBASE_INCOMPLETE_PACKET ] { 43 }
- Constant [ integer COUCHBASE_ECONNREFUSED ] { 44 }
- Constant [ integer COUCHBASE_ESOCKSHUTDOWN ] { 45 }
- Constant [ integer COUCHBASE_ECONNRESET ] { 46 }
- Constant [ integer COUCHBASE_ECANTGETPORT ] { 47 }
- Constant [ integer COUCHBASE_EFDLIMITREACHED ] { 48 }
- Constant [ integer COUCHBASE_ENETUNREACH ] { 49 }
- Constant [ integer COUCHBASE_ECTL_UNKNOWN ] { 50 }
- Constant [ integer COUCHBASE_ECTL_UNSUPPMODE ] { 51 }
- Constant [ integer COUCHBASE_ECTL_BADARG ] { 52 }
- Constant [ integer COUCHBASE_EMPTY_KEY ] { 53 }
- Constant [ integer COUCHBASE_SSL_ERROR ] { 54 }
- Constant [ integer COUCHBASE_SSL_CANTVERIFY ] { 55 }
- Constant [ integer COUCHBASE_SCHEDFAIL_INTERNAL ] { 56 }
- Constant [ integer COUCHBASE_CLIENT_FEATURE_UNAVAILABLE ] { 57 }
- Constant [ integer COUCHBASE_OPTIONS_CONFLICT ] { 58 }
- Constant [ integer COUCHBASE_HTTP_ERROR ] { 59 }
- Constant [ integer COUCHBASE_DURABILITY_NO_MUTATION_TOKENS ] { 60 }
- Constant [ integer COUCHBASE_UNKNOWN_MEMCACHED_ERROR ] { 61 }
- Constant [ integer COUCHBASE_MUTATION_LOST ] { 62 }
- Constant [ integer COUCHBASE_SUBDOC_PATH_ENOENT ] { 63 }
- Constant [ integer COUCHBASE_SUBDOC_PATH_MISMATCH ] { 64 }
- Constant [ integer COUCHBASE_SUBDOC_PATH_EINVAL ] { 65 }
- Constant [ integer COUCHBASE_SUBDOC_PATH_E2BIG ] { 66 }
- Constant [ integer COUCHBASE_SUBDOC_DOC_E2DEEP ] { 67 }
- Constant [ integer COUCHBASE_SUBDOC_VALUE_CANTINSERT ] { 68 }
- Constant [ integer COUCHBASE_SUBDOC_DOC_NOTJSON ] { 69 }
- Constant [ integer COUCHBASE_SUBDOC_NUM_ERANGE ] { 70 }
- Constant [ integer COUCHBASE_SUBDOC_BAD_DELTA ] { 71 }
- Constant [ integer COUCHBASE_SUBDOC_PATH_EEXISTS ] { 72 }
- Constant [ integer COUCHBASE_SUBDOC_MULTI_FAILURE ] { 73 }
- Constant [ integer COUCHBASE_SUBDOC_VALUE_E2DEEP ] { 74 }
- Constant [ integer COUCHBASE_EINVAL_MCD ] { 75 }
- Constant [ integer COUCHBASE_EMPTY_PATH ] { 76 }
- Constant [ integer COUCHBASE_UNKNOWN_SDCMD ] { 77 }
- Constant [ integer COUCHBASE_ENO_COMMANDS ] { 78 }
- Constant [ integer COUCHBASE_QUERY_ERROR ] { 79 }
- Constant [ integer COUCHBASE_GENERIC_TMPERR ] { 80 }
- Constant [ integer COUCHBASE_GENERIC_SUBDOCERR ] { 81 }
- Constant [ integer COUCHBASE_GENERIC_CONSTRAINT_ERR ] { 82 }
- Constant [ integer COUCHBASE_NAMESERVER_ERROR ] { 83 }
- Constant [ integer COUCHBASE_NOT_AUTHORIZED ] { 84 }
- Constant [ integer COUCHBASE_SUBDOC_INVALID_COMBO ] { 85 }
- Constant [ integer COUCHBASE_SUBDOC_MULTI_PATH_FAILURE ] { 86 }
- Constant [ integer COUCHBASE_SUBDOC_SUCCESS_DELETED ] { 87 }
- Constant [ integer COUCHBASE_SUBDOC_XATTR_INVALID_FLAG_COMBO ] { 88 }
- Constant [ integer COUCHBASE_SUBDOC_XATTR_INVALID_KEY_COMBO ] { 89 }
- Constant [ integer COUCHBASE_SUBDOC_XATTR_UNKNOWN_MACRO ] { 90 }
- Constant [ integer COUCHBASE_SUBDOC_XATTR_UNKNOWN_VATTR ] { 91 }
- Constant [ integer COUCHBASE_SUBDOC_XATTR_CANT_MODIFY_VATTR ] { 92 }
- Constant [ integer COUCHBASE_SUBDOC_MULTI_PATH_FAILURE_DELETED ] { 93 }
- Constant [ integer COUCHBASE_SUBDOC_INVALID_XATTR_ORDER ] { 94 }
- Constant [ integer COUCHBASE_TMPFAIL ] { 11 }
- Constant [ integer COUCHBASE_KEYALREADYEXISTS ] { 12 }
- Constant [ integer COUCHBASE_KEYNOTFOUND ] { 13 }
- Constant [ integer COUCHBASE_VAL_MASK ] { 31 }
- Constant [ integer COUCHBASE_VAL_IS_STRING ] { 0 }
- Constant [ integer COUCHBASE_VAL_IS_LONG ] { 1 }
- Constant [ integer COUCHBASE_VAL_IS_DOUBLE ] { 2 }
- Constant [ integer COUCHBASE_VAL_IS_BOOL ] { 3 }
- Constant [ integer COUCHBASE_VAL_IS_SERIALIZED ] { 4 }
- Constant [ integer COUCHBASE_VAL_IS_IGBINARY ] { 5 }
- Constant [ integer COUCHBASE_VAL_IS_JSON ] { 6 }
- Constant [ integer COUCHBASE_COMPRESSION_MASK ] { 224 }
- Constant [ integer COUCHBASE_COMPRESSION_NONE ] { 0 }
- Constant [ integer COUCHBASE_COMPRESSION_ZLIB ] { 32 }
- Constant [ integer COUCHBASE_COMPRESSION_FASTLZ ] { 64 }
- Constant [ integer COUCHBASE_COMPRESSION_MCISCOMPRESSED ] { 16 }
- Constant [ integer COUCHBASE_SERTYPE_JSON ] { 0 }
- Constant [ integer COUCHBASE_SERTYPE_IGBINARY ] { 1 }
- Constant [ integer COUCHBASE_SERTYPE_PHP ] { 2 }
- Constant [ integer COUCHBASE_CMPRTYPE_NONE ] { 0 }
- Constant [ integer COUCHBASE_CMPRTYPE_ZLIB ] { 1 }
- Constant [ integer COUCHBASE_CMPRTYPE_FASTLZ ] { 2 }
- Constant [ integer COUCHBASE_CFFMT_MASK ] { -16777216 }
- Constant [ integer COUCHBASE_CFFMT_PRIVATE ] { 16777216 }
- Constant [ integer COUCHBASE_CFFMT_JSON ] { 33554432 }
- Constant [ integer COUCHBASE_CFFMT_RAW ] { 50331648 }
- Constant [ integer COUCHBASE_CFFMT_STRING ] { 67108864 }
- Constant [ integer Couchbase\ENCODER_FORMAT_JSON ] { 0 }
- Constant [ integer Couchbase\ENCODER_FORMAT_IGBINARY ] { 1 }
- Constant [ integer Couchbase\ENCODER_FORMAT_PHP ] { 2 }
- Constant [ integer Couchbase\ENCODER_COMPRESSION_NONE ] { 0 }
- Constant [ integer Couchbase\ENCODER_COMPRESSION_ZLIB ] { 1 }
- Constant [ integer Couchbase\ENCODER_COMPRESSION_FASTLZ ] { 2 }
- Constant [ integer Couchbase\HAVE_IGBINARY ] { 1 }
- Constant [ integer Couchbase\HAVE_ZLIB ] { 1 }
+ - Constants [163] {
+ Constant [ int COUCHBASE_PERSISTTO_MASTER ] { 1 }
+ Constant [ int COUCHBASE_PERSISTTO_ONE ] { 1 }
+ Constant [ int COUCHBASE_PERSISTTO_TWO ] { 2 }
+ Constant [ int COUCHBASE_PERSISTTO_THREE ] { 4 }
+ Constant [ int COUCHBASE_REPLICATETO_ONE ] { 16 }
+ Constant [ int COUCHBASE_REPLICATETO_TWO ] { 32 }
+ Constant [ int COUCHBASE_REPLICATETO_THREE ] { 64 }
+ Constant [ int COUCHBASE_SDCMD_GET ] { 1 }
+ Constant [ int COUCHBASE_SDCMD_REPLACE ] { 3 }
+ Constant [ int COUCHBASE_SDCMD_EXISTS ] { 2 }
+ Constant [ int COUCHBASE_SDCMD_DICT_ADD ] { 4 }
+ Constant [ int COUCHBASE_SDCMD_DICT_UPSERT ] { 5 }
+ Constant [ int COUCHBASE_SDCMD_ARRAY_ADD_FIRST ] { 6 }
+ Constant [ int COUCHBASE_SDCMD_ARRAY_ADD_LAST ] { 7 }
+ Constant [ int COUCHBASE_SDCMD_ARRAY_INSERT ] { 9 }
+ Constant [ int COUCHBASE_SDCMD_ARRAY_ADD_UNIQUE ] { 8 }
+ Constant [ int COUCHBASE_SDCMD_COUNTER ] { 10 }
+ Constant [ int COUCHBASE_SDCMD_REMOVE ] { 11 }
+ Constant [ int COUCHBASE_CNTL_OP_TIMEOUT ] { 0 }
+ Constant [ int COUCHBASE_CNTL_VIEW_TIMEOUT ] { 1 }
+ Constant [ int COUCHBASE_CNTL_DURABILITY_INTERVAL ] { 14 }
+ Constant [ int COUCHBASE_CNTL_DURABILITY_TIMEOUT ] { 13 }
+ Constant [ int COUCHBASE_CNTL_HTTP_TIMEOUT ] { 15 }
+ Constant [ int COUCHBASE_CNTL_CONFIGURATION_TIMEOUT ] { 18 }
+ Constant [ int COUCHBASE_CNTL_CONFDELAY_THRESH ] { 25 }
+ Constant [ int COUCHBASE_CNTL_CONFIG_NODE_TIMEOUT ] { 27 }
+ Constant [ int COUCHBASE_CNTL_HTCONFIG_IDLE_TIMEOUT ] { 28 }
+ Constant [ int COUCHBASE_VALUE_F_JSON ] { 1 }
+ Constant [ int COUCHBASE_N1XSPEC_T_DEFAULT ] { 0 }
+ Constant [ int COUCHBASE_N1XSPEC_T_GSI ] { 1 }
+ Constant [ int COUCHBASE_N1XSPEC_T_VIEW ] { 2 }
+ Constant [ int COUCHBASE_SUCCESS ] { 0 }
+ Constant [ int COUCHBASE_AUTH_CONTINUE ] { 1 }
+ Constant [ int COUCHBASE_AUTH_ERROR ] { 2 }
+ Constant [ int COUCHBASE_DELTA_BADVAL ] { 3 }
+ Constant [ int COUCHBASE_E2BIG ] { 4 }
+ Constant [ int COUCHBASE_EBUSY ] { 5 }
+ Constant [ int COUCHBASE_EINTERNAL ] { 6 }
+ Constant [ int COUCHBASE_EINVAL ] { 7 }
+ Constant [ int COUCHBASE_ENOMEM ] { 8 }
+ Constant [ int COUCHBASE_ERANGE ] { 9 }
+ Constant [ int COUCHBASE_ERROR ] { 10 }
+ Constant [ int COUCHBASE_ETMPFAIL ] { 11 }
+ Constant [ int COUCHBASE_KEY_EEXISTS ] { 12 }
+ Constant [ int COUCHBASE_KEY_ENOENT ] { 13 }
+ Constant [ int COUCHBASE_DLOPEN_FAILED ] { 14 }
+ Constant [ int COUCHBASE_DLSYM_FAILED ] { 15 }
+ Constant [ int COUCHBASE_NETWORK_ERROR ] { 16 }
+ Constant [ int COUCHBASE_NOT_MY_VBUCKET ] { 17 }
+ Constant [ int COUCHBASE_NOT_STORED ] { 18 }
+ Constant [ int COUCHBASE_NOT_SUPPORTED ] { 19 }
+ Constant [ int COUCHBASE_UNKNOWN_COMMAND ] { 20 }
+ Constant [ int COUCHBASE_UNKNOWN_HOST ] { 21 }
+ Constant [ int COUCHBASE_PROTOCOL_ERROR ] { 22 }
+ Constant [ int COUCHBASE_ETIMEDOUT ] { 23 }
+ Constant [ int COUCHBASE_CONNECT_ERROR ] { 24 }
+ Constant [ int COUCHBASE_BUCKET_ENOENT ] { 25 }
+ Constant [ int COUCHBASE_CLIENT_ENOMEM ] { 26 }
+ Constant [ int COUCHBASE_CLIENT_ENOCONF ] { 27 }
+ Constant [ int COUCHBASE_EBADHANDLE ] { 28 }
+ Constant [ int COUCHBASE_SERVER_BUG ] { 29 }
+ Constant [ int COUCHBASE_PLUGIN_VERSION_MISMATCH ] { 30 }
+ Constant [ int COUCHBASE_INVALID_HOST_FORMAT ] { 31 }
+ Constant [ int COUCHBASE_INVALID_CHAR ] { 32 }
+ Constant [ int COUCHBASE_DURABILITY_ETOOMANY ] { 33 }
+ Constant [ int COUCHBASE_DUPLICATE_COMMANDS ] { 34 }
+ Constant [ int COUCHBASE_NO_MATCHING_SERVER ] { 35 }
+ Constant [ int COUCHBASE_BAD_ENVIRONMENT ] { 36 }
+ Constant [ int COUCHBASE_BUSY ] { 37 }
+ Constant [ int COUCHBASE_INVALID_USERNAME ] { 38 }
+ Constant [ int COUCHBASE_CONFIG_CACHE_INVALID ] { 39 }
+ Constant [ int COUCHBASE_SASLMECH_UNAVAILABLE ] { 40 }
+ Constant [ int COUCHBASE_TOO_MANY_REDIRECTS ] { 41 }
+ Constant [ int COUCHBASE_MAP_CHANGED ] { 42 }
+ Constant [ int COUCHBASE_INCOMPLETE_PACKET ] { 43 }
+ Constant [ int COUCHBASE_ECONNREFUSED ] { 44 }
+ Constant [ int COUCHBASE_ESOCKSHUTDOWN ] { 45 }
+ Constant [ int COUCHBASE_ECONNRESET ] { 46 }
+ Constant [ int COUCHBASE_ECANTGETPORT ] { 47 }
+ Constant [ int COUCHBASE_EFDLIMITREACHED ] { 48 }
+ Constant [ int COUCHBASE_ENETUNREACH ] { 49 }
+ Constant [ int COUCHBASE_ECTL_UNKNOWN ] { 50 }
+ Constant [ int COUCHBASE_ECTL_UNSUPPMODE ] { 51 }
+ Constant [ int COUCHBASE_ECTL_BADARG ] { 52 }
+ Constant [ int COUCHBASE_EMPTY_KEY ] { 53 }
+ Constant [ int COUCHBASE_SSL_ERROR ] { 54 }
+ Constant [ int COUCHBASE_SSL_CANTVERIFY ] { 55 }
+ Constant [ int COUCHBASE_SCHEDFAIL_INTERNAL ] { 56 }
+ Constant [ int COUCHBASE_CLIENT_FEATURE_UNAVAILABLE ] { 57 }
+ Constant [ int COUCHBASE_OPTIONS_CONFLICT ] { 58 }
+ Constant [ int COUCHBASE_HTTP_ERROR ] { 59 }
+ Constant [ int COUCHBASE_DURABILITY_NO_MUTATION_TOKENS ] { 60 }
+ Constant [ int COUCHBASE_UNKNOWN_MEMCACHED_ERROR ] { 61 }
+ Constant [ int COUCHBASE_MUTATION_LOST ] { 62 }
+ Constant [ int COUCHBASE_SUBDOC_PATH_ENOENT ] { 63 }
+ Constant [ int COUCHBASE_SUBDOC_PATH_MISMATCH ] { 64 }
+ Constant [ int COUCHBASE_SUBDOC_PATH_EINVAL ] { 65 }
+ Constant [ int COUCHBASE_SUBDOC_PATH_E2BIG ] { 66 }
+ Constant [ int COUCHBASE_SUBDOC_DOC_E2DEEP ] { 67 }
+ Constant [ int COUCHBASE_SUBDOC_VALUE_CANTINSERT ] { 68 }
+ Constant [ int COUCHBASE_SUBDOC_DOC_NOTJSON ] { 69 }
+ Constant [ int COUCHBASE_SUBDOC_NUM_ERANGE ] { 70 }
+ Constant [ int COUCHBASE_SUBDOC_BAD_DELTA ] { 71 }
+ Constant [ int COUCHBASE_SUBDOC_PATH_EEXISTS ] { 72 }
+ Constant [ int COUCHBASE_SUBDOC_MULTI_FAILURE ] { 73 }
+ Constant [ int COUCHBASE_SUBDOC_VALUE_E2DEEP ] { 74 }
+ Constant [ int COUCHBASE_EINVAL_MCD ] { 75 }
+ Constant [ int COUCHBASE_EMPTY_PATH ] { 76 }
+ Constant [ int COUCHBASE_UNKNOWN_SDCMD ] { 77 }
+ Constant [ int COUCHBASE_ENO_COMMANDS ] { 78 }
+ Constant [ int COUCHBASE_QUERY_ERROR ] { 79 }
+ Constant [ int COUCHBASE_GENERIC_TMPERR ] { 80 }
+ Constant [ int COUCHBASE_GENERIC_SUBDOCERR ] { 81 }
+ Constant [ int COUCHBASE_GENERIC_CONSTRAINT_ERR ] { 82 }
+ Constant [ int COUCHBASE_NAMESERVER_ERROR ] { 83 }
+ Constant [ int COUCHBASE_NOT_AUTHORIZED ] { 84 }
+ Constant [ int COUCHBASE_SUBDOC_INVALID_COMBO ] { 85 }
+ Constant [ int COUCHBASE_SUBDOC_MULTI_PATH_FAILURE ] { 86 }
+ Constant [ int COUCHBASE_SUBDOC_SUCCESS_DELETED ] { 87 }
+ Constant [ int COUCHBASE_SUBDOC_XATTR_INVALID_FLAG_COMBO ] { 88 }
+ Constant [ int COUCHBASE_SUBDOC_XATTR_INVALID_KEY_COMBO ] { 89 }
+ Constant [ int COUCHBASE_SUBDOC_XATTR_UNKNOWN_MACRO ] { 90 }
+ Constant [ int COUCHBASE_SUBDOC_XATTR_UNKNOWN_VATTR ] { 91 }
+ Constant [ int COUCHBASE_SUBDOC_XATTR_CANT_MODIFY_VATTR ] { 92 }
+ Constant [ int COUCHBASE_SUBDOC_MULTI_PATH_FAILURE_DELETED ] { 93 }
+ Constant [ int COUCHBASE_SUBDOC_INVALID_XATTR_ORDER ] { 94 }
+ Constant [ int COUCHBASE_SSL_INVALID_CIPHERSUITES ] { 95 }
+ Constant [ int COUCHBASE_SSL_NO_CIPHERS ] { 96 }
+ Constant [ int COUCHBASE_TMPFAIL ] { 11 }
+ Constant [ int COUCHBASE_KEYALREADYEXISTS ] { 12 }
+ Constant [ int COUCHBASE_KEYNOTFOUND ] { 13 }
+ Constant [ int COUCHBASE_VAL_MASK ] { 31 }
+ Constant [ int COUCHBASE_VAL_IS_STRING ] { 0 }
+ Constant [ int COUCHBASE_VAL_IS_LONG ] { 1 }
+ Constant [ int COUCHBASE_VAL_IS_DOUBLE ] { 2 }
+ Constant [ int COUCHBASE_VAL_IS_BOOL ] { 3 }
+ Constant [ int COUCHBASE_VAL_IS_SERIALIZED ] { 4 }
+ Constant [ int COUCHBASE_VAL_IS_IGBINARY ] { 5 }
+ Constant [ int COUCHBASE_VAL_IS_JSON ] { 6 }
+ Constant [ int COUCHBASE_COMPRESSION_MASK ] { 224 }
+ Constant [ int COUCHBASE_COMPRESSION_NONE ] { 0 }
+ Constant [ int COUCHBASE_COMPRESSION_ZLIB ] { 32 }
+ Constant [ int COUCHBASE_COMPRESSION_FASTLZ ] { 64 }
+ Constant [ int COUCHBASE_COMPRESSION_MCISCOMPRESSED ] { 16 }
+ Constant [ int COUCHBASE_SERTYPE_JSON ] { 0 }
+ Constant [ int COUCHBASE_SERTYPE_IGBINARY ] { 1 }
+ Constant [ int COUCHBASE_SERTYPE_PHP ] { 2 }
+ Constant [ int COUCHBASE_CMPRTYPE_NONE ] { 0 }
+ Constant [ int COUCHBASE_CMPRTYPE_ZLIB ] { 1 }
+ Constant [ int COUCHBASE_CMPRTYPE_FASTLZ ] { 2 }
+ Constant [ int COUCHBASE_CFFMT_MASK ] { -16777216 }
+ Constant [ int COUCHBASE_CFFMT_PRIVATE ] { 16777216 }
+ Constant [ int COUCHBASE_CFFMT_JSON ] { 33554432 }
+ Constant [ int COUCHBASE_CFFMT_RAW ] { 50331648 }
+ Constant [ int COUCHBASE_CFFMT_STRING ] { 67108864 }
+ Constant [ int Couchbase\ENCODER_FORMAT_JSON ] { 0 }
+ Constant [ int Couchbase\ENCODER_FORMAT_IGBINARY ] { 1 }
+ Constant [ int Couchbase\ENCODER_FORMAT_PHP ] { 2 }
+ Constant [ int Couchbase\ENCODER_COMPRESSION_NONE ] { 0 }
+ Constant [ int Couchbase\ENCODER_COMPRESSION_ZLIB ] { 1 }
+ Constant [ int Couchbase\ENCODER_COMPRESSION_FASTLZ ] { 2 }
+ Constant [ int Couchbase\HAVE_IGBINARY ] { 1 }
+ Constant [ int Couchbase\HAVE_ZLIB ] { 1 }
}
- Functions {
@@ -493,8 +495,8 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> class Couchbase\ClusterManager ] {
- Constants [2] {
- Constant [ public integer RBAC_DOMAIN_LOCAL ] { 1 }
- Constant [ public integer RBAC_DOMAIN_EXTERNAL ] { 2 }
+ Constant [ public int RBAC_DOMAIN_LOCAL ] { 1 }
+ Constant [ public int RBAC_DOMAIN_EXTERNAL ] { 2 }
}
- Static properties [0] {
@@ -622,10 +624,10 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> class Couchbase\Bucket ] {
- Constants [4] {
- Constant [ public integer PINGSVC_KV ] { 1 }
- Constant [ public integer PINGSVC_N1QL ] { 2 }
- Constant [ public integer PINGSVC_VIEWS ] { 4 }
- Constant [ public integer PINGSVC_FTS ] { 8 }
+ Constant [ public int PINGSVC_KV ] { 1 }
+ Constant [ public int PINGSVC_N1QL ] { 2 }
+ Constant [ public int PINGSVC_VIEWS ] { 4 }
+ Constant [ public int PINGSVC_FTS ] { 8 }
}
- Static properties [0] {
@@ -1401,11 +1403,11 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> class Couchbase\ViewQuery implements Couchbase\ViewQueryEncodable ] {
- Constants [5] {
- Constant [ public integer UPDATE_BEFORE ] { 1 }
- Constant [ public integer UPDATE_NONE ] { 2 }
- Constant [ public integer UPDATE_AFTER ] { 3 }
- Constant [ public integer ORDER_ASCENDING ] { 1 }
- Constant [ public integer ORDER_DESCENDING ] { 2 }
+ Constant [ public int UPDATE_BEFORE ] { 1 }
+ Constant [ public int UPDATE_NONE ] { 2 }
+ Constant [ public int UPDATE_AFTER ] { 3 }
+ Constant [ public int ORDER_ASCENDING ] { 1 }
+ Constant [ public int ORDER_DESCENDING ] { 2 }
}
- Static properties [0] {
@@ -1703,9 +1705,9 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> class Couchbase\N1qlQuery ] {
- Constants [6] {
- Constant [ public integer NOT_BOUNDED ] { 1 }
- Constant [ public integer REQUEST_PLUS ] { 2 }
- Constant [ public integer STATEMENT_PLUS ] { 3 }
+ Constant [ public int NOT_BOUNDED ] { 1 }
+ Constant [ public int REQUEST_PLUS ] { 2 }
+ Constant [ public int STATEMENT_PLUS ] { 3 }
Constant [ public string PROFILE_NONE ] { off }
Constant [ public string PROFILE_PHASES ] { phases }
Constant [ public string PROFILE_TIMINGS ] { timings }
@@ -1831,9 +1833,9 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> class Couchbase\N1qlIndex ] {
- Constants [3] {
- Constant [ public integer VIEW ] { 2 }
- Constant [ public integer GSI ] { 1 }
- Constant [ public integer UNSPECIFIED ] { 0 }
+ Constant [ public int VIEW ] { 2 }
+ Constant [ public int GSI ] { 1 }
+ Constant [ public int UNSPECIFIED ] { 0 }
}
- Static properties [0] {
@@ -1918,9 +1920,9 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> class Couchbase\MutateInBuilder ] {
- Constants [3] {
- Constant [ public integer FULLDOC_REPLACE ] { 1 }
- Constant [ public integer FULLDOC_INSERT ] { 2 }
- Constant [ public integer FULLDOC_UPSERT ] { 3 }
+ Constant [ public int FULLDOC_REPLACE ] { 1 }
+ Constant [ public int FULLDOC_INSERT ] { 2 }
+ Constant [ public int FULLDOC_UPSERT ] { 3 }
}
- Static properties [0] {
@@ -3752,8 +3754,8 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Class [ <internal:couchbase> abstract class Couchbase\CryptoProvider ] {
- Constants [2] {
- Constant [ public integer KEY_TYPE_ENCRYPT ] { 0 }
- Constant [ public integer KEY_TYPE_DECRYPT ] { 1 }
+ Constant [ public int KEY_TYPE_ENCRYPT ] { 0 }
+ Constant [ public int KEY_TYPE_DECRYPT ] { 1 }
}
- Static properties [0] {
@@ -3812,7 +3814,7 @@ Extension [ <persistent> extension #191 couchbase version 2.6.1 ] {
Method [ <internal, deprecated:couchbase> public method loadKey ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $keyType ]
+ Parameter #0 [ <required> int $keyType ]
Parameter #1 [ <required> string $keyId ]
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index d9375f0..c09450f 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-couchbase2
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -26,10 +26,10 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
Version: 2.6.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-URL: http://pecl.php.net/package/couchbase
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+URL: https://pecl.php.net/package/couchbase
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.6
@@ -37,7 +37,7 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-tokenizer
-BuildRequires: pkgconfig(libcouchbase) >= 2.9.5
+BuildRequires: pkgconfig(libcouchbase) >= 2.10.5
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
@@ -68,16 +68,6 @@ Conflicts: %{?scl_prefix}php-pecl-couchbase < 2
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php56u-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name}2 <= %{version}
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name}2 <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name}2 <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php72w-pecl-%{pecl_name}2 <= %{version}
@@ -250,6 +240,10 @@ fi
%changelog
+* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.6.1-3
+- rebuild libcouchase 2.10.5 for
+ https://github.com/remicollet/remirepo/issues/136
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 2.6.1-2
- rebuild for 7.4.0RC1