summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION70
-rw-r--r--php-pecl-couchbase2.spec8
2 files changed, 57 insertions, 21 deletions
diff --git a/REFLECTION b/REFLECTION
index c283387..bb4f678 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
+Extension [ <persistent> extension #183 couchbase version 2.4.7 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -637,7 +637,7 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
- Properties [0] {
}
- - Methods [48] {
+ - Methods [50] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -1002,7 +1002,7 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
}
}
- Method [ <internal:couchbase> public method encryptDocument ] {
+ Method [ <internal:couchbase> public method encryptFields ] {
- Parameters [3] {
Parameter #0 [ <required> $document ]
@@ -1011,7 +1011,25 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
}
}
- Method [ <internal:couchbase> public method decryptDocument ] {
+ Method [ <internal:couchbase> public method decryptFields ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $document ]
+ Parameter #1 [ <required> array $options ]
+ Parameter #2 [ <optional> string $prefix ]
+ }
+ }
+
+ Method [ <internal, deprecated:couchbase> public method encryptDocument ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $document ]
+ Parameter #1 [ <required> array $options ]
+ Parameter #2 [ <optional> string $prefix ]
+ }
+ }
+
+ Method [ <internal, deprecated:couchbase> public method decryptDocument ] {
- Parameters [2] {
Parameter #0 [ <required> $document ]
@@ -1633,10 +1651,13 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
Class [ <internal:couchbase> class Couchbase\N1qlQuery ] {
- - Constants [3] {
+ - Constants [6] {
Constant [ public integer NOT_BOUNDED ] { 1 }
Constant [ public integer REQUEST_PLUS ] { 2 }
Constant [ public integer STATEMENT_PLUS ] { 3 }
+ Constant [ public string PROFILE_NONE ] { off }
+ Constant [ public string PROFILE_PHASES ] { phases }
+ Constant [ public string PROFILE_TIMINGS ] { timings }
}
- Static properties [0] {
@@ -1655,7 +1676,7 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
Property [ <default> public $options ]
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -1697,6 +1718,13 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
}
}
+ Method [ <internal:couchbase> public method profile ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $profileType ]
+ }
+ }
+
Method [ <internal:couchbase> public method consistentWith ] {
- Parameters [1] {
@@ -3678,30 +3706,26 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
- Properties [0] {
}
- - Methods [6] {
- Method [ <internal:couchbase> abstract public method loadKey ] {
+ - Methods [7] {
+ Method [ <internal:couchbase> abstract public method encrypt ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $keyType ]
- Parameter #1 [ <required> string $keyId ]
+ Parameter #0 [ <required> string $bytes ]
+ Parameter #1 [ <required> string $iv ]
}
}
- Method [ <internal:couchbase> abstract public method encrypt ] {
+ Method [ <internal:couchbase> abstract public method decrypt ] {
- - Parameters [3] {
+ - Parameters [2] {
Parameter #0 [ <required> string $bytes ]
- Parameter #1 [ <required> string $key ]
- Parameter #2 [ <optional> string $iv ]
+ Parameter #1 [ <required> string $iv ]
}
}
- Method [ <internal:couchbase> abstract public method decrypt ] {
+ Method [ <internal:couchbase> public method getKeyId ] {
- - Parameters [3] {
- Parameter #0 [ <required> string $bytes ]
- Parameter #1 [ <required> string $key ]
- Parameter #2 [ <optional> string $iv ]
+ - Parameters [0] {
}
}
@@ -3725,6 +3749,14 @@ Extension [ <persistent> extension #182 couchbase version 2.4.6 ] {
Parameter #1 [ <required> string $signature ]
}
}
+
+ Method [ <internal, deprecated:couchbase> public method loadKey ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> integer $keyType ]
+ Parameter #1 [ <required> string $keyId ]
+ }
+ }
}
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 21dd542..3966d3b 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -25,7 +25,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.4.6
+Version: 2.4.7
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/couchbase
@@ -37,7 +37,7 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-tokenizer
-BuildRequires: pkgconfig(libcouchbase) >= 2.8.6
+BuildRequires: pkgconfig(libcouchbase) >= 2.9.0
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
@@ -242,6 +242,10 @@ fi
%changelog
+* Fri Jun 8 2018 Remi Collet <remi@remirepo.net> - 2.4.7-1
+- update to 2.4.7
+- raise dependency on libcouchbase 2.9.0
+
* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 2.4.6-1
- update to 2.4.6
- raise dependency on libcouchbase 2.8.6