summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--REFLECTION67
-rw-r--r--php-pecl-couchbase2.spec8
3 files changed, 73 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION b/REFLECTION
index 9eade7d..d4a4da8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
+Extension [ <persistent> extension #164 couchbase version 2.3.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -26,7 +26,7 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
}
}
- - Constants [146] {
+ - Constants [149] {
Constant [ integer COUCHBASE_PERSISTTO_MASTER ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_ONE ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_TWO ] { 2 }
@@ -138,6 +138,9 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
Constant [ integer COUCHBASE_UNKNOWN_SDCMD ] { 77 }
Constant [ integer COUCHBASE_ENO_COMMANDS ] { 78 }
Constant [ integer COUCHBASE_QUERY_ERROR ] { 79 }
+ Constant [ integer COUCHBASE_GENERIC_TMPERR ] { 80 }
+ Constant [ integer COUCHBASE_GENERIC_SUBDOCERR ] { 81 }
+ Constant [ integer COUCHBASE_GENERIC_CONSTRAINT_ERR ] { 82 }
Constant [ integer COUCHBASE_TMPFAIL ] { 11 }
Constant [ integer COUCHBASE_KEYALREADYEXISTS ] { 12 }
Constant [ integer COUCHBASE_KEYNOTFOUND ] { 13 }
@@ -314,7 +317,7 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
}
}
- - Classes [41] {
+ - Classes [42] {
Class [ <internal:couchbase> class Couchbase\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -502,7 +505,7 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
Method [ <internal:couchbase> final public method removeBucket ] {
- Parameters [1] {
- Parameter #0 [ <required> $connstr ]
+ Parameter #0 [ <required> $name ]
}
}
@@ -528,7 +531,7 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
- Properties [0] {
}
- - Methods [40] {
+ - Methods [41] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -645,6 +648,14 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
}
}
+ Method [ <internal:couchbase> final public method unlock ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $id ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+
Method [ <internal:couchbase> final public method touch ] {
- Parameters [3] {
@@ -1394,6 +1405,43 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
}
}
+ Class [ <internal:couchbase> final class Couchbase\AnalyticsQuery ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:couchbase> final static public method fromString ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $statement ]
+ }
+ }
+ }
+
+ - Properties [1] {
+ Property [ <default> public $options ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:couchbase, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method hostname ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $hostname ]
+ }
+ }
+ }
+ }
+
Class [ <internal:couchbase> final class Couchbase\N1qlQuery ] {
- Constants [3] {
@@ -1832,7 +1880,7 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:couchbase, ctor> final public method __construct ] {
- Parameters [2] {
@@ -1889,6 +1937,13 @@ Extension [ <persistent> extension #163 couchbase version 2.3.0 ] {
}
}
+ Method [ <internal:couchbase> final public method sort ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$(sort) ]
+ }
+ }
+
Method [ <internal:couchbase> final public method highlight ] {
- Parameters [2] {
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 898a9c7..7137fc0 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -25,7 +25,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.3.0
+Version: 2.3.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -36,7 +36,7 @@ BuildRequires: %{?scl_prefix}php-devel >= 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-json
-BuildRequires: libcouchbase-devel >= 2.7.2
+BuildRequires: libcouchbase-devel >= 2.7.3
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
# to ensure compatibility with XDebug
@@ -234,7 +234,6 @@ fi
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -250,6 +249,9 @@ fi
%changelog
+* Wed Apr 5 2017 Remi Collet <remi@remirepo.net> - 2.3.1-1
+- Update to 2.3.1
+
* Wed Mar 8 2017 Remi Collet <remi@remirepo.net> - 2.3.0-1
- Update to 2.3.0
- drop dependency on pcs extension