summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-bitset.spec44
2 files changed, 39 insertions, 16 deletions
diff --git a/REFLECTION b/REFLECTION
index cf0d1af..4eea205 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #77 bitset version 2.0.1 ] {
+Extension [ <persistent> extension #80 bitset version 2.0.2 ] {
- Functions {
Function [ <internal:bitset> function bitset_empty ] {
@@ -122,7 +122,7 @@ Extension [ <persistent> extension #77 bitset version 2.0.1 ] {
- Static properties [0] {
}
- - Static methods [2] {
+ - Static methods [3] {
Method [ <internal:bitset> static public method fromArray ] {
- Parameters [1] {
@@ -136,6 +136,13 @@ Extension [ <persistent> extension #77 bitset version 2.0.1 ] {
Parameter #0 [ <required> $str ]
}
}
+
+ Method [ <internal:bitset> static public method fromRawValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $str ]
+ }
+ }
}
- Properties [0] {
diff --git a/php-pecl-bitset.spec b/php-pecl-bitset.spec
index b6c0fbc..b2cefd7 100644
--- a/php-pecl-bitset.spec
+++ b/php-pecl-bitset.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-bitset
+# remirepo spec file for php-pecl-bitset
#
# Copyright (c) 2014-2016 Remi Collet
# License: CC-BY-SA
@@ -22,21 +22,19 @@
Summary: BITSET library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-upstream.patch
+Source1: https://raw.githubusercontent.com/php/pecl-numbers-bitset/master/LICENSE
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -45,6 +43,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -72,7 +72,7 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%description
Bitsets manipulation library.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -80,10 +80,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
-%patch0 -p1 -b .upstream
+cp %{SOURCE1} LICENSE
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_BITSET_VERSION/{s/.* "//;s/".*$//;p}' php_bitset.h)
@@ -144,14 +146,24 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -194,10 +206,10 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc %{pecl_docdir}/%{pecl_name}
%{?_licensedir:%license NTS/LICENSE}
-
+%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
+
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -208,8 +220,12 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2
+- drop runtime dependency on pear, new scriptlets
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1.1
- Fedora 21 SCL mass rebuild
* Fri Oct 31 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- initial package, version 2.0.1 (beta) \ No newline at end of file
+- initial package, version 2.0.1 (beta)