summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-binpack.spec26
1 files changed, 17 insertions, 9 deletions
diff --git a/php-pecl-binpack.spec b/php-pecl-binpack.spec
index e508cde..6c21f23 100644
--- a/php-pecl-binpack.spec
+++ b/php-pecl-binpack.spec
@@ -22,12 +22,15 @@
Summary: Binpack for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.1
-Release: 0.1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# https://github.com/binpack/binpack-php/pull/4
+Patch0: %{pecl_name}-pr.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
@@ -73,14 +76,16 @@ The php implementation for BINPACK.
%setup -q -c
mv %{pecl_name}-%{version} NTS
-#cd NTS
-## Sanity check, really often broken
-#extver=$(sed -n '/#define PHP_BINPACK_VERSION/{s/.* "//;s/".*$//;p}' php_binpack.h)
-#if test "x${extver}" != "x%{version}"; then
-# : Error: Upstream extension version is ${extver}, expecting %{version}.
-# exit 1
-#fi
-#cd ..
+cd NTS
+%patch0 -p1 -b .pr
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define BINPACK_EXTENSION_VERSION/{s/.* "//;s/".*$//;p}' php_binpack.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
@@ -196,6 +201,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Aug 12 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-0.2
+- add patch from https://github.com/binpack/binpack-php/pull/4
+
* Tue Aug 5 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-0.1
- test build before release