summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--50353e06d89a0bf0a77287f9d232f3a2edb60667.patch26
-rw-r--r--PHPINFO12
-rw-r--r--REFLECTION158
-rw-r--r--apcu-5.1.19.ini (renamed from apcu-5.1.2.ini)2
-rw-r--r--apcu-panel.conf8
-rw-r--r--php-pecl-apcu.spec179
6 files changed, 206 insertions, 179 deletions
diff --git a/50353e06d89a0bf0a77287f9d232f3a2edb60667.patch b/50353e06d89a0bf0a77287f9d232f3a2edb60667.patch
deleted file mode 100644
index 4da2788..0000000
--- a/50353e06d89a0bf0a77287f9d232f3a2edb60667.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 50353e06d89a0bf0a77287f9d232f3a2edb60667 Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Fri, 7 Jun 2019 10:04:14 +0200
-Subject: [PATCH] Use different fatal error
-
-The string conversion fatal is an exception in 7.4.
----
- tests/apc_entry_003.phpt | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/tests/apc_entry_003.phpt b/tests/apc_entry_003.phpt
-index ef8ace9..0fd7be4 100644
---- a/tests/apc_entry_003.phpt
-+++ b/tests/apc_entry_003.phpt
-@@ -8,8 +8,9 @@ apc.enable_cli=1
- --FILE--
- <?php
- $value = apcu_entry("test", function($key) {
-- (string) new stdClass;
-+ // Fatal error
-+ class X implements Y {}
- });
- ?>
- --EXPECTF--
--%s fatal error: Object of class stdClass could not be converted to string in %s on line %d
-+Fatal error: Interface 'Y' not found in %s on line %d
diff --git a/PHPINFO b/PHPINFO
index 5833f2a..c4305d9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
apcu
APCu Support => Enabled
-Version => 5.1.17
+Version => 5.1.23
APCu Debugging => Disabled
MMAP Support => Enabled
-MMAP File Mask => /tmp/apc.GR4vQm
-Serialization Support => php, igbinary
-Build Date => Feb 8 2019 11:54:42
+MMAP File Mask => /tmp/apc.Ju2Kie
+Serialization Support => php, brotli, igbinary, lz4, snappy, zstd
+Build Date => Nov 12 2023 00:00:00
Directive => Local Value => Master Value
apc.enabled => On => On
@@ -17,10 +17,10 @@ apc.entries_hint => 4096 => 4096
apc.gc_ttl => 3600 => 3600
apc.ttl => 0 => 0
apc.smart => 0 => 0
-apc.mmap_file_mask => /tmp/apc.GR4vQm => /tmp/apc.GR4vQm
+apc.mmap_file_mask => /tmp/apc.XXXXXX => /tmp/apc.XXXXXX
apc.enable_cli => On => On
apc.slam_defense => Off => Off
apc.preload_path => no value => no value
apc.coredump_unmap => Off => Off
-apc.use_request_time => On => On
+apc.use_request_time => Off => Off
apc.serializer => php => php
diff --git a/REFLECTION b/REFLECTION
index d2fe928..1c3f326 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #75 apcu version 5.1.17 ] {
+Extension [ <persistent> extension #68 apcu version 5.1.23 ] {
- INI {
Entry [ apc.enabled <SYSTEM> ]
@@ -23,7 +23,7 @@ Extension [ <persistent> extension #75 apcu version 5.1.17 ] {
Current = '0'
}
Entry [ apc.mmap_file_mask <SYSTEM> ]
- Current = '/tmp/apc.SvCmZg'
+ Current = '/tmp/apc.XXXXXX'
}
Entry [ apc.enable_cli <SYSTEM> ]
Current = '1'
@@ -38,7 +38,7 @@ Extension [ <persistent> extension #75 apcu version 5.1.17 ] {
Current = '0'
}
Entry [ apc.use_request_time <ALL> ]
- Current = '1'
+ Current = '0'
}
Entry [ apc.serializer <SYSTEM> ]
Current = 'php'
@@ -46,126 +46,140 @@ Extension [ <persistent> extension #75 apcu version 5.1.17 ] {
}
- Constants [16] {
- Constant [ integer ] { 139780637056704 }
- Constant [ integer APC_LIST_ACTIVE ] { 1 }
- Constant [ integer APC_LIST_DELETED ] { 2 }
- Constant [ integer APC_ITER_TYPE ] { 1 }
- Constant [ integer APC_ITER_KEY ] { 2 }
- Constant [ integer APC_ITER_VALUE ] { 4 }
- Constant [ integer APC_ITER_NUM_HITS ] { 8 }
- Constant [ integer APC_ITER_MTIME ] { 16 }
- Constant [ integer APC_ITER_CTIME ] { 32 }
- Constant [ integer APC_ITER_DTIME ] { 64 }
- Constant [ integer APC_ITER_ATIME ] { 128 }
- Constant [ integer APC_ITER_REFCOUNT ] { 256 }
- Constant [ integer APC_ITER_MEM_SIZE ] { 512 }
- Constant [ integer APC_ITER_TTL ] { 1024 }
- Constant [ integer APC_ITER_NONE ] { 0 }
- Constant [ integer APC_ITER_ALL ] { 4294967295 }
+ Constant [ int ] { 139777182917712 }
+ Constant [ int APC_LIST_ACTIVE ] { 1 }
+ Constant [ int APC_LIST_DELETED ] { 2 }
+ Constant [ int APC_ITER_TYPE ] { 1 }
+ Constant [ int APC_ITER_KEY ] { 2 }
+ Constant [ int APC_ITER_VALUE ] { 4 }
+ Constant [ int APC_ITER_NUM_HITS ] { 8 }
+ Constant [ int APC_ITER_MTIME ] { 16 }
+ Constant [ int APC_ITER_CTIME ] { 32 }
+ Constant [ int APC_ITER_DTIME ] { 64 }
+ Constant [ int APC_ITER_ATIME ] { 128 }
+ Constant [ int APC_ITER_REFCOUNT ] { 256 }
+ Constant [ int APC_ITER_MEM_SIZE ] { 512 }
+ Constant [ int APC_ITER_TTL ] { 1024 }
+ Constant [ int APC_ITER_NONE ] { 0 }
+ Constant [ int APC_ITER_ALL ] { 4294967295 }
}
- Functions {
- Function [ <internal:apcu> function apcu_cache_info ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $limited ]
- }
- }
Function [ <internal:apcu> function apcu_clear_cache ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Function [ <internal:apcu> function apcu_sma_info ] {
+ Function [ <internal:apcu> function apcu_cache_info ] {
- Parameters [1] {
- Parameter #0 [ <optional> $limited ]
+ Parameter #0 [ <optional> bool $limited = false ]
}
+ - Return [ array|false ]
}
Function [ <internal:apcu> function apcu_key_info ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> string $key ]
}
+ - Return [ ?array ]
+ }
+ Function [ <internal:apcu> function apcu_sma_info ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> bool $limited = false ]
+ }
+ - Return [ array|false ]
}
Function [ <internal:apcu> function apcu_enabled ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Function [ <internal:apcu> function apcu_store ] {
- Parameters [3] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $var ]
- Parameter #2 [ <optional> $ttl ]
- }
- }
- Function [ <internal:apcu> function apcu_fetch ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> &$success ]
- }
- }
- Function [ <internal:apcu> function apcu_delete ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $ttl = 0 ]
}
+ - Return [ array|bool ]
}
Function [ <internal:apcu> function apcu_add ] {
- Parameters [3] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $var ]
- Parameter #2 [ <optional> $ttl ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $ttl = 0 ]
}
+ - Return [ array|bool ]
}
Function [ <internal:apcu> function apcu_inc ] {
- Parameters [4] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $step ]
- Parameter #2 [ <optional> &$success ]
- Parameter #3 [ <optional> $ttl ]
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <optional> int $step = 1 ]
+ Parameter #2 [ <optional> &$success = null ]
+ Parameter #3 [ <optional> int $ttl = 0 ]
}
+ - Return [ int|false ]
}
Function [ <internal:apcu> function apcu_dec ] {
- Parameters [4] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $step ]
- Parameter #2 [ <optional> &$success ]
- Parameter #3 [ <optional> $ttl ]
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <optional> int $step = 1 ]
+ Parameter #2 [ <optional> &$success = null ]
+ Parameter #3 [ <optional> int $ttl = 0 ]
}
+ - Return [ int|false ]
}
Function [ <internal:apcu> function apcu_cas ] {
- Parameters [3] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> int $old ]
+ Parameter #2 [ <required> int $new ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:apcu> function apcu_fetch ] {
+
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $old ]
- Parameter #2 [ <required> $new ]
+ Parameter #1 [ <optional> &$success = null ]
}
+ - Return [ mixed ]
}
Function [ <internal:apcu> function apcu_exists ] {
- Parameters [1] {
- Parameter #0 [ <required> $keys ]
+ Parameter #0 [ <required> $key ]
+ }
+ - Return [ array|bool ]
+ }
+ Function [ <internal:apcu> function apcu_delete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
+ - Return [ array|bool ]
}
Function [ <internal:apcu> function apcu_entry ] {
- Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> callable $generator ]
- Parameter #2 [ <optional> integer $ttl ]
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> callable $callback ]
+ Parameter #2 [ <optional> int $ttl = 0 ]
}
+ - Return [ mixed ]
}
}
- Classes [1] {
- Class [ <internal:apcu> <iterateable> class APCuIterator implements Iterator, Traversable ] {
+ Class [ <internal:apcu> <iterateable> class APCUIterator implements Iterator, Traversable ] {
- Constants [0] {
}
@@ -183,10 +197,10 @@ Extension [ <persistent> extension #75 apcu version 5.1.17 ] {
Method [ <internal:apcu, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <optional> $search ]
- Parameter #1 [ <optional> $format ]
- Parameter #2 [ <optional> $chunk_size ]
- Parameter #3 [ <optional> $list ]
+ Parameter #0 [ <optional> $search = null ]
+ Parameter #1 [ <optional> int $format = APC_ITER_ALL ]
+ Parameter #2 [ <optional> int $chunk_size = 0 ]
+ Parameter #3 [ <optional> int $list = APC_LIST_ACTIVE ]
}
}
@@ -194,48 +208,56 @@ Extension [ <persistent> extension #75 apcu version 5.1.17 ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:apcu, prototype Iterator> public method current ] {
+ Method [ <internal:apcu, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:apcu, prototype Iterator> public method key ] {
+ Method [ <internal:apcu, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Method [ <internal:apcu, prototype Iterator> public method next ] {
+ Method [ <internal:apcu, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Return [ string|int ]
}
- Method [ <internal:apcu, prototype Iterator> public method valid ] {
+ Method [ <internal:apcu, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
Method [ <internal:apcu> public method getTotalHits ] {
- Parameters [0] {
}
+ - Return [ int ]
}
Method [ <internal:apcu> public method getTotalSize ] {
- Parameters [0] {
}
+ - Return [ int ]
}
Method [ <internal:apcu> public method getTotalCount ] {
- Parameters [0] {
}
+ - Return [ int ]
}
}
}
diff --git a/apcu-5.1.2.ini b/apcu-5.1.19.ini
index ed8dd16..dacb938 100644
--- a/apcu-5.1.2.ini
+++ b/apcu-5.1.19.ini
@@ -55,7 +55,7 @@ apc.mmap_file_mask=/tmp/apc.XXXXXX
;apc.serializer='php'
; use the SAPI request start time for TTL
-;apc.use_request_time=1
+;apc.use_request_time=0
; Enables APCu handling of signals, such as SIGSEGV, that write core files
; when signaled. APCu will attempt to unmap the shared memory segment in
diff --git a/apcu-panel.conf b/apcu-panel.conf
index e51a40f..de7d690 100644
--- a/apcu-panel.conf
+++ b/apcu-panel.conf
@@ -3,15 +3,7 @@ Alias /apcu-panel /usr/share/apcu-panel
<Directory /usr/share/apcu-panel>
<IfModule mod_authz_core.c>
- # Apache 2.4
Require local
</IfModule>
- <IfModule !mod_authz_core.c>
- # Apache 2.2
- Order Deny,Allow
- Deny from All
- Allow from 127.0.0.1
- Allow from ::1
- </IfModule>
</Directory>
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 613ceff..1791d39 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -3,8 +3,8 @@
#
# Fedora spec file for php-pecl-apcu
#
-# Copyright (c) 2013-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -13,58 +13,46 @@
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-apcu
-%endif
+%{?scl:%scl_package php-pecl-apcu}
+
+%bcond_without tests
%global gh_commit b771cd50a7fe519b6aaccbe5dc97594e68e0c88f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
%global gh_project apcu
-#global gh_date 20161018
%global pecl_name apcu
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
-Name: %{?sub_prefix}php-pecl-apcu
+Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 5.1.17
-%if 0%{?gh_date:1}
-Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
-Source1: %{pecl_name}-5.1.2.ini
+Version: 5.1.23
+License: PHP-3.01
+URL: https://pecl.php.net/package/APCu
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source1: %{pecl_name}-5.1.19.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
-Patch0: https://github.com/krakjoe/apcu/commit/50353e06d89a0bf0a77287f9d232f3a2edb60667.patch
-
-License: PHP
-URL: http://pecl.php.net/package/APCu
-
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Obsoletes: %{?scl_prefix}php-apcu < 4.0.0-1
Provides: %{?scl_prefix}php-apcu = %{version}
Provides: %{?scl_prefix}php-apcu%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(apcu) = %{version}
Provides: %{?scl_prefix}php-pecl(apcu)%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-apcu = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-apcu%{?_isa} = %{version}-%{release}
-%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
@@ -94,19 +82,13 @@ Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
APCu is userland caching: APC stripped of opcode caching.
APCu only supports userland caching of variables.
-The %{?sub_prefix}php-pecl-apcu-bc package provides a drop
+The %{?scl_prefix}php-pecl-apcu-bc package provides a drop
in replacement for APC.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -120,10 +102,6 @@ Requires: %{?scl_prefix}php-devel%{?_isa}
Obsoletes: %{?scl_prefix}php-pecl-apc-devel < 4
Provides: %{?scl_prefix}php-pecl-apc-devel = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-apc-devel%{?_isa} = %{version}-%{release}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-apcu-devel = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-apcu-devel%{?_isa} = %{version}-%{release}
-%endif
%description devel
These are the files needed to compile programs using APCu.
@@ -149,35 +127,26 @@ configuration, available on http://localhost/apcu-panel/
%prep
%setup -qc
-%if 0%{?gh_date:1}
-mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
-%else
-mv %{pecl_name}-%{version} NTS
-%endif
-
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-cd NTS
-%patch0 -p1
-
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_APCU_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
-if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
%if 0%{!?scl:1}
# Fix path to configuration file
sed -e s:apc.conf.php:%{_sysconfdir}/apcu-panel/conf.php:g \
- -i NTS/apc.php
+ -i %{sources}/apc.php
%else
# Provide the control panel as doc
sed -e '/"apc.php"/s/role="src"/role="doc"/' -i package.xml
@@ -186,19 +155,20 @@ sed -e '/"apc.php"/s/role="src"/role="doc"/' -i package.xml
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--enable-apcu \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--enable-apcu \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -222,7 +192,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if 0%{!?scl:1}
# Install the Control Panel
# Pages
-install -D -m 644 -p NTS/apc.php \
+install -D -m 644 -p %{sources}/apc.php \
%{buildroot}%{_datadir}/apcu-panel/index.php
# Apache config
install -D -m 644 -p %{SOURCE2} \
@@ -234,7 +204,7 @@ install -D -m 644 -p %{SOURCE3} \
# Test & Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do [ -f $i ] && install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
[ -f tests/$i ] && install -Dpm 644 tests/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/$i
@@ -245,30 +215,32 @@ done
%check
-cd NTS
+cd %{sources}
+
%{_bindir}/php -n \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
-m | grep 'apcu'
+%if %{with tests}
# Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
+%endif
%if %{with_zts}
-cd ../ZTS
%{__ztsphp} -n \
-d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
-m | grep 'apcu'
+%if %{with tests}
# Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
+%endif
%endif
@@ -293,7 +265,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -326,6 +298,73 @@ fi
%changelog
+* Sun Nov 12 2023 Remi Collet <remi@remirepo.net> - 5.1.23-1
+- update to 5.1.23
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 5.1.22-3
+- rebuild for PHP 8.3.0RC1
+
+* Tue Jun 6 2023 Remi Collet <remi@remirepo.net> - 5.1.22-2
+- build out of sources tree
+- add upstream patch for 8.3
+- add patch for tests when build out of sources tree from
+ https://github.com/krakjoe/apcu/pull/490
+
+* Mon Sep 19 2022 Remi Collet <remi@remirepo.net> - 5.1.22-1
+- update to 5.1.22
+
+* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 5.1.21-3
+- rebuild for PHP 8.2.0RC1
+
+* Thu Aug 18 2022 Remi Collet <remi@remirepo.net> - 5.1.21-2
+- add upstream patches for PHP 8.2
+
+* Thu Oct 7 2021 Remi Collet <remi@remirepo.net> - 5.1.21-1
+- update to 5.1.21
+
+* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 5.1.20-5
+- rebuild for 8.1.0RC1
+
+* Fri Jul 23 2021 Remi Collet <remi@remirepo.net> - 5.1.20-4
+- add upstream patch for PHP 8.1.0beta1
+
+* Wed Jul 7 2021 Remi Collet <remi@remirepo.net> - 5.1.20-3
+- add upstream patch for test suite with PHP 8.1
+
+* Thu Jun 10 2021 Remi Collet <remi@remirepo.net> - 5.1.20-2
+- temporarily ignore 3 tests with PHP 8.1
+
+* Thu Mar 4 2021 Remi Collet <remi@remirepo.net> - 5.1.20-1
+- update to 5.1.20
+
+* Mon Oct 5 2020 Remi Collet <remi@remirepo.net> - 5.1.19-1
+- update to 5.1.19
+
+* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 5.1.18-7
+- rebuild for PHP 8.0.0RC1
+
+* Wed Sep 23 2020 Remi Collet <remi@remirepo.net> - 5.1.18-6
+- rebuild for PHP 8.0.0beta4
+
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 5.1.18-5
+- more upstream patches
+
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 5.1.18-4
+- rebuild for PHP 8.0.0beta3
+
+* Wed Aug 5 2020 Remi Collet <remi@remirepo.net> - 5.1.18-3
+- rebuild for 8.0.0beta1
+- more upstream patches
+
+* Fri Apr 10 2020 Remi Collet <remi@remirepo.net> - 5.1.18-2
+- add upstream patch for 8.0
+
+* Mon Oct 28 2019 Remi Collet <remi@remirepo.net> - 5.1.18-1
+- update to 5.1.18
+
+* Thu Oct 3 2019 Remi Collet <remi@remirepo.net> - 5.1.17-6
+- more upstream patch for test suite
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 5.1.17-5
- rebuild for 7.4.0RC1