summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-09 10:08:10 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-09 10:08:10 +0200
commit6c22be9f36561500233ad930f3983859061a4d9c (patch)
tree10c51d534841fc7fa73800f755b19ca90194bbef /php-pecl-apcu.spec
parent8da8c8157d9cb026f5204f9447a973651aba20e0 (diff)
php-pecl: add numerical prefix to extension configuration file
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec18
1 files changed, 13 insertions, 5 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 8e11fca..7120d9d 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -14,11 +14,16 @@
%{!?__php: %global __php %{_bindir}/php}
%global pecl_name apcu
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
Version: 4.0.4
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}.ini
Source2: %{pecl_name}-panel.conf
@@ -190,12 +195,12 @@ rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Install the package XML file
@@ -272,11 +277,11 @@ fi
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
%{php_ztsextdir}/%{pecl_name}.so
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%endif
@@ -301,6 +306,9 @@ fi
%changelog
+* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 4.0.4-2
+- add numerical prefix to extension configuration file
+
* Sat Mar 01 2014 Remi Collet <remi@fedoraproject.org> - 4.0.4-1
- Update to 4.0.4 (beta)