summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-20 12:59:36 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-20 12:59:36 +0100
commit5cea834684288ea55883c2ebf91f0badb64f6bd1 (patch)
tree244de67f753014d9c34eecfed18832f4e87e8559
parent1aeaf6ce33d32421eb642f34aba7721599d329b3 (diff)
php-pecl-apcu: 5.1.0 (beta for php 7)
-rw-r--r--REFLECTION-PHP7102
-rw-r--r--php-pecl-apcu-php7.spec16
2 files changed, 108 insertions, 10 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index d0002bf..9b0f981 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 apcu version 5.0.0-dev ] {
+Extension [ <persistent> extension #70 apcu version 5.1.0 ] {
- INI {
Entry [ apc.enabled <SYSTEM> ]
@@ -23,7 +23,7 @@ Extension [ <persistent> extension #108 apcu version 5.0.0-dev ] {
Current = '0'
}
Entry [ apc.mmap_file_mask <SYSTEM> ]
- Current = '/tmp/apc.j1DyUf'
+ Current = '/tmp/apc.PaEi1m'
}
Entry [ apc.enable_cli <SYSTEM> ]
Current = '1'
@@ -49,7 +49,7 @@ Extension [ <persistent> extension #108 apcu version 5.0.0-dev ] {
}
- Constants [16] {
- Constant [ integer ] { 140428353469648 }
+ Constant [ integer ] { 139697376948720 }
Constant [ integer APC_LIST_ACTIVE ] { 1 }
Constant [ integer APC_LIST_DELETED ] { 2 }
Constant [ integer APC_ITER_TYPE ] { 1 }
@@ -155,10 +155,18 @@ Extension [ <persistent> extension #108 apcu version 5.0.0-dev ] {
Parameter #0 [ <required> $keys ]
}
}
+ Function [ <internal:apcu> function apcu_entry ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> callable $generator ]
+ Parameter #2 [ <optional> integer $ttl ]
+ }
+ }
}
- Classes [1] {
- Class [ <internal:apcu> <iterateable> class APCIterator implements Iterator, Traversable ] {
+ Class [ <internal:apcu> <iterateable> class APCuIterator implements Iterator, Traversable ] {
- Constants [0] {
}
@@ -176,7 +184,7 @@ Extension [ <persistent> extension #108 apcu version 5.0.0-dev ] {
Method [ <internal:apcu, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <required> $search ]
+ Parameter #0 [ <optional> $search ]
Parameter #1 [ <optional> $format ]
Parameter #2 [ <optional> $chunk_size ]
Parameter #3 [ <optional> $list ]
@@ -235,7 +243,11 @@ Extension [ <persistent> extension #108 apcu version 5.0.0-dev ] {
}
}
-Extension [ <persistent> extension #109 apc version 5.0.0-dev ] {
+Extension [ <persistent> extension #71 apc version 5.1.0 ] {
+
+ - Dependencies {
+ Dependency [ apcu (Required) ]
+ }
- Functions {
Function [ <internal:apc> function apc_cache_info ] {
@@ -322,5 +334,83 @@ Extension [ <persistent> extension #109 apc version 5.0.0-dev ] {
}
}
}
+
+ - Classes [1] {
+ Class [ <internal:apc> <iterateable> class APCIterator extends APCuIterator implements Traversable, Iterator ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:apc, overwrites APCuIterator, ctor> public method __construct ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $ignored ]
+ Parameter #1 [ <optional> $search ]
+ Parameter #2 [ <optional> $format ]
+ Parameter #3 [ <optional> $chunk_size ]
+ Parameter #4 [ <optional> $list ]
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator> public method getTotalHits ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator> public method getTotalSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator> public method getTotalCount ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
}
diff --git a/php-pecl-apcu-php7.spec b/php-pecl-apcu-php7.spec
index 32f18f4..5362284 100644
--- a/php-pecl-apcu-php7.spec
+++ b/php-pecl-apcu-php7.spec
@@ -24,11 +24,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit ba683bc0ff8732aa4a8122ebcb8632da5796cb34
+%global gh_commit ccd50c3b3ab773452bcec60fc4b8931c75233f8a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
%global gh_project apcu
-%global gh_date 20151120
+#global gh_date 20151120
%global pecl_name apcu
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
@@ -38,10 +38,11 @@ Summary: APC User Cache
Version: 5.1.0
%if 0%{?gh_date:1}
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
Source1: %{pecl_name}-5.0.0.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
@@ -166,8 +167,12 @@ configuration, available on http://localhost/apcu-panel/
%prep
%setup -qc
+%if 0%{?gh_date:1}
mv %{gh_project}-%{gh_commit} NTS
mv NTS/package.xml .
+%else
+mv %{pecl_name}-%{version} NTS
+%endif
cd NTS
# Sanity check, really often broken
@@ -239,7 +244,7 @@ install -D -m 644 -p %{SOURCE3} \
# Test & Documentation
cd NTS
for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 tests/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/$i
+do install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
done
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -344,6 +349,9 @@ fi
%changelog
+* Fri Nov 20 2015 Remi Collet <remi@fedoraproject.org> - 5.1.0-1
+- Update to 5.1.0 (beta)
+
* Fri Nov 20 2015 Remi Collet <remi@fedoraproject.org> - 5.1.0-0.1.20151120gitba683bc
- test build for upcoming 5.1.0