summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-27 06:49:49 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-27 06:49:49 +0100
commit1aae961a7ce6a83d8b8d162cbd23968266af843e (patch)
treea76c995efd59bf05604d09b57b522c3131e06e8e
parentdc15d86ec7e5c79065a815c808bc8cabdb4eec8e (diff)
php-pecl-apcu: cleanups before review
-rw-r--r--php-pecl-apcu-dev.spec15
-rw-r--r--php-pecl-apcu.spec10
2 files changed, 0 insertions, 25 deletions
diff --git a/php-pecl-apcu-dev.spec b/php-pecl-apcu-dev.spec
index 042a0b7..5c82008 100644
--- a/php-pecl-apcu-dev.spec
+++ b/php-pecl-apcu-dev.spec
@@ -1,7 +1,4 @@
-%{!?php_inidir: %{expand: %%global php_inidir %{_sysconfdir}/php.d}}
-%{!?php_incldir: %{expand: %%global php_incldir %{_includedir}/php}}
%global pecl_name apcu
-%global with_zts 0%{?__ztsphp:1}
Name: php-pecl-apcu
Summary: APC User Cache
@@ -97,10 +94,8 @@ if test "x${extver}" != "x%{version}"; then
exit 1
fi
-%if %{with_zts}
# duplicate for ZTS build
cp -pr NTS ZTS
-%endif
%build
@@ -109,12 +104,10 @@ cd NTS
%configure --with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
-%if %{with_zts}
cd ../ZTS
%{_bindir}/zts-phpize
%configure --with-php-config=%{_bindir}/zts-php-config
make %{?_smp_mflags}
-%endif
%install
@@ -124,10 +117,8 @@ make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{pecl_name}.ini
# Install the ZTS stuff
-%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
-%endif
# Install the package XML file
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -159,7 +150,6 @@ NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php
-%if %{with_zts}
cd ../ZTS
%{__ztsphp} -n -d extension_dir=modules -d extension=apcu.so -m | grep 'apcu'
@@ -170,7 +160,6 @@ TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php
-%endif
%clean
@@ -185,17 +174,13 @@ rm -rf %{buildroot}
%config(noreplace) %{php_inidir}/%{pecl_name}.ini
%{php_extdir}/%{pecl_name}.so
-%if %{with_zts}
%{php_ztsextdir}/%{pecl_name}.so
%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
-%endif
%files devel
%defattr(-,root,root,-)
%{php_incldir}/ext/%{pecl_name}
-%if %{with_zts}
%{php_ztsincldir}/ext/%{pecl_name}
-%endif
%files -n apcu-panel
%defattr(-,root,root,-)
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 042a0b7..3bece25 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -16,7 +16,6 @@ License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/APCu
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-devel
BuildRequires: php-pear
@@ -74,9 +73,7 @@ These are the files needed to compile programs using APCu.
%package -n apcu-panel
Summary: APCu control panel
Group: Applications/Internet
-%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
BuildArch: noarch
-%endif
Requires: %{name} = %{version}-%{release}
Requires: mod_php, httpd, php-gd
#Obsoletes: apc-panel
@@ -118,7 +115,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{pecl_name}.ini
@@ -173,12 +169,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-, root, root, 0755)
%doc NTS/{NOTICE,LICENSE,README.md}
%{pecl_xmldir}/%{name}.xml
@@ -191,7 +182,6 @@ rm -rf %{buildroot}
%endif
%files devel
-%defattr(-,root,root,-)
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
%{php_ztsincldir}/ext/%{pecl_name}