summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-apcu-bc.spec9
3 files changed, 15 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..8436f1d
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+apc
+
+APC Compatibility => 1.0.5
diff --git a/REFLECTION b/REFLECTION
index 264be2d..8cb23a7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #178 apc version 5.1.10 ] {
+Extension [ <persistent> extension #186 apc version 5.1.17 ] {
- Dependencies {
Dependency [ apcu (Required) ]
@@ -60,18 +60,20 @@ Extension [ <persistent> extension #178 apc version 5.1.10 ] {
}
Function [ <internal:apc> function apc_inc ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> $step ]
Parameter #2 [ <optional> &$success ]
+ Parameter #3 [ <optional> $ttl ]
}
}
Function [ <internal:apc> function apc_dec ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> $step ]
Parameter #2 [ <optional> &$success ]
+ Parameter #3 [ <optional> $ttl ]
}
}
Function [ <internal:apc> function apc_cas ] {
diff --git a/php-pecl-apcu-bc.spec b/php-pecl-apcu-bc.spec
index 9c2efa9..aeb0bed 100644
--- a/php-pecl-apcu-bc.spec
+++ b/php-pecl-apcu-bc.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-apcu-bc
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -32,12 +32,12 @@
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Summary: APCu Backwards Compatibility Module
-Version: 1.0.4
+Version: 1.0.5
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{proj_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
%endif
@@ -250,6 +250,9 @@ fi
%changelog
+* Wed Feb 20 2019 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.0.4-3
- rebuild for 7.3.0beta2 new ABI