summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--apc-dev.ini75
-rw-r--r--apc.ini91
-rw-r--r--php-pecl-apc-dev.spec388
-rw-r--r--php-pecl-apc.spec100
4 files changed, 118 insertions, 536 deletions
diff --git a/apc-dev.ini b/apc-dev.ini
deleted file mode 100644
index 2b39aaf..0000000
--- a/apc-dev.ini
+++ /dev/null
@@ -1,75 +0,0 @@
-; Enable apc extension module
-extension = apc.so
-
-; Options for the APC module version >= 3.1.3
-; See http://www.php.net/manual/en/apc.configuration.php
-
-
-; This can be set to enable the old opcode cache
-; Don't use this option if zendoptimizerplus is enabled
-apc.enable_opcode_cache=0
-; This can be set to 0 to disable APC.
-apc.enabled=1
-; The number of shared memory segments to allocate for the compiler cache.
-apc.shm_segments=1
-; The size of each shared memory segment, with M/G suffixe
-apc.shm_size=64M
-; A "hint" about the number of distinct source files that will be included or
-; requested on your web server. Set to zero or omit if you are not sure;
-apc.num_files_hint=1024
-; Just like num_files_hint, a "hint" about the number of distinct user cache
-; variables to store. Set to zero or omit if you are not sure;
-apc.user_entries_hint=4096
-; The number of seconds a cache entry is allowed to idle in a slot in case this
-; cache entry slot is needed by another entry.
-apc.ttl=7200
-; use the SAPI request start time for TTL
-apc.use_request_time=1
-; The number of seconds a user cache entry is allowed to idle in a slot in case
-; this cache entry slot is needed by another entry.
-apc.user_ttl=7200
-; The number of seconds that a cache entry may remain on the garbage-collection list.
-apc.gc_ttl=3600
-; On by default, but can be set to off and used in conjunction with positive
-; apc.filters so that files are only cached if matched by a positive filter.
-apc.cache_by_default=1
-; A comma-separated list of POSIX extended regular expressions.
-apc.filters
-; The mktemp-style file_mask to pass to the mmap module
-apc.mmap_file_mask=/tmp/apc.XXXXXX
-; This file_update_protection setting puts a delay on caching brand new files.
-apc.file_update_protection=2
-; Setting this enables APC for the CLI version of PHP (Mostly for testing and debugging).
-apc.enable_cli=0
-; Prevents large files from being cached
-apc.max_file_size=1M
-; Whether to stat the main script file and the fullpath includes.
-apc.stat=1
-; Vertification with ctime will avoid problems caused by programs such as svn or rsync by making
-; sure inodes have not changed since the last stat. APC will normally only check mtime.
-apc.stat_ctime=0
-; Whether to canonicalize paths in stat=0 mode or fall back to stat behaviour
-apc.canonicalize=0
-; With write_lock enabled, only one process at a time will try to compile an
-; uncached script while the other processes will run uncached
-apc.write_lock=1
-; Logs any scripts that were automatically excluded from being cached due to early/late binding issues.
-apc.report_autofilter=0
-; RFC1867 File Upload Progress hook handler
-apc.rfc1867=0
-apc.rfc1867_prefix =upload_
-apc.rfc1867_name=APC_UPLOAD_PROGRESS
-apc.rfc1867_freq=0
-apc.rfc1867_ttl=3600
-; Optimize include_once and require_once calls and avoid the expensive system calls used.
-apc.include_once_override=0
-apc.lazy_classes=0
-apc.lazy_functions=0
-; Enables APC handling of signals, such as SIGSEGV, that write core files when signaled.
-; APC will attempt to unmap the shared memory segment in order to exclude it from the core file
-apc.coredump_unmap=0
-; Records a md5 hash of files.
-apc.file_md5=0
-; not documented
-apc.preload_path
-
diff --git a/apc.ini b/apc.ini
index 9827664..9827dc2 100644
--- a/apc.ini
+++ b/apc.ini
@@ -4,68 +4,95 @@ extension = apc.so
; Options for the APC module version >= 3.1.3
; See http://www.php.net/manual/en/apc.configuration.php
+
+; This can be set to enable the APC opcode cache
+; Don't set this option if another opcode cache is enabled
+apc.enable_opcode_cache=0
+
; This can be set to 0 to disable APC.
-apc.enabled=1
-; The number of shared memory segments to allocate for the compiler cache.
-apc.shm_segments=1
+;apc.enabled=1
+
; The size of each shared memory segment, with M/G suffixe
apc.shm_size=64M
+
+; The shared memory size reserved for strings, with M/G suffixe
+apc.shm_strings_buffer=8M
+
; A "hint" about the number of distinct source files that will be included or
; requested on your web server. Set to zero or omit if you are not sure;
-apc.num_files_hint=1024
+;apc.num_files_hint=1000
+
; Just like num_files_hint, a "hint" about the number of distinct user cache
; variables to store. Set to zero or omit if you are not sure;
-apc.user_entries_hint=4096
+;apc.user_entries_hint=4096
+
; The number of seconds a cache entry is allowed to idle in a slot in case this
; cache entry slot is needed by another entry.
-apc.ttl=7200
+;apc.ttl=0
+
; use the SAPI request start time for TTL
-apc.use_request_time=1
+;apc.use_request_time=1
+
; The number of seconds a user cache entry is allowed to idle in a slot in case
; this cache entry slot is needed by another entry.
-apc.user_ttl=7200
+;apc.user_ttl=0
+
; The number of seconds that a cache entry may remain on the garbage-collection list.
-apc.gc_ttl=3600
+;apc.gc_ttl=3600
+
; On by default, but can be set to off and used in conjunction with positive
; apc.filters so that files are only cached if matched by a positive filter.
-apc.cache_by_default=1
+;apc.cache_by_default=1
+
; A comma-separated list of POSIX extended regular expressions.
-apc.filters
+;apc.filters=
+
; The mktemp-style file_mask to pass to the mmap module
apc.mmap_file_mask=/tmp/apc.XXXXXX
+
+
; This file_update_protection setting puts a delay on caching brand new files.
-apc.file_update_protection=2
+;apc.file_update_protection=2
+
; Setting this enables APC for the CLI version of PHP (Mostly for testing and debugging).
-apc.enable_cli=0
+;apc.enable_cli=0
+
; Prevents large files from being cached
-apc.max_file_size=1M
+;apc.max_file_size=1M
+
; Whether to stat the main script file and the fullpath includes.
-apc.stat=1
+;apc.stat=1
+
; Vertification with ctime will avoid problems caused by programs such as svn or rsync by making
; sure inodes have not changed since the last stat. APC will normally only check mtime.
-apc.stat_ctime=0
-; Whether to canonicalize paths in stat=0 mode or fall back to stat behaviour
-apc.canonicalize=0
+;apc.stat_ctime=0
+
+; If on, then relative paths are canonicalized in no-stat mode.
+; If set, then files included via stream wrappers can not be cached
+; as realpath() does not support stream wrappers.
+;apc.canonicalize=1
+
; With write_lock enabled, only one process at a time will try to compile an
; uncached script while the other processes will run uncached
-apc.write_lock=1
+;apc.write_lock=1
+
; Logs any scripts that were automatically excluded from being cached due to early/late binding issues.
-apc.report_autofilter=0
+;apc.report_autofilter=0
+
; RFC1867 File Upload Progress hook handler
-apc.rfc1867=0
-apc.rfc1867_prefix =upload_
-apc.rfc1867_name=APC_UPLOAD_PROGRESS
-apc.rfc1867_freq=0
-apc.rfc1867_ttl=3600
-; Optimize include_once and require_once calls and avoid the expensive system calls used.
-apc.include_once_override=0
-apc.lazy_classes=0
-apc.lazy_functions=0
+;apc.rfc1867=0
+;apc.rfc1867_prefix =upload_
+;apc.rfc1867_name=APC_UPLOAD_PROGRESS
+;apc.rfc1867_freq=0
+;apc.rfc1867_ttl=3600
+
; Enables APC handling of signals, such as SIGSEGV, that write core files when signaled.
; APC will attempt to unmap the shared memory segment in order to exclude it from the core file
-apc.coredump_unmap=0
+;apc.coredump_unmap=0
+
; Records a md5 hash of files.
-apc.file_md5=0
+;apc.file_md5=0
+
; not documented
-apc.preload_path
+;apc.preload_path=
diff --git a/php-pecl-apc-dev.spec b/php-pecl-apc-dev.spec
deleted file mode 100644
index b4fadf2..0000000
--- a/php-pecl-apc-dev.spec
+++ /dev/null
@@ -1,388 +0,0 @@
-%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
-
-%global pecl_name APC
-%global svnrev 329724
-# TODO rev >= 329725 have opcache default on (so need to be fixed)
-
-Summary: APC caches and optimizes PHP intermediate code
-Name: php-pecl-apc
-Version: 3.1.15
-Release: 0.1.svn%{svnrev}%{?dist}.2
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/APC
-# svn export -r 329724 http://svn.php.net/repository/pecl/apc/trunk APC-3.1.15
-# tar czf APC-3.1.15-dev.tgz APC-3.1.15
-Source0: http://pecl.php.net/get/APC-%{version}%{?svnrev:-dev}.tgz
-Source1: apc-dev.ini
-Source2: apc-panel.conf
-Source3: apc.conf.php
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: php-devel
-BuildRequires: php-pear
-BuildRequires: httpd-devel
-# Only for tests (used by some unit tests)
-BuildRequires: php-dom
-
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
-
-Provides: php-apc = %{version}
-Provides: php-apc%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
-
-# Other third party repo stuff
-Obsoletes: php53-pecl-apc
-Obsoletes: php53u-pecl-apc
-%if "%{php_version}" > "5.4"
-Obsoletes: php54-pecl-apc
-%endif
-%if "%{php_version}" > "5.5"
-Obsoletes: php55-pecl-apc
-%endif
-
-# Filter private shared
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-
-
-%description
-APC is a free, open, and robust framework for caching and optimizing PHP
-intermediate code.
-
-
-%package devel
-Summary: APC developer files (header)
-Group: Development/Libraries
-Requires: php-pecl-apc%{?_isa} = %{version}-%{release}
-Requires: php-devel%{?_isa}
-
-%description devel
-These are the files needed to compile programs using APC serializer.
-
-
-%package -n apc-panel
-Summary: APC control panel
-Group: Applications/Internet
-%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
-BuildArch: noarch
-%endif
-Requires: %{name} = %{version}-%{release}
-Requires: mod_php, httpd, php-gd
-
-%description -n apc-panel
-This package provides the APC control panel, with Apache
-configuration, available on http://localhost/apc-panel/
-
-
-%prep
-%setup -q -c
-%if 0%{?svnrev}
-sed -e "/release/s/%{version}/%{version}dev/" \
- -e "/date/s/2013-??-??/2013-03-10/" \
- APC-%{version}/package.xml >package.xml
-grep date package.xml
-%endif
-
-cd APC-%{version}
-
-sed -e "/PHP_CLI_SERVER_PORT/s/8964/8960+PHP_INT_SIZE/" \
- -i tests/server_test.inc
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_APC_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
-if test "x${extver}" != "x%{version}%{?svnrev:-dev}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?svnrev:-dev}..
- exit 1
-fi
-cd ..
-
-# duplicate for ZTS build
-cp -pr APC-%{version} APC-%{version}-zts
-
-
-%build
-cd APC-%{version}
-%{_bindir}/phpize
-%configure --enable-apc-mmap --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-cd ../APC-%{version}-zts
-%{_bindir}/zts-phpize
-%configure --enable-apc-mmap --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-
-
-%install
-rm -rf %{buildroot}
-# Install the NTS stuff
-pushd APC-%{version}
-make install INSTALL_ROOT=%{buildroot}
-
-# Fix the charset of NOTICE
-iconv -f iso-8859-1 -t utf8 NOTICE >NOTICE.utf8
-mv NOTICE.utf8 NOTICE
-popd
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/apc.ini
-
-# Install the ZTS stuff
-pushd APC-%{version}-zts
-make install INSTALL_ROOT=%{buildroot}
-popd
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/apc.ini
-
-# Install the package XML file
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-# Install the Control Panel
-# Pages
-install -d -m 755 %{buildroot}%{_datadir}/apc-panel
-sed -e s:apc.conf.php:%{_sysconfdir}/apc-panel/conf.php:g \
- APC-%{version}/apc.php >%{buildroot}%{_datadir}/apc-panel/index.php
-# Apache config
-install -D -m 644 -p %{SOURCE2} \
- %{buildroot}%{_sysconfdir}/httpd/conf.d/apc-panel.conf
-# Panel config
-install -D -m 644 -p %{SOURCE3} \
- %{buildroot}%{_sysconfdir}/apc-panel/conf.php
-
-
-%check
-%ifarch x86_64
-cd %{pecl_name}-%{version}
-ln -sf %{php_extdir}/dom.so modules/
-
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=dom.so -d extension=apc.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=0 \
-%{_bindir}/php -n run-tests.php
-
-cd ../%{pecl_name}-%{version}-zts
-ln -sf %{php_ztsextdir}/dom.so modules/
-
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=dom.so -d extension=apc.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=0 \
-%{__ztsphp} -n run-tests.php
-%else
-: minimal load test
-%{__php} -n -d extension_dir=%{pecl_name}-%{version}/modules -d extension=apc.so -m | grep apc
-%{__ztsphp} -n -d extension_dir=%{pecl_name}-%{version}-zts/modules -d extension=apc.so -m | grep apc
-%endif
-
-
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-
-
-%postun
-if [ $1 -eq 0 ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%doc APC-%{version}/TECHNOTES.txt APC-%{version}/CHANGELOG APC-%{version}/LICENSE
-%doc APC-%{version}/NOTICE APC-%{version}/TODO APC-%{version}/apc.php
-%doc APC-%{version}/INSTALL
-%config(noreplace) %{php_inidir}/apc.ini
-%{php_extdir}/apc.so
-%{pecl_xmldir}/%{name}.xml
-
-%{php_ztsextdir}/apc.so
-%config(noreplace) %{php_ztsinidir}/apc.ini
-
-%files devel
-%defattr(-,root,root,-)
-%{php_incldir}/ext/apc
-%{php_ztsincldir}/ext/apc
-
-%files -n apc-panel
-%defattr(-,root,root,-)
-# Need to restrict access, as it contains a clear password
-%attr(750,apache,root) %dir %{_sysconfdir}/apc-panel
-%config(noreplace) %{_sysconfdir}/apc-panel/conf.php
-%config(noreplace) %{_sysconfdir}/httpd/conf.d/apc-panel.conf
-%{_datadir}/apc-panel
-
-
-%changelog
-* Sun Mar 10 2013 Remi Collet <remi@fedoraproject.org> - 3.1.15-0.1.svn329724
-- update to 3.1.15dev (svn snaphot) with new directive to enable opcache
- (default disabled) and allow to cache user data and use zendoptimizerplus
-
-* Tue Dec 18 2012 Remi Collet <remi@fedoraproject.org> - 3.1.14-0.1.svn328828
-- new snapshot
-
-* Mon Dec 10 2012 Remi Collet <remi@fedoraproject.org> - 3.1.14-0.1.svn328704
-- build SVN snapshot for PHP 5.5
-
-* Mon Nov 19 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-3.1
-- apc-panel requires php-gd
-- also provides php-apc
-- only run test on x86_64
-
-* Fri Oct 26 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-3
-- move apc.ini to Source3
-- new apc-panel package
-
-* Tue Sep 4 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-2
-- sync with rawhide
-- EL rebuild
-
-* Mon Sep 3 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-1
-- Version 3.1.13 (beta) - API 3.1.0 (stable)
-- add patches from upstream (fixes some tests)
-- change serveur port for tests (allow 32/64 bits build)
-- obsoletes php53*, php54*
-
-* Sun Aug 26 2012 Remi Collet <remi@fedoraproject.org> - 3.1.12-2
-- add patches from upstream
-- delete tests which fail because of missing dom extension
-
-* Thu Aug 16 2012 Remi Collet <remi@fedoraproject.org> - 3.1.12-1
-- Version 3.1.12 (beta) - API 3.1.0 (stable)
-- spec cleanups
-
-* Fri Jul 20 2012 Remi Collet <remi@fedoraproject.org> - 3.1.11-1
-- update to 3.1.11 (beta)
-
-* Fri Jun 22 2012 Remi Collet <remi@fedoraproject.org> - 3.1.10-2.1
-- sync with rawhide, rebuild for remi repo
-
-* Fri Jun 22 2012 Remi Collet <remi@fedoraproject.org> - 3.1.10-2
-- add patches from upstream
-
-* Wed Apr 11 2012 Remi Collet <remi@fedoraproject.org> - 3.1.10-2
-- Update to 3.1.10 (beta) for PHP 5.4
-
-* Wed Apr 11 2012 Remi Collet <remi@fedoraproject.org> - 3.1.10-1
-- Update to 3.1.10 (beta) for PHP 5.3
-- fix reported version, https://bugs.php.net/61696
-
-* Sun Mar 18 2012 Remi Collet <remi@fedoraproject.org> - 3.1.9-8.svn324329
-- pull changes from SVN revision 324329
-
-* Mon Mar 12 2012 Remi Collet <remi@fedoraproject.org> - 3.1.9-7.svn324146
-- pull changes from SVN revision 324146, fix https://bugs.php.net/60658
-
-* Sun Mar 11 2012 Remi Collet <remi@fedoraproject.org> - 3.1.9-7.svn324037
-- pull changes from SVN revision 324037
-- add patch from https://bugs.php.net/61238
-
-* Mon Feb 27 2012 Remi Collet <remi@fedoraproject.org> - 3.1.9-6.svn323587
-- pull changes from SVN revision 323587
-
-* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 3.1.9-5.svn322617
-- pull changes from SVN revision 322617
-
-* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 3.1.9-4.svn316786
-- pull changes from SVN revision 316786
-- build against php 5.4
-
-* Sat Sep 16 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.9-3
-- rebuild using latest php version and macro
-
-* Tue Aug 24 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.9-2
-- build zts extension
-
-* Sun May 15 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.9-1
-- update to 3.1.9 (bugfix, stable)
-
-* Sat May 14 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.8-2
-- fix for http://pecl.php.net/bugs/22687
-
-* Tue May 3 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.8-1
-- update to 3.1.8 (bugfix, stable)
-
-* Thu Feb 17 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.7-1.1
-- test rebuild with new Arch specific ABI macro
-
-* Wed Jan 12 2011 Remi Collet <Fedora@FamilleCollet.com> - 3.1.7-1
-- update to 3.1.7 (bugfix)
-- add devel subpackage (for serializer)
-
-* Mon Dec 27 2010 Remi Collet <rpms@famillecollet.com> 3.1.6-2
-- relocate using phpname macro
-
-* Tue Nov 30 2010 Remi Collet <Fedora@FamilleCollet.com> - 3.1.6-1
-- update to 3.1.6 (bugfix)
-
-* Wed Nov 03 2010 Remi Collet <Fedora@FamilleCollet.com> - 3.1.5-2
-- fix reported version, see http://pecl.php.net/bugs/19590
-
-* Wed Nov 03 2010 Remi Collet <Fedora@FamilleCollet.com> - 3.1.5-1
-- update to 3.1.5 (bugfix)
-
-* Sat Oct 23 2010 Remi Collet <Fedora@FamilleCollet.com> - 3.1.4-3
-- add filter_provides to avoid private-shared-object-provides apc.so
-
-* Sun Aug 08 2010 Remi Collet <Fedora@FamilleCollet.com> - 3.1.4-2
-- fix default value for apc.shm_size (need M suffixes)
-
-* Thu Aug 05 2010 Remi Collet <Fedora@FamilleCollet.com> - 3.1.4-1
-- update to Version 3.1.4 (beta) - API 3.1.0 (beta)
-
-* Fri Aug 14 2009 Remi Collet <Fedora@FamilleCollet.com> - 3.1.3p1-1
-- update to 3.1.3 patch1 (beta, for PHP 5.3 support)
-- add test suite (disabled for http://pecl.php.net/bugs/bug.php?id=16793)
-- add use_request_time, lazy_classes, lazy_functions options (apc.ini)
-
-* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.2-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
-
-* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> - 3.1.2-1
-- update to 3.1.2 (beta) - PHP 5.3 support
-- use setup -q -c
-
-* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.19-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
-
-* Wed Jun 25 2008 Tim Jackson <rpm@timj.co.uk> - 3.0.19-1
-- Update to 3.0.19
-- Fix PHP Zend API/ABI dependencies to work on EL-4/5
-- Fix "License" tag
-- Fix encoding of "NOTICE" file
-- Add registration via PECL
-
-* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.14-3
-- Autorebuild for GCC 4.3
-
-* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.0.14-2
-- Rebuild for selinux ppc32 issue.
-
-* Thu Jun 28 2007 Chris Chabot <chabotc@xs4all.nl> - 3.0.14-1
-- Updated to 3.0.14
-- Included new php api snipplets
-
-* Fri Sep 15 2006 Chris Chabot <chabotc@xs4all.nl> - 3.0.12-5
-- Updated to new upstream version
-
-* Mon Sep 11 2006 Chris Chabot <chabotc@xs4all.nl> - 3.0.10-5
-- FC6 rebuild
-
-* Sun Aug 13 2006 Chris Chabot <chabotc@xs4all.nl> - 3.0.10-4
-- FC6T2 rebuild
-
-* Mon Jun 19 2006 - Chris Chabot <chabotc@xs4all.nl> - 3.0.10-3
-- Renamed to php-pecl-apc and added provides php-apc
-- Removed php version string from the package version
-
-* Mon Jun 19 2006 - Chris Chabot <chabotc@xs4all.nl> - 3.0.10-2
-- Trimmed down BuildRequires
-- Added Provices php-pecl(apc)
-
-* Sun Jun 18 2006 - Chris Chabot <chabotc@xs4all.nl> - 3.0.10-1
-- Initial package, templated on already existing php-json
- and php-eaccelerator packages
diff --git a/php-pecl-apc.spec b/php-pecl-apc.spec
index 850d70f..4abb37e 100644
--- a/php-pecl-apc.spec
+++ b/php-pecl-apc.spec
@@ -1,25 +1,22 @@
-%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
%global pecl_name APC
+%global svnrev 329913
Summary: APC caches and optimizes PHP intermediate code
Name: php-pecl-apc
-Version: 3.1.14
-Release: 1%{?dist}.1
+Version: 3.1.15
+Release: 0.3.svn%{svnrev}%{?dist}.1
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/APC
-Source0: http://pecl.php.net/get/APC-%{version}.tgz
+# svn export -r 329913 http://svn.php.net/repository/pecl/apc/trunk APC-3.1.15
+# tar czf APC-3.1.15-dev.tgz APC-3.1.15
+Source0: http://pecl.php.net/get/APC-%{version}%{?svnrev:-dev}.tgz
Source1: apc.ini
Source2: apc-panel.conf
Source3: apc.conf.php
-# Upstream patches from SVN
-# http://svn.php.net/viewvc?view=revision&revision=328955
-# http://svn.php.net/viewvc?view=revision&revision=328956
-# http://svn.php.net/viewvc?view=revision&revision=328957
-Patch0: apc-svn.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: php-devel
BuildRequires: php-pear
@@ -32,9 +29,6 @@ Requires(postun): %{__pecl}
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
-Conflicts: php-mmcache
-Conflicts: php-eaccelerator
-Conflicts: php-xcache
Provides: php-apc = %{version}
Provides: php-apc%{?_isa} = %{version}
Provides: php-pecl(%{pecl_name}) = %{version}
@@ -85,27 +79,40 @@ configuration, available on http://localhost/apc-panel/
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
+%setup -q -c
+%if 0%{?svnrev}
+sed -e "/release/s/%{version}/%{version}dev/" \
+ -e "/date/s/2013-??-??/2013-03-25/" \
+ APC-%{version}/package.xml >package.xml
+%endif
cd APC-%{version}
-%patch0 -p0 -b .php55
-%if 0%{?__isa_bits}
-# port number to allow 32/64 build at same time
-port=$(expr %{__isa_bits} + 8900)
-sed -e "/PHP_CLI_SERVER_PORT/s/8964/$port/" \
- -i tests/server_test.inc
+%if "%{php_version}" > "5.5"
+# With PHP > 5.5, disable
+sed -e '/apc.enable_opcode_cache/s/1/0/' \
+ -i php_apc.c
+sed -e '/apc.enable_opcode_cache/s/1/0/' \
+ %{SOURCE1} > ../apc.ini
+%else
+# With PHP < 5.4, enable
+sed -e '/apc.enable_opcode_cache/s/0/1/' \
+ -i php_apc.c
+sed -e '/apc.enable_opcode_cache/s/0/1/' \
+ %{SOURCE1} > ../apc.ini
%endif
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_APC_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
+if test "x${extver}" != "x%{version}%{?svnrev:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?svnrev:-dev}..
exit 1
fi
cd ..
+# Fix the charset of NOTICE
+iconv -f iso-8859-1 -t utf8 APC-%{version}/NOTICE >NOTICE
+
# duplicate for ZTS build
cp -pr APC-%{version} APC-%{version}-zts
@@ -124,21 +131,15 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
+
# Install the NTS stuff
-pushd APC-%{version}
-make install INSTALL_ROOT=%{buildroot}
+make install -C APC-%{version} INSTALL_ROOT=%{buildroot}
-# Fix the charset of NOTICE
-iconv -f iso-8859-1 -t utf8 NOTICE >NOTICE.utf8
-mv NOTICE.utf8 NOTICE
-popd
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/apc.ini
+install -D -m 644 apc.ini %{buildroot}%{php_inidir}/apc.ini
# Install the ZTS stuff
-pushd APC-%{version}-zts
-make install INSTALL_ROOT=%{buildroot}
-popd
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/apc.ini
+make install -C APC-%{version}-zts INSTALL_ROOT=%{buildroot}
+install -D -m 644 apc.ini %{buildroot}%{php_ztsinidir}/apc.ini
# Install the package XML file
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -164,7 +165,7 @@ ln -sf %{php_extdir}/dom.so modules/
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=dom.so -d extension=apc.so" \
NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
+REPORT_EXIT_STATUS=0 \
%{_bindir}/php -n run-tests.php
cd ../%{pecl_name}-%{version}-zts
@@ -173,12 +174,16 @@ ln -sf %{php_ztsextdir}/dom.so modules/
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=dom.so -d extension=apc.so" \
NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
+REPORT_EXIT_STATUS=0 \
%{__ztsphp} -n run-tests.php
%else
: minimal load test
-%{__php} -n -d extension_dir=%{pecl_name}-%{version}/modules -d extension=apc.so -m | grep apc
-%{__ztsphp} -n -d extension_dir=%{pecl_name}-%{version}-zts/modules -d extension=apc.so -m | grep apc
+%{__php} -n \
+ -d extension_dir=%{pecl_name}-%{version}/modules \
+ -d extension=apc.so -m | grep apc
+%{__ztsphp} -n \
+ -d extension_dir=%{pecl_name}-%{version}-zts/modules \
+ -d extension=apc.so -m | grep apc
%endif
@@ -198,9 +203,8 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc APC-%{version}/TECHNOTES.txt APC-%{version}/CHANGELOG APC-%{version}/LICENSE
-%doc APC-%{version}/NOTICE APC-%{version}/TODO APC-%{version}/apc.php
-%doc APC-%{version}/INSTALL
+%doc APC-%{version}/{TECHNOTES.txt,CHANGELOG,LICENSE,INSTALL,TODO,apc.php}
+%doc NOTICE
%config(noreplace) %{php_inidir}/apc.ini
%{php_extdir}/apc.so
%{pecl_xmldir}/%{name}.xml
@@ -223,9 +227,23 @@ rm -rf %{buildroot}
%changelog
+* Wed Apr 17 2013 Remi Collet <remi@fedoraproject.org> - 3.1.15-0.3.svn329913
+- update to latest snapshot
+- switch most configuration to upstream default
+
+* Sun Mar 10 2013 Remi Collet <remi@fedoraproject.org> - 3.1.15-0.1.svn329724
+- update to 3.1.15dev (svn snaphot) with new directive to enable opcache
+ (default disabled) and allow to cache user data and use zendoptimizerplus
+
* Thu Jan 3 2013 Remi Collet <remi@fedoraproject.org> - 3.1.14-1
- Version 3.1.14 (beta) - API 3.1.0 (stable)
+* Tue Dec 18 2012 Remi Collet <remi@fedoraproject.org> - 3.1.14-0.1.svn328828
+- new snapshot
+
+* Mon Dec 10 2012 Remi Collet <remi@fedoraproject.org> - 3.1.14-0.1.svn328704
+- build SVN snapshot for PHP 5.5
+
* Mon Nov 19 2012 Remi Collet <remi@fedoraproject.org> - 3.1.13-3.1
- apc-panel requires php-gd
- also provides php-apc