summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--apc-dev.ini75
-rw-r--r--php-pecl-apc-dev.spec34
2 files changed, 98 insertions, 11 deletions
diff --git a/apc-dev.ini b/apc-dev.ini
new file mode 100644
index 0000000..2b39aaf
--- /dev/null
+++ b/apc-dev.ini
@@ -0,0 +1,75 @@
+; Enable apc extension module
+extension = apc.so
+
+; Options for the APC module version >= 3.1.3
+; See http://www.php.net/manual/en/apc.configuration.php
+
+
+; This can be set to enable the old opcode cache
+; Don't use this option if zendoptimizerplus is enabled
+apc.enable_opcode_cache=0
+; This can be set to 0 to disable APC.
+apc.enabled=1
+; The number of shared memory segments to allocate for the compiler cache.
+apc.shm_segments=1
+; The size of each shared memory segment, with M/G suffixe
+apc.shm_size=64M
+; A "hint" about the number of distinct source files that will be included or
+; requested on your web server. Set to zero or omit if you are not sure;
+apc.num_files_hint=1024
+; Just like num_files_hint, a "hint" about the number of distinct user cache
+; variables to store. Set to zero or omit if you are not sure;
+apc.user_entries_hint=4096
+; The number of seconds a cache entry is allowed to idle in a slot in case this
+; cache entry slot is needed by another entry.
+apc.ttl=7200
+; use the SAPI request start time for TTL
+apc.use_request_time=1
+; The number of seconds a user cache entry is allowed to idle in a slot in case
+; this cache entry slot is needed by another entry.
+apc.user_ttl=7200
+; The number of seconds that a cache entry may remain on the garbage-collection list.
+apc.gc_ttl=3600
+; On by default, but can be set to off and used in conjunction with positive
+; apc.filters so that files are only cached if matched by a positive filter.
+apc.cache_by_default=1
+; A comma-separated list of POSIX extended regular expressions.
+apc.filters
+; The mktemp-style file_mask to pass to the mmap module
+apc.mmap_file_mask=/tmp/apc.XXXXXX
+; This file_update_protection setting puts a delay on caching brand new files.
+apc.file_update_protection=2
+; Setting this enables APC for the CLI version of PHP (Mostly for testing and debugging).
+apc.enable_cli=0
+; Prevents large files from being cached
+apc.max_file_size=1M
+; Whether to stat the main script file and the fullpath includes.
+apc.stat=1
+; Vertification with ctime will avoid problems caused by programs such as svn or rsync by making
+; sure inodes have not changed since the last stat. APC will normally only check mtime.
+apc.stat_ctime=0
+; Whether to canonicalize paths in stat=0 mode or fall back to stat behaviour
+apc.canonicalize=0
+; With write_lock enabled, only one process at a time will try to compile an
+; uncached script while the other processes will run uncached
+apc.write_lock=1
+; Logs any scripts that were automatically excluded from being cached due to early/late binding issues.
+apc.report_autofilter=0
+; RFC1867 File Upload Progress hook handler
+apc.rfc1867=0
+apc.rfc1867_prefix =upload_
+apc.rfc1867_name=APC_UPLOAD_PROGRESS
+apc.rfc1867_freq=0
+apc.rfc1867_ttl=3600
+; Optimize include_once and require_once calls and avoid the expensive system calls used.
+apc.include_once_override=0
+apc.lazy_classes=0
+apc.lazy_functions=0
+; Enables APC handling of signals, such as SIGSEGV, that write core files when signaled.
+; APC will attempt to unmap the shared memory segment in order to exclude it from the core file
+apc.coredump_unmap=0
+; Records a md5 hash of files.
+apc.file_md5=0
+; not documented
+apc.preload_path
+
diff --git a/php-pecl-apc-dev.spec b/php-pecl-apc-dev.spec
index a069c6a..4bb5014 100644
--- a/php-pecl-apc-dev.spec
+++ b/php-pecl-apc-dev.spec
@@ -1,24 +1,27 @@
%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
%global pecl_name APC
-%global svnrev 328828
+%global svnrev 329724
+# TODO rev >= 329725 have opcache default on (so need to be fixed)
Summary: APC caches and optimizes PHP intermediate code
Name: php-pecl-apc
-Version: 3.1.14
+Version: 3.1.15
Release: 0.1.svn%{svnrev}%{?dist}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/APC
-# svn export -r 328828 http://svn.php.net/repository/pecl/apc/trunk APC-3.1.14
-# tar czf APC-3.1.14-dev.tgz APC-3.1.14
+# svn export -r 329724 http://svn.php.net/repository/pecl/apc/trunk APC-3.1.15
+# tar czf APC-3.1.15-dev.tgz APC-3.1.15
Source0: http://pecl.php.net/get/APC-%{version}%{?svnrev:-dev}.tgz
-Source1: apc.ini
+Source1: apc-dev.ini
Source2: apc-panel.conf
Source3: apc.conf.php
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: php-devel >= 5.1.0, httpd-devel, php-pear
+BuildRequires: php-devel
+BuildRequires: php-pear
+BuildRequires: httpd-devel
# Only for tests (used by some unit tests)
BuildRequires: php-dom
@@ -27,8 +30,6 @@ Requires(postun): %{__pecl}
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
-Conflicts: php-mmcache
-Conflicts: php-eaccelerator
Provides: php-apc = %{version}
Provides: php-apc%{?_isa} = %{version}
Provides: php-pecl(%{pecl_name}) = %{version}
@@ -40,6 +41,9 @@ Obsoletes: php53u-pecl-apc
%if "%{php_version}" > "5.4"
Obsoletes: php54-pecl-apc
%endif
+%if "%{php_version}" > "5.5"
+Obsoletes: php55-pecl-apc
+%endif
# Filter private shared
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
@@ -78,8 +82,8 @@ configuration, available on http://localhost/apc-panel/
%prep
%setup -q -c
%if 0%{?svnrev}
-sed -e '/release/s/%{version}-dev/%{version}dev/' \
- -e '/date/s/2012-??-??/2012-12-10/' \
+sed -e "/release/s/%{version}/%{version}dev/" \
+ -e "/date/s/2013-??-??/2013-03-10/" \
APC-%{version}/package.xml >package.xml
grep date package.xml
%endif
@@ -159,7 +163,7 @@ ln -sf %{php_extdir}/dom.so modules/
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=dom.so -d extension=apc.so" \
NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
+REPORT_EXIT_STATUS=0 \
%{_bindir}/php -n run-tests.php
cd ../%{pecl_name}-%{version}-zts
@@ -170,6 +174,10 @@ TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=dom.so -d extension
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=0 \
%{__ztsphp} -n run-tests.php
+%else
+: minimal load test
+%{__php} -n -d extension_dir=%{pecl_name}-%{version}/modules -d extension=apc.so -m | grep apc
+%{__ztsphp} -n -d extension_dir=%{pecl_name}-%{version}-zts/modules -d extension=apc.so -m | grep apc
%endif
@@ -214,6 +222,10 @@ rm -rf %{buildroot}
%changelog
+* Sun Mar 10 2013 Remi Collet <remi@fedoraproject.org> - 3.1.15-0.1.svn329724
+- update to 3.1.15dev (svn snaphot) with new directive to enable opcache
+ (default disabled) and allow to cache user data and use zendoptimizerplus
+
* Tue Dec 18 2012 Remi Collet <remi@fedoraproject.org> - 3.1.14-0.1.svn328828
- new snapshot