summaryrefslogtreecommitdiffstats
path: root/php-pecl-ahocorasick.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-03-15 09:38:14 +0100
committerRemi Collet <remi@remirepo.net>2019-03-15 09:38:14 +0100
commitc4e942953e32789edb2d2d978b1dc663a45ca1ce (patch)
tree8a2d7f4afc1163e587ac37c49ff4d856ce6af147 /php-pecl-ahocorasick.spec
parent23f2f19feff8cbe58faef9f7bdf1e54dce53ed74 (diff)
update to 0.0.4
drop patch merged upstream open https://github.com/ph4r05/php_aho_corasick/pull/17 fix version open https://github.com/ph4r05/php_aho_corasick/pull/16 travis run upstream test suite added in https://github.com/ph4r05/php_aho_corasick/pull/13 open https://github.com/ph4r05/php_aho_corasick/pull/18 arginfo
Diffstat (limited to 'php-pecl-ahocorasick.spec')
-rw-r--r--php-pecl-ahocorasick.spec30
1 files changed, 24 insertions, 6 deletions
diff --git a/php-pecl-ahocorasick.spec b/php-pecl-ahocorasick.spec
index 035aab8..ec1e7ee 100644
--- a/php-pecl-ahocorasick.spec
+++ b/php-pecl-ahocorasick.spec
@@ -19,17 +19,19 @@
%global ini_name 40-%{pecl_name}.ini
%endif
# Nothing yet
-%global with_tests 0%{?_with_tests:1}
+%global with_tests 0%{!?_without_tests:1}
Summary: Effective Aho-Corasick string pattern matching algorithm
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.0.3
+Version: 0.0.4
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP and LGPLv3
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://github.com/ph4r05/php_aho_corasick/pull/11.patch
+Patch0: https://github.com/ph4r05/php_aho_corasick/pull/17.patch
+Patch1: https://github.com/ph4r05/php_aho_corasick/pull/18.patch
+Patch2: https://github.com/ph4r05/php_aho_corasick/commit/5687f6975d8c18223f114d0d0f1246c505b6f101.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -96,14 +98,15 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr11
+%patch0 -p1 -b .pr17
+%patch1 -p1 -b .pr18
+%patch2 -p1 -b .up
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_AHOCORASICK_VERSION/{s/.* "//;s/".*$//;p}' src/php_ahocorasick.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
- # TODO check this with upstream
- #exit 1
+ exit 1
fi
cd ..
@@ -183,6 +186,12 @@ fi
%check
+%if "%{php_version}" > "7.3"
+# See https://github.com/ph4r05/php_aho_corasick/pull/16
+rm ?TS/tests/test1.phpt
+rm ?TS/tests/test3.phpt
+%endif
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -231,6 +240,15 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Mar 15 2019 Remi Collet <remi@remirepo.net> - 0.0.4-1
+- update to 0.0.4
+- drop patch merged upstream
+- open https://github.com/ph4r05/php_aho_corasick/pull/17 fix version
+- open https://github.com/ph4r05/php_aho_corasick/pull/16 travis
+- run upstream test suite added in
+ https://github.com/ph4r05/php_aho_corasick/pull/13
+- open https://github.com/ph4r05/php_aho_corasick/pull/18 arginfo
+
* Thu Mar 14 2019 Remi Collet <remi@remirepo.net> - 0.0.3-1
- update to 0.0.3
- open https://github.com/ph4r05/php_aho_corasick/pull/11