summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--71.patch23
-rw-r--r--pear-proxy.patch26
-rw-r--r--php-pear.spec11
3 files changed, 32 insertions, 28 deletions
diff --git a/71.patch b/71.patch
new file mode 100644
index 0000000..88da655
--- /dev/null
+++ b/71.patch
@@ -0,0 +1,23 @@
+From c5f321f171783c1b088490dcaf39b0aad5eb5c13 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 12 Oct 2017 09:35:57 +0200
+Subject: [PATCH] fix Warning: count(): Parameter must be an array or an
+ object that implements Countable in PEAR/RunTest.php on line 346
+
+---
+ PEAR/RunTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/PEAR/RunTest.php b/PEAR/RunTest.php
+index 8eabac3c3..482beccb3 100644
+--- a/PEAR/RunTest.php
++++ b/PEAR/RunTest.php
+@@ -343,7 +343,7 @@ function run($file, $ini_settings = array(), $test_number = 1)
+
+ // Check if test should be skipped.
+ $res = $this->_runSkipIf($section_text, $temp_skipif, $tested, $ini_settings);
+- if (count($res) != 2) {
++ if ($res == 'SKIPPED' || count($res) != 2) {
+ return $res;
+ }
+ $info = $res['info'];
diff --git a/pear-proxy.patch b/pear-proxy.patch
deleted file mode 100644
index d5d7685..0000000
--- a/pear-proxy.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 798621dda8328228a6cccfc09a7b7cce77ba3424 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Wed, 30 Mar 2016 11:45:21 +0200
-Subject: [PATCH] fix https connection via proxy
-
----
- PEAR/REST.php | 6 +-----
- 1 file changed, 1 insertion(+), 5 deletions(-)
-
-diff --git a/PEAR/REST.php b/PEAR/REST.php
-index 1e472b7..00129ba 100644
---- a/PEAR/REST.php
-+++ b/PEAR/REST.php
-@@ -360,11 +360,7 @@ function downloadHttp($url, $lastmodified = null, $accept = false, $channel = fa
- if ($this->config->get('http_proxy')&&
- $proxy = parse_url($this->config->get('http_proxy'))
- ) {
-- $proxy_host = isset($proxy['host']) ? $proxy['host'] : null;
-- if ($schema === 'https') {
-- $proxy_host = 'ssl://' . $proxy_host;
-- }
--
-+ $proxy_host = isset($proxy['host']) ? $proxy['host'] : null;
- $proxy_port = isset($proxy['port']) ? $proxy['port'] : 8080;
- $proxy_user = isset($proxy['user']) ? urldecode($proxy['user']) : null;
- $proxy_pass = isset($proxy['pass']) ? urldecode($proxy['pass']) : null;
diff --git a/php-pear.spec b/php-pear.spec
index 619fcb2..6a3b9fd 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -40,7 +40,7 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
Version: 1.10.5
-Release: 5%{?dist}
+Release: 6%{?dist}
Epoch: 1
# PEAR, PEAR_Manpages, Archive_Tar, XML_Util, Console_Getopt are BSD
# Structures_Graph is LGPLv3+
@@ -62,6 +62,9 @@ Source23: http://pear.php.net/get/Structures_Graph-%{structver}.tgz
Source24: http://pear.php.net/get/XML_Util-%{xmlutil}.tgz
Source25: http://pear.php.net/get/PEAR_Manpages-%{manpages}.tgz
+# https://github.com/pear/pear-core/pull/71
+Patch0: https://patch-diff.githubusercontent.com/raw/pear/pear-core/pull/71.patch
+
BuildArch: noarch
BuildRequires: %{?scl_prefix}php(language) > 5.4
BuildRequires: %{?scl_prefix}php-cli
@@ -276,7 +279,7 @@ install -m 644 -D macros.pear \
# apply patches on installed PEAR tree
pushd %{buildroot}%{peardir}
-: no patch \\o/
+patch --no-backup --fuzz 0 -p1 < %{PATCH0}
popd
# Why this file here ?
@@ -462,6 +465,10 @@ fi
%changelog
+* Tue Feb 13 2018 Remi Collet <remi@remirepo.net> - 1:1.10.5-6
+- add patch for PHP 7.2 from
+ https://github.com/pear/pear-core/pull/71
+
* Tue Dec 19 2017 Remi Collet <remi@remirepo.net> - 1:1.10.5-5
- drop autoloader from SCL packages