summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--12.patch24
-rw-r--r--php-pear.spec15
2 files changed, 9 insertions, 30 deletions
diff --git a/12.patch b/12.patch
deleted file mode 100644
index 48448bf..0000000
--- a/12.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From e2c9854408bc0b45206336060e28603de3371c99 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 12 Dec 2019 14:17:38 +0100
-Subject: [PATCH] fix Trying to access array offset on value of type int
-
----
- XML/Util.php | 2 +-
- tests/IsValidNameTests.php | 24 ++++++++++++++++++++++++
- 2 files changed, 25 insertions(+), 1 deletion(-)
-
-diff --git a/XML/Util.php b/XML/Util.php
-index df37e07..1ba45ac 100644
---- a/XML/Util.php
-+++ b/XML/Util.php
-@@ -918,7 +918,7 @@ public static function splitQualifiedName($qname, $defaultNs = null)
- public static function isValidName($string)
- {
- // check for invalid chars
-- if (!preg_match('/^[[:alpha:]_]\\z/', $string[0])) {
-+ if (!is_string($string) || !strlen($string) || !preg_match('/^[[:alpha:]_]\\z/', $string[0])) {
- return XML_Util::raiseError(
- 'XML names may only start with letter or underscore',
- XML_UTIL_ERROR_INVALID_START
-
diff --git a/php-pear.spec b/php-pear.spec
index 75b9ef0..e8488be 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -24,7 +24,7 @@
# https://pear.php.net/bugs/bug.php?id=19367
# Structures_Graph 1.0.4 - incorrect FSF address
%global structver 1.1.1
-%global xmlutil 1.4.4
+%global xmlutil 1.4.5
%global manpages 1.10.0
# Tests are only run with rpmbuild --with tests
@@ -39,7 +39,7 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
-Version: 1.10.11
+Version: 1.10.12
Release: 1%{?dist}
Epoch: 1
# PEAR, PEAR_Manpages, Archive_Tar, XML_Util, Console_Getopt are BSD
@@ -61,8 +61,6 @@ Source23: http://pear.php.net/get/Structures_Graph-%{structver}.tgz
Source24: http://pear.php.net/get/XML_Util-%{xmlutil}.tgz
Source25: http://pear.php.net/get/PEAR_Manpages-%{manpages}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/pear/XML_Util/pull/12.patch
-
BuildArch: noarch
BuildRequires: %{?scl_prefix}php(language) > 5.4
BuildRequires: %{?scl_prefix}php-cli
@@ -279,11 +277,11 @@ install -m 644 -D macros.pear \
# apply patches on installed PEAR tree
pushd %{buildroot}%{peardir}
-patch -p1 < %{PATCH0}
+: no patch
popd
# Why this file here ?
-rm -rf %{buildroot}/.depdb* %{buildroot}/.lock $RPM_BUILD_ROOT/.channels $RPM_BUILD_ROOT/.filemap
+rm -rf %{buildroot}/.depdb* %{buildroot}/.lock %{buildroot}/.channels $RPM_BUILD_ROOT/.filemap
# Need for re-registrying XML_Util
install -pm 644 *.xml %{buildroot}%{_localstatedir}/lib/pear/pkgxml
@@ -464,6 +462,11 @@ fi
%changelog
+* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 1.10.12-1
+- update PEAR to 1.10.12
+- update XML_Util to 1.4.5
+- drop patch merged upstream
+
* Sat Apr 11 2020 Remi Collet <remi@remirepo.net> - 1.10.11-1
- update to 1.10.11
- drop patch merged upstream