summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--pear.sh6
-rw-r--r--pecl.sh6
-rw-r--r--php-pear.spec5
3 files changed, 4 insertions, 13 deletions
diff --git a/pear.sh b/pear.sh
index d0f10ed..218014a 100644
--- a/pear.sh
+++ b/pear.sh
@@ -1,11 +1,5 @@
#!/bin/sh
-EXT="-d extension=posix.so"
-DIR=$(/usr/bin/php -n -r 'echo ini_get("extension_dir");')
-if [ -f $DIR/xml.so ] ; then
- EXT="$EXT -d extension=xml.so"
-fi
exec /usr/bin/php -C \
- -n $EXT \
-d include_path=/usr/share/pear \
-d date.timezone=UTC \
-d output_buffering=1 \
diff --git a/pecl.sh b/pecl.sh
index fbb999a..f150dd0 100644
--- a/pecl.sh
+++ b/pecl.sh
@@ -1,11 +1,5 @@
#!/bin/sh
-EXT="-d extension=posix.so"
-DIR=$(/usr/bin/php -n -r 'echo ini_get("extension_dir");')
-if [ -f $DIR/xml.so ] ; then
- EXT="$EXT -d extension=xml.so"
-fi
exec /usr/bin/php -C \
- -n $EXT \
-d include_path=/usr/share/pear \
-d date.timezone=UTC \
-d output_buffering=1 \
diff --git a/php-pear.spec b/php-pear.spec
index 3524c50..7058937 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -17,7 +17,7 @@
Summary: PHP Extension and Application Repository framework
Name: php-pear
Version: 1.9.4
-Release: 26%{?dist}.1
+Release: 27%{?dist}
Epoch: 1
# PEAR, Archive_Tar, XML_Util are BSD
# Console_Getopt is PHP
@@ -322,6 +322,9 @@ fi
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> 1:1.9.4-27
+- revert previous, was a bad solution
+
* Thu Apr 10 2014 Remi Collet <rcollet@redhat.com> 1:1.9.4-26.1
- better fix to detect xml.so