From ef3eb70e53eab13366039b2ca7c6318f0895cf92 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Fri, 5 Dec 2014 12:53:13 +0100
Subject: php-pear-PHP-CodeSniffer: 2.0.0

---
 PHP_CodeSniffer-licence.txt   | 28 ----------------------------
 PHP_CodeSniffer-role.patch    | 10 ++++++++++
 php-pear-PHP-CodeSniffer.spec | 32 +++++++++++++++++---------------
 3 files changed, 27 insertions(+), 43 deletions(-)
 delete mode 100644 PHP_CodeSniffer-licence.txt
 create mode 100644 PHP_CodeSniffer-role.patch

diff --git a/PHP_CodeSniffer-licence.txt b/PHP_CodeSniffer-licence.txt
deleted file mode 100644
index b2f2ab1..0000000
--- a/PHP_CodeSniffer-licence.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-PHP_CodeSniffer Licence
-
-Copyright (c) 2006, Squiz Pty Ltd (ABN 77 084 670 600) All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-    * Redistributions of source code must retain the above copyright
-      notice, this list of conditions and the following disclaimer.
-    * Redistributions in binary form must reproduce the above copyright
-      notice, this list of conditions and the following disclaimer in
-      the documentation and/or other materials provided with the
-      distribution.
-    * Neither the name of Squiz Pty Ltd nor the names of its
-      contributors may be used to endorse or promote products derived
-      from this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
-IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
-TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
-OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
-EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
-PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
-LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
-NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PHP_CodeSniffer-role.patch b/PHP_CodeSniffer-role.patch
new file mode 100644
index 0000000..7e3ce1d
--- /dev/null
+++ b/PHP_CodeSniffer-role.patch
@@ -0,0 +1,10 @@
+--- package.xml.old	2014-12-05 12:39:59.000000000 +0100
++++ package.xml	2014-12-05 12:40:45.000000000 +0100
+@@ -1912,6 +1912,7 @@
+   <filelist>
+    <install as="phpcs" name="scripts/phpcs" />
+    <install as="phpcbf" name="scripts/phpcbf" />
++   <install as="phpcs-svn-pre-commit" name="scripts/phpcs-svn-pre-commit" />
+    <install as="README" name="README.md" />
+    <install as="CONTRIBUTING" name="CONTRIBUTING.md" />
+    <install as="LICENCE" name="licence.txt" />
diff --git a/php-pear-PHP-CodeSniffer.spec b/php-pear-PHP-CodeSniffer.spec
index bd3e071..d4d6aa2 100644
--- a/php-pear-PHP-CodeSniffer.spec
+++ b/php-pear-PHP-CodeSniffer.spec
@@ -13,7 +13,7 @@
 %global pear_name     PHP_CodeSniffer
 
 Name:           php-pear-PHP-CodeSniffer
-Version:        1.5.5
+Version:        2.0.0
 Release:        1%{?dist}
 Summary:        PHP coding standards enforcement tool
 
@@ -21,8 +21,8 @@ Group:          Development/Tools
 License:        BSD
 URL:            http://pear.php.net/package/PHP_CodeSniffer
 Source0:        http://pear.php.net/get/%{pear_name}-%{version}.tgz
-# https://github.com/squizlabs/PHP_CodeSniffer/issues/273
-Source1:        PHP_CodeSniffer-licence.txt
+
+Patch0:         %{pear_name}-role.patch
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch:      noarch
@@ -34,16 +34,14 @@ Requires(post): %{__pear}
 Requires(postun): %{__pear}
 # From package.xml
 Requires:       php-pear(PEAR)
-# From package.xml - optional
-Requires:       php-pear(pear.phpunit.de/PHP_Timer) >= 1.0.0
-# From phpcompatinfo report for version 1.5.5
+# From phpcompatinfo report for version 2.0.0
 Requires:       php-ctype
 Requires:       php-date
 Requires:       php-dom
 Requires:       php-iconv
 Requires:       php-pcre
 Requires:       php-reflection
-Requires:       php-simplexml
+Requires:       php-soap
 Requires:       php-spl
 Requires:       php-tokenizer
 Requires:       php-xmlwriter
@@ -62,8 +60,11 @@ certain standards, such as PEAR, or user-defined.
 %prep
 %setup -q -c
 
-sed -e '/phpcs-svn-pre-commit/s/role="script"/role="doc"/' \
-    package.xml >%{pear_name}-%{version}/%{pear_name}.xml
+# install scripts/phpcs-svn-pre-commit properly
+%patch0 -p0 -b .old
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{pear_name}.xml
 
 
 %build
@@ -83,17 +84,12 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
 mkdir -p %{buildroot}%{pear_xmldir}
 install -pm 644 %{pear_name}.xml %{buildroot}%{pear_xmldir}
 
-install -pm 644 %{SOURCE1} %{buildroot}%{pear_docdir}/%{pear_name}/LICENSE
-
 
 %check
 cd %{pear_name}-%{version}/tests
 
 # Version 1.5.5 : 216, Assertions: 57, Skipped: 4.
-%{_bindir}/phpunit \
-  -d date.timezone=UTC \
-  --verbose \
-  AllTests.php
+%{_bindir}/phpunit AllTests.php
 
 
 %clean
@@ -118,10 +114,16 @@ fi
 %{pear_testdir}/%{pear_name}
 %{pear_datadir}/%{pear_name}
 %{pear_phpdir}/PHP
+%{_bindir}/phpcbf
 %{_bindir}/phpcs
+%{_bindir}/phpcs-svn-pre-commit
 
 
 %changelog
+* Fri Dec 05 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- Update to 2.0.0
+- add phpcbf and phpcs-svn-pre-commit commands
+
 * Fri Sep 26 2014 Remi Collet <remi@fedoraproject.org> - 1.5.5-1
 - Update to 1.5.5 (stable)
 - provide php-composer(squizlabs/php_codesniffer)
-- 
cgit