summaryrefslogtreecommitdiffstats
path: root/php-pear-PHP-CodeSniffer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pear-PHP-CodeSniffer.spec')
-rw-r--r--php-pear-PHP-CodeSniffer.spec9
1 files changed, 6 insertions, 3 deletions
diff --git a/php-pear-PHP-CodeSniffer.spec b/php-pear-PHP-CodeSniffer.spec
index 18e63cf..822ad07 100644
--- a/php-pear-PHP-CodeSniffer.spec
+++ b/php-pear-PHP-CodeSniffer.spec
@@ -13,7 +13,7 @@
%global pear_name PHP_CodeSniffer
Name: php-pear-PHP-CodeSniffer
-Version: 3.2.3
+Version: 3.3.0
Release: 1%{?dist}
Summary: PHP coding standards enforcement tool
@@ -25,7 +25,7 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.4
BuildRequires: php-pear
# to run test suite
-%if 0%{?fedora} >= 28
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
%else
# remirepo:1
@@ -98,7 +98,7 @@ cd %{pear_name}-%{version}
# Version 3.2.3: Tests: 294, Assertions: 320, Skipped: 3.
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -129,6 +129,9 @@ fi
%changelog
+* Thu Jun 7 2018 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+
* Wed Feb 21 2018 Remi Collet <remi@remirepo.net> - 3.2.3-1
- Update to 3.2.3
- use phpunit7 on F28+