summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-12 15:18:38 +0100
committerRemi Collet <remi@php.net>2024-01-12 15:18:38 +0100
commit7b7b4b8dd829b1ae6a72ee3df130115273353c0e (patch)
tree0061bd8900541be9a00823339f66d9c9b90e7933
parentb4dd5d832e49eaf641edd5831895757ae4e80a77 (diff)
optimize sources retrieval
-rwxr-xr-xmakesrc.sh7
-rw-r--r--php-pear-PHP-CodeSniffer.spec1
2 files changed, 5 insertions, 3 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 1ee3ac8..06b0ee0 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,6 +1,7 @@
#!/bin/bash
NAME=$(basename $PWD)
+DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
@@ -10,11 +11,11 @@ SHORT=${COMMIT:0:7}
if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
echo Skip $NAME-$VERSION-$SHORT.tgz
else
- echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Date=$DATE\n"
echo "Cloning..."
rm -rf $PROJECT-$COMMIT
- git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
echo "Getting commit..."
pushd $PROJECT-$COMMIT
@@ -23,7 +24,7 @@ else
popd
echo "Archiving..."
- tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+ tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
echo "Cleaning..."
rm -rf $PROJECT-$COMMIT
diff --git a/php-pear-PHP-CodeSniffer.spec b/php-pear-PHP-CodeSniffer.spec
index 9bc34b0..1713f52 100644
--- a/php-pear-PHP-CodeSniffer.spec
+++ b/php-pear-PHP-CodeSniffer.spec
@@ -18,6 +18,7 @@
%global gh_commit 14f5fff1e64118595db5408e946f3a22c75807f7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_date 2024-01-10
%global gh_owner PHPCSStandards
%global gh_project PHP_CodeSniffer
# keep in old PEAR tree