summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-29 13:43:41 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-29 13:43:41 +0100
commit5ff77b9954e959fb028e711beabd6e4dbc44adc4 (patch)
tree83d6ef2d5d1835641a1b27004763747ec4331f9e
php-pear-Net-IMAP: new package
-rw-r--r--3_01.txt68
-rw-r--r--Makefile4
-rw-r--r--php-pear-Net-IMAP.spec102
3 files changed, 174 insertions, 0 deletions
diff --git a/3_01.txt b/3_01.txt
new file mode 100644
index 0000000..42536af
--- /dev/null
+++ b/3_01.txt
@@ -0,0 +1,68 @@
+--------------------------------------------------------------------
+ The PHP License, version 3.01
+Copyright (c) 1999 - 2012 The PHP Group. All rights reserved.
+--------------------------------------------------------------------
+
+Redistribution and use in source and binary forms, with or without
+modification, is permitted provided that the following conditions
+are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ 3. The name "PHP" must not be used to endorse or promote products
+ derived from this software without prior written permission. For
+ written permission, please contact group@php.net.
+
+ 4. Products derived from this software may not be called "PHP", nor
+ may "PHP" appear in their name, without prior written permission
+ from group@php.net. You may indicate that your software works in
+ conjunction with PHP by saying "Foo for PHP" instead of calling
+ it "PHP Foo" or "phpfoo"
+
+ 5. The PHP Group may publish revised and/or new versions of the
+ license from time to time. Each version will be given a
+ distinguishing version number.
+ Once covered code has been published under a particular version
+ of the license, you may always continue to use it under the terms
+ of that version. You may also choose to use such covered code
+ under the terms of any subsequent version of the license
+ published by the PHP Group. No one other than the PHP Group has
+ the right to modify the terms applicable to covered code created
+ under this License.
+
+ 6. Redistributions of any form whatsoever must retain the following
+ acknowledgment:
+ "This product includes PHP software, freely available from
+ <http://www.php.net/software/>".
+
+THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
+ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
+DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+OF THE POSSIBILITY OF SUCH DAMAGE.
+
+--------------------------------------------------------------------
+
+This software consists of voluntary contributions made by many
+individuals on behalf of the PHP Group.
+
+The PHP Group can be contacted via Email at group@php.net.
+
+For more information on the PHP Group and the PHP project,
+please see <http://www.php.net>.
+
+PHP includes the Zend Engine, freely available at
+<http://www.zend.com>.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pear-Net-IMAP.spec b/php-pear-Net-IMAP.spec
new file mode 100644
index 0000000..8475ebc
--- /dev/null
+++ b/php-pear-Net-IMAP.spec
@@ -0,0 +1,102 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+%global pear_channel pear.php.net
+%global pear_name Net_IMAP
+
+# Cannot run test suite which requires a valid IMAP account
+
+Name: php-pear-Net-IMAP
+Version: 1.1.2
+Release: 1%{?dist}
+Summary: Provides an implementation of the IMAP protocol
+
+Group: Development/Libraries
+License: PHP
+URL: http://%{pear_channel}/package/%{pear_name}
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# https://pear.php.net/bugs/19875
+Source1: http://www.php.net/license/3_01.txt
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-date
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-pear(PEAR)
+Requires: php-pear(Net_Socket) >= 1.0.8
+# Optional
+Requires: php-pear(Auth_SASL) >= 1.0.2
+
+Provides: php-pear(%{pear_name}) = %{version}
+
+
+%description
+Provides an implementation of the IMAP4Rev1 protocol using PEAR's
+Net_Socket and the optional Auth_SASL class.
+
+
+%prep
+# http://pear.php.net/bugs/19730
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cp %{SOURCE1} LICENSE
+
+cd %{pear_name}-%{version}
+# https://pear.php.net/bugs/19876
+sed -e '/README/s/role="data"/role="doc"/' \
+ -e '/docs/s/role="test"/role="doc"/' \
+ -e '/phpunit.xml/s/role="data"/role="test"/' \
+ ../package.xml >%{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Net/IMAP*
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Fri Mar 29 2013 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- initial pakage