summaryrefslogtreecommitdiffstats
path: root/php-paragonie-constant-time-encoding.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-paragonie-constant-time-encoding.spec')
-rw-r--r--php-paragonie-constant-time-encoding.spec10
1 files changed, 5 insertions, 5 deletions
diff --git a/php-paragonie-constant-time-encoding.spec b/php-paragonie-constant-time-encoding.spec
index 204a41b..9a712a6 100644
--- a/php-paragonie-constant-time-encoding.spec
+++ b/php-paragonie-constant-time-encoding.spec
@@ -35,11 +35,11 @@ BuildRequires: php(language) >= 7
BuildRequires: php-mbstring
BuildRequires: php-spl
# "phpunit/phpunit": "^6|^7",
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit7
%else
-BuildRequires: phpunit6
+BuildRequires: phpunit8
%global phpunit %{_bindir}/phpunit6
%endif
@@ -70,10 +70,10 @@ cp -pr src/* %{buildroot}%{_datadir}/php/%{composer_namespace}
%check
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php71 %{_bindir}/phpunit7" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose --bootstrap=src/autoload.php || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose --bootstrap=src/autoload.php || ret=1
fi
done
exit $ret