summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json17
-rw-r--r--php-paragonie-constant-time-encoding.spec18
2 files changed, 24 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 1d80ae0..ac78c04 100644
--- a/composer.json
+++ b/composer.json
@@ -2,7 +2,18 @@
"name": "paragonie/constant_time_encoding",
"description": "Constant-time Implementations of RFC 4648 Encoding (Base-64, Base-32, Base-16)",
"keywords": [
- "base64", "encoding", "rfc4648", "base32", "base16", "hex", "bin2hex", "hex2bin", "base64_encode", "base64_decode", "base32_encode", "base32_decode"
+ "base64",
+ "encoding",
+ "rfc4648",
+ "base32",
+ "base16",
+ "hex",
+ "bin2hex",
+ "hex2bin",
+ "base64_encode",
+ "base64_decode",
+ "base32_encode",
+ "base32_decode"
],
"license": "MIT",
"type": "library",
@@ -26,11 +37,11 @@
"source": "https://github.com/paragonie/constant_time_encoding"
},
"require": {
- "php": "^7"
+ "php": "^7|^8"
},
"require-dev": {
"phpunit/phpunit": "^6|^7",
- "vimeo/psalm": "^1"
+ "vimeo/psalm": "^1|^2|^3"
},
"autoload": {
"psr-4": {
diff --git a/php-paragonie-constant-time-encoding.spec b/php-paragonie-constant-time-encoding.spec
index 00375c3..8ab23f0 100644
--- a/php-paragonie-constant-time-encoding.spec
+++ b/php-paragonie-constant-time-encoding.spec
@@ -14,16 +14,15 @@
%global github_owner paragonie
%global github_name constant_time_encoding
-%global commit0 eccf915f45f911bfb189d1d1638d940ec6ee6e33
+%global commit0 47a1cedd2e4d52688eb8c96469c05ebc8fd28fa2
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Name: php-%{composer_vendor}-constant-time-encoding
-Version: 2.2.2
-Release: 4%{?dist}
+Version: 2.3.0
+Release: 1%{?dist}
Summary: Constant-time Implementations of RFC 4648 Encoding
-Group: System Environment/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
@@ -31,12 +30,12 @@ Source0: %{url}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
BuildArch: noarch
-# "php": "^7"
+# "php": "^7|^8"
BuildRequires: php(language) >= 7
BuildRequires: php-mbstring
BuildRequires: php-spl
# "phpunit/phpunit": "^6|^7",
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: phpunit7
%global phpunit %{_bindir}/phpunit7
%else
@@ -46,7 +45,7 @@ BuildRequires: phpunit6
BuildRequires: php-fedora-autoloader-devel
-# "php": "^7"
+# "php": "^7|^8"
Requires: php(language) >= 7
Requires: php-mbstring
Requires: php-spl
@@ -71,7 +70,7 @@ cp -pr src/* %{buildroot}%{_datadir}/php/%{composer_namespace}
%check
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose --bootstrap=src/autoload.php || ret=1
@@ -88,6 +87,9 @@ exit $ret
%license LICENSE.txt
%changelog
+* Wed Nov 06 2019 François Kooman <fkooman@tuxed.net> - 2.3.0-1
+- update to 2.3.0
+
* Thu May 03 2018 François Kooman <fkooman@tuxed.net> - 2.2.2-4
- also BuildRequire phpunit7 for future EL release