summaryrefslogtreecommitdiffstats
path: root/php-ocramius-proxy-manager.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ocramius-proxy-manager.spec')
-rw-r--r--php-ocramius-proxy-manager.spec32
1 files changed, 15 insertions, 17 deletions
diff --git a/php-ocramius-proxy-manager.spec b/php-ocramius-proxy-manager.spec
index fb172dc..623697b 100644
--- a/php-ocramius-proxy-manager.spec
+++ b/php-ocramius-proxy-manager.spec
@@ -12,17 +12,17 @@
%global github_owner Ocramius
%global github_name ProxyManager
-%global github_version 2.1.1
-%global github_commit e18ac876b2e4819c76349de8f78ccc8ef1554cd7
+%global github_version 2.2.0
+%global github_commit 81d53b2878f1d1c40ad27270e64b51798485dfc5
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor ocramius
%global composer_project proxy-manager
-# "php": "^7.1.0"
-%global php_min_ver 7.1.0
-# "zendframework/zend-code": "^3.1.0"
-%global zf_min_ver 3.1.0
+# "php": "^7.2.0"
+%global php_min_ver 7.2
+# "zendframework/zend-code": "^3.3.0"
+%global zf_min_ver 3.3
%global zf_max_ver 4
# Build using "--without tests" to disable tests
@@ -46,7 +46,6 @@ Source1: makesrc.sh
# drop dependency on ocramius/package-versions
Patch0: %{name}-rpm.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Autoloader
BuildRequires: %{_bindir}/phpab
@@ -58,18 +57,18 @@ BuildRequires: php-composer(zendframework/zend-code) >= %{zf_min_ver}
BuildRequires: php-composer(zendframework/zend-code) < %{zf_max_ver}
BuildRequires: php-composer(zendframework/zend-loader)
BuildRequires: php-composer(ocramius/generated-hydrator) >= 2
-## phpcompatinfo (computed from version 2.0.0)
+## phpcompatinfo (computed from version 2.2.0)
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
-BuildRequires: php-composer(phpunit/phpunit) >= 5.6.4
+BuildRequires: phpunit6 >= 6.4.3
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
Requires: php-composer(zendframework/zend-code) >= %{zf_min_ver}
Requires: php-composer(zendframework/zend-code) < %{zf_max_ver}
-# phpcompatinfo (computed from version 2.1.1)
+# phpcompatinfo (computed from version 2.2.0)
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -129,7 +128,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}/
@@ -144,18 +142,13 @@ require_once '%{buildroot}%{phpdir}/ProxyManager/autoload.php';
EOF
: Run tests
-%{_bindir}/phpunit --verbose
+%{_bindir}/phpunit6 --verbose
%else
: Tests skipped
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -164,6 +157,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Nov 17 2017 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- Update to 2.2.0
+- raise dependency on PHP 7.2
+- raise dependency on zend-code 3.3
+
* Thu May 4 2017 Remi Collet <remi@remirepo.net> - 2.1.1-1
- Update to 2.1.1